Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 510
  • Last Modified:

Changed RDP port wont work win2008 - hyperv environment

I have 4 Virtual servers running on a Hyper-v host.  All servers are win2008 ent edition x64.  There is a router and firewall at the front of the network and all server run static 192.168.n.n addresses. One server runs AD, DNS, DHCP.

On all servers i have static IP address and have changed each listening RDP port to 3385 (hyper-v host), 3386,3387,3388, (3389 / default port is reserved for the teminal services server).

The firewall is configured to port forward to the approriate port / Ip address and all works well except for the last server port 3388.  I cannot get that particular server to work on any port excpet the DEFAULT port 3389.

I have checked things like dual IPs wrong port forwarding.  I cant see anything that would prevent it from listening on the assigned 3388 port.  I have tesed the port from inside the firewall to eliminate the firewall as the issue.  As mentioned above it works on the default port 3389 ok.

Any help trying to figure out what could be stopping it from listening on my assigned port would be apprecaited.
0
martinmcginley
Asked:
martinmcginley
  • 2
1 Solution
 
PerarduaadastraCommented:
Hi

Try using port 3384 instead - if you still have the same problem  then it's likely to be a configuration or firewall issue rather than a peculiarity of the chosen port number.

Speaking of firewalls, have you checked whether the firewall on the affected VM is blocking the traffic? It's turned on by default, and the fact that 3389 works OK on that one but nothing else does would have me looking very carefully at its configuration before looking elsewhere, When you are configuring a number of similar and/or nearly identical computers it's very easy to think that you've done everything right on each of them and then discover that you've missed something out that you did on the others.

The fact that it's the last one in the sequence of non-standard RDP port numbers makes this more likely. Also, the fact that port 3389 still works on this VM indicates that it's not yet been told to listen on port 3388...
0
 
martinmcginleyAuthor Commented:
You were right. I had not turned off/modified the domain firewall block list on the server in question.  After I changed it all is fine. Thanks
0
 
PerarduaadastraCommented:
Glad to help.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now