SSIS validation not ending when package opened

Have encrypted SSIS package.  When opened, it hangs during validation.  Is there any way for me to interrupt or suppress validation?  I know when it's open, I can set the DelayValidation property for various tasks and flat file connection managers.  If it weren't encrypted, I could edit the DTSX file in Textpad and change all the instances of DelayValidation">0 to DelayValidation"-1.  Looking for another another workaround.
rfeldleitAsked:
Who is Participating?
 
dbaSQLConnect With a Mentor Commented:
the ValidateExternalMetadata let's you get in a little more granular than delayvalidation.  i am still researching options that are specific to the encrypted packages, but maybe take a look at this:
http://searchsqlserver.techtarget.com/tip/Open-SSIS-packages-without-validation-using-these-SQL-properties
0
 
dbaSQLCommented:
0
 
rfeldleitAuthor Commented:
I specifically said I know when the package is open, I can set DelayValidation = True.  My problem is I can't open the file because it's hanging on validation.  I was looking for a workaround.  I repeat that the package is encrypted, so I can't simply go into DTSX using a text editor and change the properties in text.
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
dbaSQLCommented:
My apologies, rfeldleit. I didn't read your inquiry thoroughly.  Let me see if I can research a little, and help you any further.
0
 
rfeldleitAuthor Commented:
i apologize for being snippy.  A little frustrated with my last couple of questions where people provide basic answers where I explicitly mention my problems run deeper.

In this case, the problem was the Oracle database which was the source of one of my data connections was down, so my package hung.  Once it came back up, the package eventually opened although with considerable delay.  I should probably get in the habit of setting DelayValidation to TRUE by default and better understand the ramifications of doing so.

I appreciate you taking the time to try to answer.  I will take a look at your thread.
0
 
dbaSQLCommented:
oh gosh, no apology necessary, rfeldleit.  I understand your frustrations, and I really should have read your inquiry more clearly.  Far beyond my own, there are some fabulous resources here within EE, I assure you.  

>>I should probably get in the habit of setting DelayValidation to TRUE by default and better understand the ramifications of doing so.

Take a look at #9:
http://www.mssqltips.com/sqlservertip/1867/sql-server-integration-services-ssis-performance-best-practices/
0
 
rfeldleitAuthor Commented:
Thought I marked this as an acceptable solution last night
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.