?
Solved

Your automatic reply settings cannot be displayed exchange 2007 outlook 2010

Posted on 2011-09-04
32
Medium Priority
?
4,091 Views
Last Modified: 2012-05-12
When trying to use Automatic Replies in Outlook 2010, all users get message "Your automatic reply settings cannot be displayed because the server is currently unavailable. Try again later."

Troubleshooting I've done so far:
•      Installed Exchange update SP4 rollup.
•      Ran Test E-mail AutoConfiguration successfully and confirmed that I could reach both OOF URL’s after authentication.
•      Ran Office repair on local machine.
•      Ensured an A record in DNS called autodiscover  is pointing to my exchange server.

NOTE: users can use the OOF when accessing email via the OWA\webmail page.

Any ideas or what other troubleshooting I can do?
0
Comment
Question by:bermudahs
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 17
  • 15
32 Comments
 
LVL 10

Expert Comment

by:scriven_j
ID: 36483112
Are you also missing Free / Busy information?

Sounds like the Availability Service is not configured properly.  These links might help:-

http://www.msexchange.org/articles_tutorials/exchange-server-2007/management-administration/configuring-outlook-2007-exchange-server-2007.html

http://technet.microsoft.com/en-us/library/ff597979(EXCHG.80).aspx
0
 
LVL 10

Expert Comment

by:scriven_j
ID: 36483123
This also might help with troubleshooting if you don't get anywhere.  Relates to Exchange 2010, but essentially the same on Exchange 2007.

http://geekswithblogs.net/BWCA/archive/2011/03/24/exchange-2010-troubleshooting-ndash-out-of-office-reply-issue.aspx
0
 
LVL 10

Expert Comment

by:scriven_j
ID: 36483125
Post back here and let us know how you get on.
0
NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

 

Author Comment

by:bermudahs
ID: 36484181
OK so I turned on logging and checked the log after I clicked on the Out of Office.
I think the issue is that the credentials are not being passed through to the exchange server.
If I go to https://servername.domain.local/ews.exchange.asmx using IE, I get prompted for my username and password and after entering these, I get through.
Here is part of the log:
2011/09/05 10:51:25.131: Sending request

2011/09/05 10:51:25.156: Request sent

2011/09/05 10:51:25.170: Response error code: 0x0

2011/09/05 10:51:25.183: HTTP status code: 500

2011/09/05 10:51:25.187: -------------------------------

2011/09/05 10:51:25.191: There is an error in request/response.
0
 
LVL 10

Expert Comment

by:scriven_j
ID: 36484628
Please could you provide some more information about your set-up.  How many Exchange servers and what roles doe they have.  How do the Outlook clients access the CAS.  Directly or through a proxy (ISA etc).  Has this ever worked?  Are you in a transition from Exchange 2003?

The information so far indicates a problem with the configuration of Exchange / IIS.  Go through the tests on here and see if they give you any additional information about what is configured incorrectly:-

http://www.testexchangeconnectivity.com/

This only runs tests from outside the network, so might not work if your clients are all internal and not using Outlook Anywhere.

If this is a new install, then have a look at these links to check things are set-up correctly:-

http://blog.chrislehr.com/2011/02/unknown-500-autodiscover-and-rpc-errors.html

http://www.msdigest.net/2011/01/exchange-2010-outlook-anywhere-not-working-and-getting-http-500-response-error/

Both relate to Exchange 2010, but essentially 2007 is the same.

If not a new install, then has it ever worked?  What has changed recently?
0
 
LVL 10

Expert Comment

by:scriven_j
ID: 36484745
Just about to sign off for the day, but have a gut feeling you're going to come and tell me you are running ISA server, if you are then check it is configured correctly:-

http://www.shudnow.net/2007/07/15/publishing-exchange-2007-autodisover-in-isa-2006/

If not then I'll respond when next online!
0
 

Author Comment

by:bermudahs
ID: 36484916
We have a single exchange server and no ISA server.  This issue has potentionally been around on this server for a few months, I'm not 100% sure when it started.  This is not a new install.
I'm thinking it has also may have something to do with the certificates?
All users use Outlook 2010 within the office to connect, but when the users are not in the office they use OWA and are able to set the out of office without any problem.
0
 
LVL 10

Expert Comment

by:scriven_j
ID: 36488223
Could be, although I would have expected you to have other problems if there were certificate issues.  Have you configured a UCC / SAN certificate and added all the different names for the Exchange server (including NETBIOS names) and assigned all the Exchange services to the certificate? (post back if you need detail)

0
 

Author Comment

by:bermudahs
ID: 36489834
Another strange thing that is occuring is that if an email is opened and I click on the senders name up in the "From" field, outlook freezes and then reboots.
0
 
LVL 10

Expert Comment

by:scriven_j
ID: 36494319
That IS strange.  Have you checked the certificates etc as previously suggested?  Senders name thing sounds like an Outlook bug, but could be caused by an underlying problem with the GAL/OAB.  I'd focus on the certificate first though. (post back if you need detail)
0
 

Author Comment

by:bermudahs
ID: 36502125
So I think there may be several issues at hand here.  If I start outlook in safe mode we don't experience any of the freezes\reboots.  We still though are unable to open the out of office, even in safe mode.
@ scriven can you elaborate on your comment about configuring a UCC / SAN certificate?
0
 
LVL 10

Expert Comment

by:scriven_j
ID: 36506584
You would have set-up a certificate for SSL.  This should be a UCC / SAN certificate.  This is a special type of certificate which allows you to have multiple names certified for the same server.

If you go to Exchange Management Shell and type:-

get-exchangecertificate | fl

Open in new window


it will show you the certificate that you are currently using.  Check that it is in date (self-certified certificates only last for a year and then have to be renewed).  Also under the certified domains section, you would expect it to list all the different aliases that relate to your exchange box.

e.g. exchange.domain.com, exchange, exchange.domain.local, autodiscover.domain.com etc etc.

These links go into more detail on this topic including renewing a self-signed certificate.

http://exchangeinbox.com/article.aspx?i=126

http://www.msexchange.org/articles_tutorials/exchange-server-2007/management-administration/managing-exchange-certificates.html

0
 

Author Comment

by:bermudahs
ID: 36512100
Certificate looks good and is valide with all the expected aliases for domain.com, domain.local, autodiscover.domain.com, servername.
0
 
LVL 10

Expert Comment

by:scriven_j
ID: 36521954
The plot thickens....

Can you run these tests and post results here please:-

Hold down CTRL + Right Click Outlook icon in system tray

Choose 'Test email autoconfiguration'

Uncheck 'Use Guessmart' and 'Secure Guessmart Authentication

Click on 'Test'

Please post the results from all three tabs here. (Results, Logs, XML)

0
 

Author Comment

by:bermudahs
ID: 36525814
Please see attachment for results.
results.docx
0
 
LVL 10

Expert Comment

by:scriven_j
ID: 36530070
OK - that all looks normal.

There must be some problem with your EWS directory, maybe security?

If I navigate to my EWS directory directly:-

https://CAS_SERVER.DOMAIN.local/ews/exchange.asmx

It just goes straight in using the credentials I am logged in with, but you said that yours asks for a username and password.  This is the only difference I am seeing in my working configuration and yours.

Can you check that the Web Services is set up correctly in IIS.

From EMS type

Get-WebServicesVirtualDirectory

Open in new window


Check it is set to https://CAS_SERVER.DOMAIN.local/ews/exchange.asmx

If not, the command is:-

Set-WebServicesVirtualDirectory <CAS2010>\EWS* -ExternalURL https://CAS_SERVER.DOMAIN.local/ews/exchange.asmx

Open in new window


You can also check the security in IIS.

Open IIS, CAS_SERVER, Sites, Desfault Website, EWS and click on Edit Permissions in the Actions pane.

Go to the security tab and check that Authenticated Users have Read permissions.
0
 
LVL 10

Expert Comment

by:scriven_j
ID: 36530108
Second code snippet should read <CAS2007> - the name of your server, basically (sorry - I am on 2010 and so keep giving you 2010 references!)

Also in IIS, from the EWS folder, double click on Authentication.

Should have Anonymous and Windows authentication enabled.
0
 

Author Comment

by:bermudahs
ID: 36530416
OK so I did the first step and confirmed that that the InternalUrl is listed as https://SERVERNAME.DOMAIN.local/EWS/Exchange.asmx.
I checked and confirmed that Authenticated Users have Read permissions.
I then went to check the Authentication and it was set correctly.  Just for the heck of it, I decided to retype the password and after doing so, now when I go to https://SERVERNAME.DOMAIN.local/EWS/Exchange.asmx I am no longer prompted for a username\password.  I then closed my outlook and relaunched it, but I still unable to open out of office.
I think we are making progress.....
0
 

Author Comment

by:bermudahs
ID: 36530463
OK take that back...it worked a couple times, but now i'm getting an HTTP 403 Forbidden - The website declined to show this webpage
0
 

Author Comment

by:bermudahs
ID: 36530510
Strange - may be a timing issue or something as it seems very intermitent that sometimes I can access the page and other times I can't.  I've now accessed the page after unchecking "enable anonymous access"?
0
 

Author Comment

by:bermudahs
ID: 36530725
DISREGARD WHAT I STATED ABOVE
I think I see what the problem is - when enable anonymous access is UNCHECKED and I go to "https://server.domain.local/ews/exchange.asmx" I get prompted for a username\password.  When the popup box appears and I enter domain\administrator and the password it goes through without any problems.  But if the enable anonymous access is CHECKED and I have entered the same username as domain\administrator and the same password, when I go to the "https://servername.domain.local/ews/exchange.asmx", I don't get prompted, but I now get "The website declined to show this webpage - http 403 forbidden"
0
 
LVL 10

Expert Comment

by:scriven_j
ID: 36530842
Is Windows Authentication enabled as well? (both need to be).

Might be worth a reboot once you have enabled them both. (or at the very least an IISRESET and restart System Attendant) - (both Exchange and IIS can be funny like that)
0
 

Author Comment

by:bermudahs
ID: 36530859
Yes both are enabled.  I've attached a screenshot.
9-13-2011-1-50-51-PM.png
0
 

Author Comment

by:bermudahs
ID: 36531570
I found this article which is exactly what's happening in my situation. http://social.technet.microsoft.com/forums/en-US/exchangesvrclients/thread/7dfdbc80-8a65-447a-be38-3f4ec5379927/#page:2
Maybe it has something to do with my .NET or I'm needing to install an update or uninstall an update.
0
 
LVL 10

Accepted Solution

by:
scriven_j earned 2000 total points
ID: 36531783
Looks from your screenshot like IIS6 (Windows 2003) - I had assumed 2008.

Turn off Basic Authentication.

Use the IUSER_Servername account for anonymous access, not the admin account.

http://support.microsoft.com/kb/324274

The anonymous access will always get tried first and I think this is the problem.

0
 

Author Comment

by:bermudahs
ID: 36531886
I did notice that other sites such as Autodiscover and owa are using that same account.
Problem is that I don't know the password for that account (i've inheritied this system from another individual)
I should also note that when I run test-outlookwebservices that I get an error.  I've attached the screenshot.
9-13-2011-4-10-14-PM.png
0
 

Author Comment

by:bermudahs
ID: 36531906
CORRECTION: the other sites are not using anonymous access as it is unchecked for all of them and they are using "intergrated windows authentication" and "basic authentication"
0
 
LVL 10

Expert Comment

by:scriven_j
ID: 36535159
Do you mean the IUSER account password?  You shouldn't need that.  It's built into IIS.

I would remove Basic Authentication, run IISRESET, then add basic authentication again, add IISRESET and hopefully it'll add that user in automatically.
0
 
LVL 10

Expert Comment

by:scriven_j
ID: 36535874
If that doesn't work, then you can find out the password using the IIS Resource Kit

http://blog.rafelo.com/2009/01/retrieve-iusr-anonymous-password-using.html
0
 

Author Comment

by:bermudahs
ID: 36535901
GOOD NEWS: everything is working now!  I uninstalled a hotfix for .NET and ran windows update and it installed the latest patch for .NET and this seems to have resolved all issues.
I appreciate your help!
0
 
LVL 10

Expert Comment

by:scriven_j
ID: 36535921
That's really good news.  Can you post details of the hotfix to help others that might have the same problems?

Thanks!
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You need to know the location of the Office templates folder, so that when you create new templates, they are saved to that location, and thus are available for selection when creating new documents.  The steps to find the Templates folder path are …
New style of hardware planning for Microsoft Exchange server.
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
Suggested Courses
Course of the Month10 days, 6 hours left to enroll

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question