Solved

Asterisk slow to load and run if DNS server is not available

Posted on 2011-09-04
11
1,233 Views
Last Modified: 2012-05-12
I am running a couple of asterisk servers.  They are set to use a local DNS server - which forwards unknown domains to an external DNS.  I am seeing the following issues with Asterisk and DNS and any help is appreciated.

1. If the external resolution DNS is not available, when I try to load the dialplan, it takes a very long time.  you can see it loading 1 line at a time every few seconds.

2. If the local DNS server is down for any reason even after the asterisk load, it starts acting slow and erratic.

Is this an Asterisk issue or a CentOS issue.  And what can I do to avoid these slowdowns if the DNS's are down.
0
Comment
Question by:thetechgroup
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 3
11 Comments
 
LVL 36

Expert Comment

by:grblades
ID: 36483095
I would suggest you run a caching only nameserver on the asterisk box. You can set a forwarder to your regular DNS server aswell if you wish.
0
 

Author Comment

by:thetechgroup
ID: 36483562
Would you then point the resolv to the local DNS instead of the general DNS?  Seems like that could work.  Do you have any idea what it is looking for that causes it to slow down considerably?
0
 
LVL 36

Expert Comment

by:grblades
ID: 36483573
Yes you would point resolv.conf to the loopback address 127.0.0.1.
I am not sure whats causing it to slow down. You could run tcpdump on port 53 so it shows you all the dns requests.
0
Containers & Docker to Create a Powerful Team

Containers are an incredibly powerful technology that can provide you and/or your engineering team with huge productivity gains. Using containers, you can deploy, back up, replicate, and move apps and their dependencies quickly and easily.

 

Author Comment

by:thetechgroup
ID: 36488067
Sounds like a good idea.  Let me try and report back.
0
 
LVL 25

Expert Comment

by:Ron Malmstead
ID: 36497447
You could try changing trunk host registrations, to IP address rather than Hostname...then it won't need to resolve them.

See this article and tell me if you think it might apply to your situation.
http://www.voip-info.org/wiki/view/Asterisk+SIP+srvlookup
0
 
LVL 25

Expert Comment

by:Ron Malmstead
ID: 36497481
...also, how about these options in sip.conf...

http://www.asteriskdocs.org/html/apas02.html

externhost
externhost takes a fully qualified domain name as its argument. If Asterisk is behind NAT, the SIP header will normally use the private IP address assigned to the server. If you set this option, Asterisk will perform periodic DNS lookups on the hostname and replace the private IP address with the IP address returned from the DNS lookup.

    externhost=my.hostname.tld

 Warning
The use of externhost is not recommended in production systems, because if the IP address of the server changes, the wrong IP address will be set in the SIP headers until the next lookup is performed. The use of externip is recommended instead.
 

externip
externip takes an IP address as its argument. If Asterisk is behind NAT, the SIP header will normally use the private IP address assigned to the server. The remote server will not know how to route back to this address; thus, it must be replaced with a valid, routable address.

    externip=216.239.39.104
0
 

Author Comment

by:thetechgroup
ID: 36498164
Actually, all our trunk registrations are IP based and we do not use externip or externhost.  The production PBX's do not reside behind a NAT.  Is it possibly not an Asterisk issue, but a LINUX requirement to have a valid and live DNS active at all times?
0
 
LVL 25

Expert Comment

by:Ron Malmstead
ID: 36498814
Have you checked /var/log/asterisk/messages   for any errors?

Or /var/log/messages for system errors?
0
 

Author Comment

by:thetechgroup
ID: 36584681
I still have not had a chance to install bind on the asterisk boxes yet.  Other issues came ahead, but this is still a modification we would like to make. What is the best way to configure bind as a caching server?
0
 
LVL 36

Accepted Solution

by:
grblades earned 250 total points
ID: 36585469
Depends on the distribution. If you are running Centos/Redhat then there is a package called caching-nameserver or something similarly named which you just install and set to start automatically.
0
 

Author Closing Comment

by:thetechgroup
ID: 36587874
Thanks.  That makes perfect sense.
0

Featured Post

IoT Devices - Fast, Cheap or Secure…Pick Two

The IoT market is growing at a rapid pace and manufacturers are under pressure to quickly provide new products. Can you be sure that your devices do what they're supposed to do, while still being secure?

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Ever wanted to query Cisco Call Manager CDR records from MS SQL Server? Here's how! CUCM can be configured to upload a CDR file to a given FTP server every minute. This article will show you how to set this up, schedule the import of this data an…
Resolve DNS query failed errors for Exchange
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

630 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question