How to prevent run as pop-up on a Terminal Server

I have a Terminal Server and randomly find when users login they get a run as pop up prompt appearing. Using process explorer I have worked out which .exe causes the pop up and want to allow it to run regardless of who logs in. What is the best way to ensure a .exe is allowed to run?
CodeBlueEngineersAsked:
Who is Participating?
 
Sushant GulatiConnect With a Mentor ConsultantCommented:
If the support don't know what their application do and how it has been developed then I personally won't allow this application to be running? What happens if we restrict and block this pop up? Does it show an impact in anyway in the working of an application?

Can you test this? Does it call any activeX or something? Does this app` have to do something with Web World?

Good Luck..!!
~SG~
0
 
Radhakrishnan RSenior Technical LeadCommented:
Try disable messenger service and messaging queue service and check whether still you are getting the popup
0
 
CodeBlueEngineersAuthor Commented:
Thanks but I know the popup is related to a specific application I just need to know how to ensure it will always be allowed to run - it runs on each logon but only randomly do users get a run as popup.
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Radhakrishnan RSenior Technical LeadCommented:
Try add in Windows Firewall as exception, Also you can add this as exception on your AV server if available.
0
 
Sushant GulatiConsultantCommented:
And give the path in the DEP of that .exe application as an exception and see if that works.

Good Luck..!!
~SG~
0
 
CodeBlueEngineersAuthor Commented:
Windows firewall is not enabled. I have added it to DEP exceptions and will monitor to see if it resolves the problem. Thanks
0
 
Sushant GulatiConsultantCommented:
Any words on this? What have you monitored so far?

Waiting on the results..!!!

~SG~
0
 
CodeBlueEngineersAuthor Commented:
I've tried adding it to the DEP exception list but just heard from a user yesterday that they still get the run as prompt. Like I say it's random so sometimes happens every couple of days or sometimes about once a week. Still looking for a resolution....

thanks
0
 
Sushant GulatiConsultantCommented:
What this .exe does? Does it call any wizard and install something or it just runs to add some ActiveX or something?

Other than this, you can remove it from the startup and call this using a batch file and make that batch as the users login script. Test with one user first, call up the .exe in the script like in the notepad  start "c:\windows\system32\filename.exe" and see if it goes through. But you would need to restrict it to prompt in the TS Session.

See if that works.

~SG~
0
 
CodeBlueEngineersAuthor Commented:
I did ask the guys who support the relevant application what the .exe does and they claimed they didn't know. Not very helpful :-\

The .exe isn't specified in startup anywhere which is why I think it is only randomly trying to run - seems some condition occasionally occurs where this .exe is called by another program?

I suppose I could try and force the .exe to run as an admin on startup I just wanted to avoid doing that since we don't know exactly what it does.
0
 
CodeBlueEngineersAuthor Commented:
Thanks - I will try restricting the .exe and test
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.