Solved

why msmq create "LOCK" queues ?

Posted on 2011-09-05
8
611 Views
Last Modified: 2012-05-12
HI All,

I have no idea why MSMQ create a "Lock Queue" and store my queue messages ? am passing message inside the same machine its not passing or calling remote.

So i don't have a clue why its create Lock Queue.

Any idea plase  ?
0
Comment
Question by:Sha1395
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
8 Comments
 
LVL 25

Expert Comment

by:apeter
ID: 36485879
are you sending your MSMQ messages from your machine to another machine ? if yes and if the remote is not reachable then it will be stored in your local queue. And when the remote machine is queue is available it will then send the messages. Hope you have sufficient access to those queues.
0
 
LVL 18

Expert Comment

by:dj_alik
ID: 36486343
0
 

Author Comment

by:Sha1395
ID: 36486539
apeter :answer for your question is "NO". am not sending message to remote.

I have a feeling more like some concurrency problem ?

0
Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

 
LVL 25

Expert Comment

by:apeter
ID: 36491488
Then you are sending message to the same system ?
0
 

Author Comment

by:Sha1395
ID: 36492816
Yes am sending message to the same system
0
 
LVL 25

Accepted Solution

by:
apeter earned 500 total points
ID: 36498660
Try below and try sending msmq again


1.In Computer Management, right-click Message Queuing and choose Properties
 2.Go to the Server Security tab
 3.Uncheck "Enable hardened MSMQ mode to secure this computer on the Internet
0
 

Author Comment

by:Sha1395
ID: 36500440
3.Uncheck "Enable hardened MSMQ mode to secure this computer on the Internet

Its already unchecked. In the ServerSecurity tab only checked in "Disable un-authenticated RPC calls. (i think that is default).
0
 

Author Closing Comment

by:Sha1395
ID: 37800495
I solved the problem by myself but expert comment is helpful to understand some new way to think about it
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Extention Methods in C# 3.0 by Ivo Stoykov C# 3.0 offers extension methods. They allow extending existing classes without changing the class's source code or relying on inheritance. These are static methods invoked as instance method. This…
Introduction Hi all and welcome to my first article on Experts Exchange. A while ago, someone asked me if i could do some tutorials on object oriented programming. I decided to do them on C#. Now you may ask me, why's that? Well, one of the re…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question