Solved

Magento Role Resources not saving

Posted on 2011-09-05
8
1,034 Views
Last Modified: 2012-05-12
I have a new install of the Magento community edition (1.6) on a Mac PHP 5.3 installation. I am unable to get it to save Role Resources.

When I go to the Admin panel, then System->Web Services->Roles, and change to All (or choose anything custom) and click Save Role, it will say it has saved. However, going back into the settings shows nothing was actually saved. Occassionally a duplicate role will be created as well.

I have just wiped everything clean, dropped the magento database and set everything back up from scratch and it doesn't make any difference. Any ideas?
0
Comment
Question by:ktwdallas
  • 5
  • 2
8 Comments
 
LVL 13

Expert Comment

by:LinuxGuru
ID: 36486412
Hi,

It seems to be an issue with Magento. Could you please refer the following url?

http://www.magentocommerce.com/boards/viewthread/2556/
0
 

Author Comment

by:ktwdallas
ID: 36488065
I looked at that thread. Unfortunately they list it as "fixed" as of 1.3, but I'm on 1.6 and still have the issue.
0
 
LVL 12

Expert Comment

by:miked2004
ID: 36488598
Enable Logging and see if anything is logged. There may be an error thrown, that will show up in the logs. Report back what you find.
0
 

Author Comment

by:ktwdallas
ID: 36491410
I've had logging turned on under Developer->Log Settings for a while, it's not generating anything for this issue.
0
Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 

Author Comment

by:ktwdallas
ID: 36491418
0
 
LVL 12

Expert Comment

by:miked2004
ID: 36491452
Do you have any add-on modules installed?
If so I would try disabling them, then see if this issue still exists. To disable edit the file for the module in /app/etc/modules/moduleFile.xml


Then you should see a line like
<active>true</active>

Open in new window


change it to
<active>false</active>

Open in new window


Clear/disable cache and try saving the permissions again.
0
 

Accepted Solution

by:
ktwdallas earned 0 total points
ID: 36497692
It appears that part of the issue is they've renamed the columns in the api_rule table and made "permissions" and "privileges" now "api_permissions" and "api_privileges". But this renaming was apparently incomplete since the web page doesn't pay attention to those columns. Manually renaming the columns back makes the web page work properly, but I haven't tested the actual effect on the operation of Magento.
0
 

Author Closing Comment

by:ktwdallas
ID: 37923279
Confirmed in 1.6
0

Featured Post

Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It is possible to boost certain documents at query time in Solr. Query time boosting can be a powerful resource for finding the most relevant and "best" content. Of course the more information you index, the more fields you will be able to use for y…
Are you using email marketing software? If not, you're missing out on effortless marketing and the reaching of desired conversion rates through email marketing software.
Explain concepts important to validation of email addresses with regular expressions. Applies to most languages/tools that uses regular expressions. Consider email address RFCs: Look at HTML5 form input element (with type=email) regex pattern: T…
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now