Solved

Sharing folders using user groups in Windows 2008 server.

Posted on 2011-09-05
9
302 Views
Last Modified: 2012-05-12
Hi,

I am trying to share folders using user groups in the AD on Windows 2008 server. On Windows 2003 server, one would normaly follow the following procedure:

1) Create your user group and assign users to this group in the Windows AD
2) Create the folder, and share it to "domain Users" with full permisions.
3) Go to the NTFS permisions of this folder, and assign it to the group that you have created in the AD, and give it the appropriate permissions.

Bob's your uncle, it then works. But following the above on a Windows 2008 server has diffrent results, for example:

1) I create my User Group in AD, and assign my users to it
2) I create a folder and share it to the domain users
3) I then go to the NTFS permisions of this folder, and assign it to the group that you have created in the AD, and give it the appropriate permissions
                                                  Problem is:
Regardless to the user groups I assign in the NTFS security, everyone still has access to the folder. Nothing I do in the NTFS security on Windows 2008 server, when I add users or remove users from the group I added to the folder changes. The only thing I can do to change "something" is on the share, when I reduce the access level on the domain user from "Co-Ownder" to contributer, or lower. A typlical share that I create on Windows server 2008 lookd like this:

Share permisions:
Administrator (owner)
Domain Users (Co-Owner)

NTFS Permisions (Management)   <-- a group I created in the AD, there are 2 users that belong to this group

Regardles of the above config, everyone still has access to this folder. In Windows 2003, this normaly works great without fail.

Please tell me what I am missing....

Thank-you!
0
Comment
Question by:wimpie_asg
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
  • +1
9 Comments
 
LVL 57

Expert Comment

by:Mike Kline
ID: 36485291
There is nothing else listed in the NTFS permissions other than than the one group?  Could you post a screen shot if possible.  

Thanks

Mike
0
 

Expert Comment

by:Mabr0
ID: 36485358
Hi wimpie_asg,

I would like to see please the snap shot for  Managment Group in  2003 and 2008 at least to see the configuration of that Group.
0
 
LVL 3

Author Comment

by:wimpie_asg
ID: 36485374
Apolegies for the amature picture(s), I hope you can make out what it is all about.

You might have to download the picture if it is to small on the web browser, it would be big in Paint.
Sharing-Permissions.jpg
0
Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 3

Author Comment

by:wimpie_asg
ID: 36485428
My apolegies - on this screen shot I marked the User group - I did not indicate the User Group in the previous image capture.
Sharing-Permissions.jpg
0
 
LVL 3

Author Comment

by:wimpie_asg
ID: 36486728
Anyone please - this is anoying issue to have since it works great on Windows 2003, but not Windows 2008.
0
 

Expert Comment

by:TecnicalAdmin
ID: 36488266
If your problem is that all users mustn't read the content of the shared folder, i suggest you to use the advanced sharing instead of simple sharing.
With advanced sharing
Otherwise if you problem is that all users con read the content but mustn't modify it, i suggest you to remove domain users from the NTFS Permission or change the permission from Modify to Read Only.

:)
0
 
LVL 3

Author Comment

by:wimpie_asg
ID: 36488918
Hi,

Thank-you.

The problem I have is, I created a group in AD, and added two users to it. I then add this group in the NTFS file permisions, and give it the appropriate access level. Even though I add domain users to the directory share, and add this group, everyone still has access to it. I want only the group with the two users to have access to it. This works 100% in Windows server 2003, but I cant do it the same in Windows 2008 server.

I only want the user group I added to the NTFS share to have access, no one else.
0
 
LVL 57

Accepted Solution

by:
Mike Kline earned 500 total points
ID: 36488950
in your screenshot it looks like Users have "read and execute" rights to the R and J folder.


Thanks


Mike
0
 

Expert Comment

by:Mabr0
ID: 36498560
Hi,

Yes, I think you have to remove Inheritable permission from the object.

Thnks
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Had a business requirement to store the mobile number in an environmental variable. This is just a quick article on how this was done.
For anyone that has accidentally used newSID with Server 2008 R2 (like I did) and hasn't been able to get the server running again because you were unlucky (as I was) and had no backups - I was able to get things working by doing a Registry Hive rec…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles from a Windows Server 2008 domain controller to a Windows Server 2012 domain controlle…
Are you ready to implement Active Directory best practices without reading 300+ pages? You're in luck. In this webinar hosted by Skyport Systems, you gain insight into Microsoft's latest comprehensive guide, with tips on the best and easiest way…
Suggested Courses

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question