OWA not working

sharris_glascol
sharris_glascol used Ask the Experts™
on
We had an router go out over the weekend which caused us to mess up our exchange server.  I have email coming back into the office now.  But we are unable to access the email via OWA.  I can't even get it to work on the exchange server via the local host.  Any ideas where to start to track this down?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
First of all make sure that the exchange services are running, and IIS as well.

what do you get when you try to access https://servername/owa locally ?

Author

Commented:
First I am getting there is a problem with this website security certificate.  So when I continue to this website.  Then I get a 404 not found.

Author

Commented:
and yes all services are running..
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

any errors related to OWA on event viewer ? under applications nd services logs.

Author

Commented:
Not sure if this ties to OWA but getting The browser service has failed to retrieve the backup list too many times on transport \Device\NetBT_Tcpip_{B74A99BB-E4A3-420B-8B47-691E59B9E648}. The backup browser is stopping.

Author

Commented:
also this:

The browser service was unable to retrieve a list of servers from the browser master \\GCSRV1 on the network \Device\NetBT_Tcpip_{B74A99BB-E4A3-420B-8B47-691E59B9E648}.
 
 Browser master: \\GCSRV1
 Network: \Device\NetBT_Tcpip_{B74A99BB-E4A3-420B-8B47-691E59B9E648}
 
 This event may be caused by a temporary loss of network connectivity. If this message appears again, verify that the server is still connected to the network. The return code is in the Data text box.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Commented:
NOt to step on any toes, but have you tried restarted IIS? Are you certain it's running as it should be? I know you say it is (running) but I've had issues with it needing restarted.

I'd begin there and hopefully we can continue tracking this down. I've found IIS to not be the most bulletproof of services...

Author

Commented:
Yes the service is running, is there some instructions out there to re-setup IIS and OWA?

Commented:
To reset IIS, go to Start, All Programs, Accessories, right-click Command Prompt, you will need to select Run as administrator, type "iisreset" and press ENTER

That should restart the service for you. Please let me know if this helps.

Author

Commented:
I have restarted the services by going to services.msc does that do the same thing?  I geuss  what I am looking for is how to reload IIS and OWA and make sure the setting are configured properly.

Author

Commented:
What happens if the security certificate is corrupt?
what do you mean by security certificate is corrupt?

Author

Commented:
Well when I goto www.glascol.com/mail it is giving me a certificate error message and we have the certificate so this shouldn't happen.  Everything was working fine until last week we had a network issue.
Your certificate is not correct..

Please open local computer certificates store MMC, and look for your correct certificcate, does it exist there ? if so, please use :

Get-ExchangeCertificate <thumbprint> | New-ExchangeCertificate -Services SMTP,POP,IMAP
then,
Enable-ExchangeCertificate <thumbprint>

thumbprint can be viewed on certificate properties ( MMC)

Author

Commented:
Ok I got it fixed..  the router port wasn't forwarding to correct location.  But here is another issue my phone syncs which is an iphone but an android phone is not syncing because of a certificate error.  Does there need to be a certificate on the router?
Good to hear that you get sorted. but I asked to browse the server locally, not through the router.

Author

Commented:
So now I figured out that it works when connected to the wifi here at office but not outside.....????

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial