Solved

Configure IFD for crm 2011

Posted on 2011-09-06
2
1,086 Views
Last Modified: 2012-08-21
Hello, we have a Microsoft CRM 2011 server that we want to configure for IFD, we used some guides like this one: http://www.interactivewebs.com/blog/index.php/server-tips/microsoft-crm-2011-how-to-configure-ifd-hosted-setup/
and it worked great but at the end the users need to enter a port when they want to access the CRM from outside (for example https://myOrg.MySite.com:444).

We tried to switch the ports so that the ADFS will be on another port and the CRM will be on 443 and it didn't worked, we tried to add another IP for the server and use 1 for the CRM and 1 for the ADFS and got stuck with an error: "each identifier for a relying party trust must be unique across all relying party trusts in AD FS 2.0"

My question is there a way to Configure IFD for CRM 2011 so that the user can enter the URL without the port?

Thanks in advance for the response
0
Comment
Question by:haim_isr
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 27

Accepted Solution

by:
Chinmay Patel earned 500 total points
ID: 36928829
Hi halim_isr,

Yes it is possible to achieve just make sure you install on different servers and use 443 as a default port.

Regards,
Chinmay.
0
 
LVL 10

Expert Comment

by:WayneATaylor
ID: 37050333
Yes you can configure it for a different port, but my guess will be that you are using the ADFS2 server on the same server and that the ADFS2 server is usign port 443 for it's standard authentication.  That is the standard config, so you will need to change that port first away from 443, but then you will have to adjust all of the ADFS2 settings with the correct endpoint adresses etc.

Unless you know ADFS2 and IFD deployments inside out, you could fine yourself getting a bit stuck!

One simple fix would be to put a simple html redirect command on the index.aspx etc in the website that is on port 443 that redirects to the correct address with the :444

So user types in   http://server in and the default page for that server just has a redirect to http://server:444

Wayne

0

Featured Post

Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

On Sep 22nd 2014 Microsoft released Update Rollup 1 for Microsoft Dynamics CRM 2013 Service Pack 1 and back in July Update Rollup 3 was released.  So we now have:   Update Rollup 1Update Rollup 2Update Rollup 3Service Pack 1Update Rollup 1 for S…
Having trouble getting your hands on Dynamics 365 Field Service or Project Service trial? Worry No More!!!
Email security requires an ever evolving service that stays up to date with counter-evolving threats. The Email Laundry perform Research and Development to ensure their email security service evolves faster than cyber criminals. We apply our Threat…
The Email Laundry PDF encryption service allows companies to send confidential encrypted  emails to anybody. The PDF document can also contain attachments that are embedded in the encrypted PDF. The password is randomly generated by The Email Laundr…

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question