Solved

SSIS with Execute Process task

Posted on 2011-09-06
9
2,266 Views
Last Modified: 2013-11-10
I am running  a package that has  different kind of data flow tasks in it. I have execute process task control flow item. That executes an exe file.  Now when I run this package manually every thing works fine. But if I run this package using a job it gives me an error. Except this execute process task every thing else in this package run  when I run this package from sql job. What could be the reason for the failure of this particular task?

Also please note that,I have given a correct UNC path.
0
Comment
Question by:naren5star
  • 3
  • 3
  • 2
  • +1
9 Comments
 
LVL 8

Expert Comment

by:stalhw
ID: 36489303
what error is it giving to you?
0
 

Author Comment

by:naren5star
ID: 36489486
Executed as user: MPFA\Cognizant. Microsoft (R) SQL Server Execute Package Utility  Version 10.50.1600.1 for 64-bit  Copyright (C) Microsoft Corporation 2010. All rights reserved.    Started:  10:28:23 AM  Error: 2011-09-06 10:29:07.23     Code: 0xC0029151     Source: Execute Process Task Execute Process Task     Description: In Executing "\\mfa-srv-ab\d$\SSIS Sample\AutoEmailFax.exe" "" at "", The process exit code was "-532459699" while the expected was "0".  End Error  DTExec: The package execution returned DTSER_FAILURE (1).  Started:  10:28:23 AM  Finished: 10:29:07 AM  Elapsed:  43.992 seconds.  The package execution failed.  The step failed.
0
 
LVL 8

Expert Comment

by:stalhw
ID: 36489604
looks like a permission issue....
- Does the user running the job have the right to that package?
- did you setup the 'WorkingDirectory' for that Execute process task?
0
 

Author Comment

by:naren5star
ID: 36489655
Event I felt the same.I don't know how to check whether all required permissions are there?
(i.e.) How do I ensure that user running the job have all the sufficient rights?What are all the rights that a usee need to possess in order to run ?

I don't know,what you are referring to working directory for that Execute Process Task?Is that a property of an execute process task?If so, what value do i need to set that warking directory to?

0
Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 
LVL 8

Expert Comment

by:stalhw
ID: 36490136
yeah it's a property, and should probably be the directory where the exe is...

Also, did you try to delete that package and build a new one?
It seems sometimes SSIS packages fail when there was changes to DB (backup/restore, login changes, etc)...

Sorry I can't really help you more, I'm not an expert with SSIS problems...
0
 
LVL 21

Accepted Solution

by:
Jason Yousef, MS earned 250 total points
ID: 36490586
Hi,

Looks like it's a permission issue as stalhw mentioned earlier, make sure the execution account that the SQL agent job is using has permission to run access the database.

That's a common problem, just check the SQL AGENT service account and make sure it has access.

http://msdn.microsoft.com/en-us/library/dd440760%28v=sql.100%29.aspx

Regards,
Jason

0
 
LVL 21

Expert Comment

by:Alpesh Patel
ID: 36493750
Please give proper permissions to Access that folder as well as executing permission of EXE to SQL Agent user.
0
 

Author Comment

by:naren5star
ID: 36500196
Thanks to all ..Especially many  thanks to Jason for the link...
0
 
LVL 21

Expert Comment

by:Jason Yousef, MS
ID: 36502319
You're welcome, believe me all of us doing that mistake, we use an admin or SA account to devlop, then when we deploy we get permission denied!!

but always try to use package configurations to get out of that mistake.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Nowadays, some of developer are too much worried about data. Who is using data, who is updating it etc. etc. Because, data is more costlier in term of money and information. So security of data is focusing concern in days. Lets' understand the Au…
Why is this different from all of the other step by step guides?  Because I make a living as a DBA and not as a writer and I lived through this experience. Defining the name: When I talk to people they say different names on this subject stuff l…
Via a live example, show how to set up a backup for SQL Server using a Maintenance Plan and how to schedule the job into SQL Server Agent.
Viewers will learn how to use the SELECT statement in SQL to return specific rows and columns, with various degrees of sorting and limits in place.

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now