Exchange 2010 AutoDiscover

I am having an issue with Autodiscover in Exchange 2010.  I've gone through all of the settings and they all seem to be ok.  I've recreated the Autodiscover virtual directory in IIS7 and it still isn't working.  When I do a test email autoconfiguration from inside the domain I get the attached message.  Anyone know what needs to be done?  I have updated our external DNS with a record for autodiscover.  When I go to I get the second attachment. AutodiscoverErrorInside..docx
Who is Participating?
MHCITConnect With a Mentor Author Commented:
This was being caused by our external DNS provider.  They didn't know how to set up a SRV record in their system.  We are currently looking for a new external DNS provider.
setasoujiroConnect With a Mentor Commented:
Did you create the "" record on both your external DNS as your domain DNS?
if not, try that and do the test again.

also you can use :
to see if all is well on the outside
Shreedhar EtteConnect With a Mentor Commented:
- To resolve this issue you need to set the Client Certificates setting to "Ignore" under the Autodiscover virtual directory in IIS manager.

WEBINAR: GDPR Implemented - Tips & Lessons Learned

Join the WatchGuard team on Thursday, March 29th as we recount some valuable lessons learned in weighing the needs of a business against the new regulatory environment, look ahead at the two months left before implementation, and help you understand the steps you can take today!

MHCITAuthor Commented:
I put in the _autodiscover entry into our external DNS ( and our internal but I'm not sure if they are set up correctly.  Is there something somewhere that I can compare it to?
_autodiscover what do you mean by this? i assume an srv record...?
but you should have an A record both in and external pointing to your server :

click admin. tools-->dns-->click your "PBLIC" zone (not the .local) and check if there s an A record for
if not make one pointing to your local IP

and the external dns should have one, poiting to your EXTERNAL IP

refer to this:
Suliman Abu KharroubIT Consultant Commented:
when testing your IP address as attached. port 443 is blocked.

Please make sure that you have forward/publish that port in you firewall to exchange server.
MHCITAuthor Commented:
It was a mixture of fixes that finally fixed it.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.