Solved

Reading session content issue

Posted on 2011-09-06
6
144 Views
Last Modified: 2012-05-12
I have a strange issue here. I have a web application where people login and I store their user id in the session. There is a third part application that starts a page on the web application every time the agent gets a phone call. In most cases, the page started from the third party app can read the session and extracts the user id. I have three computers where that does not happen, when I try to read it I get null.

Any ideas why this works on most computers and not on these three?

Thanks
0
Comment
Question by:htabbach
  • 3
  • 3
6 Comments
 
LVL 17

Expert Comment

by:Carlos Villegas
Comment Utility
Hello, well, I dont have very clear how works your application, but may be the problem is related to cookies (if a browser is involved), you must be aware that session in asp, aspnet by default it requires a browser that has cookies enabled, otherwise it can't keep the track of the user session on the web server.
0
 

Author Comment

by:htabbach
Comment Utility
Thanks for the response, the cookies are enabled because the session cookie is created, I know that for a fact. The issue is a page launched from a third party cannot access the cookie on these three machines. It works on all other machines.
0
 

Author Comment

by:htabbach
Comment Utility
One thing I found out is the issue is specific to the windows profile, if I login under my account on one of these machines it works fine. If the user logs in, it does not work.
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 17

Expert Comment

by:Carlos Villegas
Comment Utility
mmm, ok, provide me some information:
- Windows version
- Internet Explorer version
- The users are in the Administrators group?
- The default browser is Internet Explorer? or you have another installed?
0
 

Author Comment

by:htabbach
Comment Utility
windows XP Pro
IE8
No but it did not matter when I added them to the Administrators group
The default is IE, they had Chrome on and I removed it thinking it may be the problem
0
 
LVL 17

Accepted Solution

by:
Carlos Villegas earned 500 total points
Comment Utility
Please check your Internet Options:
 Internet Options
These are the default settings, are the same in the 3 PCs?
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

This article explains how to create and use a custom WaterMark textbox class.  The custom WaterMark textbox class allows you to set the WaterMark Background Color and WaterMark text at design time.   IMAGE OF WATERMARKS STEPS Create VB …
The ECB site provides FX rates for major currencies since its inception in 1999 in the form of an XML feed. The files have the following format (reducted for brevity) (CODE) There are three files available HERE (http://www.ecb.europa.eu/stats/exch…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now