• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 154
  • Last Modified:

Reading session content issue

I have a strange issue here. I have a web application where people login and I store their user id in the session. There is a third part application that starts a page on the web application every time the agent gets a phone call. In most cases, the page started from the third party app can read the session and extracts the user id. I have three computers where that does not happen, when I try to read it I get null.

Any ideas why this works on most computers and not on these three?

Thanks
0
htabbach
Asked:
htabbach
  • 3
  • 3
1 Solution
 
Carlos VillegasFull Stack .NET DeveloperCommented:
Hello, well, I dont have very clear how works your application, but may be the problem is related to cookies (if a browser is involved), you must be aware that session in asp, aspnet by default it requires a browser that has cookies enabled, otherwise it can't keep the track of the user session on the web server.
0
 
htabbachAuthor Commented:
Thanks for the response, the cookies are enabled because the session cookie is created, I know that for a fact. The issue is a page launched from a third party cannot access the cookie on these three machines. It works on all other machines.
0
 
htabbachAuthor Commented:
One thing I found out is the issue is specific to the windows profile, if I login under my account on one of these machines it works fine. If the user logs in, it does not work.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Carlos VillegasFull Stack .NET DeveloperCommented:
mmm, ok, provide me some information:
- Windows version
- Internet Explorer version
- The users are in the Administrators group?
- The default browser is Internet Explorer? or you have another installed?
0
 
htabbachAuthor Commented:
windows XP Pro
IE8
No but it did not matter when I added them to the Administrators group
The default is IE, they had Chrome on and I removed it thinking it may be the problem
0
 
Carlos VillegasFull Stack .NET DeveloperCommented:
Please check your Internet Options:
 Internet Options
These are the default settings, are the same in the 3 PCs?
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now