• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1325
  • Last Modified:

SQL Server 2008 R2 IntelliSense

When I am trying to create a query the intellesense is not happening. Do I need to turn something on?
0
vbnetcoder
Asked:
vbnetcoder
  • 5
  • 5
  • 2
2 Solutions
 
effesCommented:
0
 
vbnetcoderAuthor Commented:
It looked mine was turned on according to what was in the article but it is still not working
0
 
BrandonGalderisiCommented:
Intellisense will only work work attaching using SQL Server 2008 (or later) tools to a SQL Server 2008 (or later) instance.  You cannot use intellisense against a 2005 instance.  If you need that, I suggest SQL prompt from Red-Gate.
0
Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

 
vbnetcoderAuthor Commented:
I am using sql server 2008 r2
0
 
BrandonGalderisiCommented:
can you run

select @@version

And post the results to verify please.
0
 
vbnetcoderAuthor Commented:
Microsoft SQL Server 2008 R2 (RTM) - 10.50.1600.1 (X64)   Apr  2 2010 15:48:46   Copyright (c) Microsoft Corporation  Enterprise Edition (64-bit) on Windows NT 6.1 <X64> (Build 7600: ) (Hypervisor)
0
 
BrandonGalderisiCommented:
Cool.  And what permission level do you have in the database which you are trying to get intellisense to work?
0
 
BrandonGalderisiCommented:
Have you checked out the solution here http://social.msdn.microsoft.com/Forums/en-US/sqltools/thread/446aebe8-7889-453b-80f3-7dd3579bd19f/

1) Make sure you are connected to SQL Server 2008 Edition.
IntelliSense does not work with the previous versions of SQL Server.

2) IntelliSense should be enabled.
Go to Tools >> Options >> Text Editor >> Transact-SQL >> IntelliSense

3) IntelliSense should be refreshed with the latest changes in database.
a) Press CTRL+SHIFT+R
b) Go to Edit >> IntelliSense >> Refresh Local Cache

4) Go to Tools >> Options >> Text Editor >> Transact-SQL >> General >> IntelliSense
Select Auto List Members and Check Parameter Information.
0
 
vbnetcoderAuthor Commented:
Yes, I tried that.
0
 
BrandonGalderisiCommented:
So what are your permissions in the database then?
0
 
effesCommented:
Any luck yet?

I found this thread in the MSDN Forums:
http://social.msdn.microsoft.com/Forums/en/sqltools/thread/dcd5c2cb-fc53-4c28-8b09-bfd9fea6684e

Maybe that will help.
0
 
vbnetcoderAuthor Commented:
ty
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

  • 5
  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now