• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 241
  • Last Modified:

No Internet Access

Windows XP System with IE 7 and Firefox 5.0. I cannot get on the Internet. I have an active and legitimate IP address - 192,168.1.2 - and I can ping web sites successfully by their FQDN and by their IP address but if I try to get there using a web browser I get the wonderful "Page not found" error. I have checked proxy setting and there are none and I have reset all defaults with no luck. I have reset the modem and the router but the problem persists. What am I missing? What could possibly be the problem?

Thank you!!

Robert
0
Robert Ehinger
Asked:
Robert Ehinger
  • 3
  • 2
  • 2
  • +7
1 Solution
 
X_layerCommented:
Try download Anti-malware.
Spyware may cause such behavior.
0
 
Gerwin Jansen, EE MVETopic Advisor Commented:
Is your XP up to date / patched, have an up to date virusscanner etc? Your Firefox is old, you should have 6.xx instead of 5.xx
0
 
Dr. KlahnPrincipal Software EngineerCommented:
Check to see if the hosts file has been tampered with.  Microsoft has a downloadable tool specifically for resetting the hosts file to its default settings.  The location and structure of the hosts file is also discussed at that URL.
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
IntegrityOfficeCommented:
when you ping a FQDN paste the ip address into the browser and see if it can connect that way.
0
 
☠ MASQ ☠Commented:
What are your settings for DNS servers?  Run
ipconfig /all
from a command prompt and post what your PC is using as IP addresses for DNS servers
0
 
Gerwin Jansen, EE MVETopic Advisor Commented:
Try accessing a website using telnet:

On cmd prompt, type: telnet www.microsoft.com 80
Type Ctrl+]
Type: set localecho and press Enter twice
Type: GET / HTTP/1.1 and press Enter twice

What reply do you get?
0
 
jake77444Commented:
Can any other machines access the internet? If so i'd recommend scanning the computer as previously suggested.
0
 
IntegrityOfficeCommented:
Trust you have checked out not an issue with your ISP
0
 
JohnnyITCommented:
I'm willing to bet it's a software-related issue....

While you say you've checked proxy settings and they say none, there may be some software, or remnants of old software sort of acting like a proxy.

Even if you don't have Norton software installed, run the removal tool to remove past remnants: http://us.norton.com/norton/support/kb/web_view.jsp?wv_type=public_web&selected_nav=&pvid=&docurl=20080710133024EN

...then Reboot

If that doesn't help try rebooting in "Safe Mode with Networking" (F8 During startup).

If a webpage comes up in safe mode, then you have a software problem for sure.  Likely culprits may be Antivirus software (like Norton), firewall software, and or networking software like Bonjour service from Apple.

....Norton Internet Security and other antivirus software are the most common culprits of this issue.

0
 
_Commented:
Winsock might be buggered:

run Winsockfix:
http://winsockfix.en.softonic.com/

or to do it manually:

Step 1: Delete the corrupted registry keys.
Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs.
For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base: 322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows.

Click Start, and then click Run. In the Open box, type regedit, and then click OK.
In Registry Editor, locate the following keys, right-click each key, and then click Delete:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock2

When you are prompted to confirm the deletion, click Yes.
Note: Restart the computer after you delete the Winsock keys. Doing so causes the Windows XP operating system to create new shell entries for those two keys. If you do not restart the computer after you delete the Winsock keys, the next step does not work correctly.

Step 2: Install TCP/IP. Right-click the network connection, and then click Properties. Click Install. Click Protocol, and then click Add. Click Have Disk. Type C:\Windows\inf, and then click OK. On the list of available protocols, click Internet Protocol (TCP/IP), and then click OK.

If Internet Protocol (TCP/IP) does not appear, follow these steps: Click Start, and then click Search. In the Search Companion pane, click More advanced options. Click to select the following three check boxes: Search system folders Search hidden files and folders Search subfolders
In the All or part of the file name box, type nettcpip.inf, and then click Search. In the results pane, right-click Nettcpip.inf, and then click Install.
Restart the computer.
0
 
jeff_01Commented:
Could be a firewall blocking port 80 ?

Try a secure website and see if that works.  

https://

0
 
Sudeep SharmaTechnical DesignerCommented:
Which security product are you using? Try disabling the Firewall/Anti-Virus and check if you are able to connect then.

0
 
IntegrityOfficeCommented:
Superantispyware or hijackthis.de and use the analyse option.
0
 
_Commented:
Thank you much.    : )
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
  • 2
  • +7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now