Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1437
  • Last Modified:

cannot delete emails in owa 2010 exchange with sp1

we are currently running Version: 14.01.0323.003 update 4 v-2 and when trying to delete emails via webmail (owa) we get the famous "an unexpected error occured and your request cannot be handled. i have tried everything on the web to no avail (resetting virtual dir permissions, renaming web.config, removing entries in web.config). I can delete emails in the lite version of owa. i also and getting the following error messages in eventviewer when i attempt to delete a message.


 "Outlook Web App couldn't connect Exchange Web Services due to a configuration error. Response code = "500".".

and...


Event code: 3005
Event message: An unhandled exception has occurred.
Event time: 9/6/2011 4:18:21 PM
Event time (UTC): 9/6/2011 9:18:21 PM
Event ID: 35a69b71525e45c99a99232a7287daa9
Event sequence: 1
Event occurrence: 1
Event detail code: 0
 
Application information:
    Application domain: /LM/W3SVC/1/ROOT/EWS-2-129598175014218750
    Trust level: Full
    Application Virtual Path: /EWS
    Application Path: E:\Exchange2010\ClientAccess\exchweb\EWS\
    Machine name: WOODLAND
 
Process information:
    Process ID: 7144
    Process name: w3wp.exe
    Account name: NT AUTHORITY\SYSTEM
 
Exception information:
    Exception type: HttpException
    Exception message: Could not load file or assembly 'Microsoft.Exchange.Data.Directory, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
 
Request information:
    Request URL: https://127.0.0.1:443/ews/exchange.asmx 
    Request path: /ews/exchange.asmx
    User host address: 127.0.0.1
    User:  
    Is authenticated: False
    Authentication Type:  
    Thread account name: NT AUTHORITY\SYSTEM
 
Thread information:
    Thread ID: 1
    Thread account name: NT AUTHORITY\SYSTEM
    Is impersonating: False
    Stack trace:    at System.Web.Compilation.BuildManager.ReportTopLevelCompilationException()
   at System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled()
   at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters)
 
 
Custom event details:
0
glpro76
Asked:
glpro76
  • 3
1 Solution
 
viveksahuCommented:
as per error it is pointed that the ews is not configured.

run the command set-webservicesvirtualdirectory

http://technet.microsoft.com/en-us/library/aa997233.aspx
0
 
glpro76Author Commented:
At what point in the error message do you see that ews is not defined? I see it defined in several areas. Just trying to get some clarification.  Thanks for info.
0
 
glpro76Author Commented:
Problem was related to webconfig file. support fixed the issue.
0
 
glpro76Author Commented:
support found solution. said it was due to webconfig file being incorrect.
0
 
shsdCommented:
I am having the same problem and I too have tried everything so I think my issue might also be the a corrupt or messed up web.config file.  Can you provide more information as to what support did to resolve this??
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now