Solved

Exchange 2010 stope receiving external mail

Posted on 2011-09-06
22
563 Views
Last Modified: 2012-05-12
I recently setup an Exchange 2010 in an Exchange 2007 environment.  All user (minus test accounts) reside on old 2007 server.  OWA and mx record both point to new 2010 server.  THis worked great for about 3 weeks.  Now every other day, we are unable to receive external email.  Once I reboot new Exchange 2010 server, mail flow works fine....for a couple days.  Then it stops again.  I cannot find anything in the event logs.  Any ideas?
0
Comment
Question by:ecubenetworks
  • 10
  • 7
  • 5
22 Comments
 

Expert Comment

by:supporthl
ID: 36492303
Next time it stops go to www.testexchangeconnectivity.com and select inbound smtp. Enter your server details and check the results.

Its a free microsoft service.

Another thing that springs to mind, backpressure, exchange 2007 and 2010 have a feature built in that monitors the disk usage and if the disk space drops on the drive that holds the installion of the hub transport role it stops working.

Hope this helps
0
 

Author Comment

by:ecubenetworks
ID: 36492333
I have run the www.testexchangeconnectivity.com  test when it occurs.  It says that the connection was refused.  

There is 27GB of free space on the c drive and 449 gb free on d:.

Another piece that I left out is that our mail goes to Trendmicro for SPAM.  But I do not think the issue is on their side because the reboot fixes it.

0
 
LVL 14

Expert Comment

by:setasoujiro
ID: 36492356
when you stop receiving mails, have you checked all the services?
are people still able to login to OWA and such?
0
 

Expert Comment

by:supporthl
ID: 36492359
Ok, is it a typical exchange installation? Ie, is the CAS, HUB and mailbox role installed on the same server?

Can you telnet the server when it happens? Do you reveive any specific NDR's?
0
 

Author Comment

by:ecubenetworks
ID: 36492412
Checked services and all are running.  No errors in event log.

Did not try to telnet, but here is the message that external senders get when trying to send mail to my server:

Your message could not be delivered for more than 2 hour(s).
It will be retried until it is 5 day(s) old.
For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can delete your own text from the attached returned message.

                   The mail system

<kmjoseth@xxxx.org>: connect to xxx.xxx.113.70xxxxx
    Connection refused
0
 

Expert Comment

by:supporthl
ID: 36492424
Is the trendmicro a hosted solution? Or is it installed on your server?
0
 
LVL 14

Expert Comment

by:setasoujiro
ID: 36492449
could it be that your resources are fully loaded on the server? (ram etc)
0
 

Author Comment

by:ecubenetworks
ID: 36492462
Trendmicro is a hosted solution.

Server is barely using anything (1% CPU and 1.65GB of 8GB of Mem).  All it is doing right now is incoming mail.  I have not migrated user mailboxes yet.
0
 
LVL 14

Expert Comment

by:setasoujiro
ID: 36492482
can you find event logs in the 2007 server?
0
 
LVL 14

Expert Comment

by:setasoujiro
ID: 36492484
can you try and move 1 mailbox to 2010 or create new one there, and see if that mbox experiences the issue as well?
0
 

Expert Comment

by:supporthl
ID: 36492489
Have you got any test mailboxes on the new server?

Can you send an external email to that mailbox? When it happens

Could it be an internal routing issue? I assume you have correct dns otherwise it wouldnt work.
0
Want to promote your upcoming event?

Are you going to an event? Are you going to be exhibiting at a tradeshow? Talking at a conference? Using a promotional banner in your email signature ensures that your organization’s most important contacts stay in the know and can potentially spread the word about the event.

 

Author Comment

by:ecubenetworks
ID: 36492501
No...I tried that.  All external mail is rejected.  I have 6 test accounts on new server.  Could not send to any of them.  Some of the test mailboxes were migrated, and some were new.  None could receive external mail.
0
 
LVL 14

Expert Comment

by:setasoujiro
ID: 36492508
i would try and telnet and deliver mail to the server that way, then check to see what this tells you.
0
 

Author Comment

by:ecubenetworks
ID: 36492557
I am seeing the following errors all over the 2007 Exchange event viewer:

Microsoft Exchange could not find a certificate that contains the domain name mail.xxxxxxx.org in the personal store on the local computer. Therefore, it is unable to support the STARTTLS SMTP verb for the connector scanner with a FQDN parameter of mail.learncharter.org. If the connector's FQDN is not specified, the computer's FQDN is used. Verify the connector configuration and the installed certificates to make sure that there is a certificate with a domain name for that FQDN. If this certificate exists, run Enable-ExchangeCertificate -Services SMTP to make sure that the Microsoft Exchange Transport service has access to the certificate key.

For more information, see Help and Support Center at
0
 
LVL 14

Expert Comment

by:setasoujiro
ID: 36493591
this can be easily ingnored, it means that you have specified to use mail.learncharter.org as SMTP banner, but don't have the certificate to match.
this is not related

try to send a mail over telnet, this will give us more clues in what's happening
0
 

Author Comment

by:ecubenetworks
ID: 36499203
how do u send a mail over telent?
0
 
LVL 14

Expert Comment

by:setasoujiro
ID: 36499252
0
 

Author Comment

by:ecubenetworks
ID: 36514455
It just happened again today. Tried restarting all Exchange services twice...No luck.  Had to do 2 reboots to get it back up.  Nothing in event viewer.  Here is the report from ExchangeServerTest :

\
 
 
 
 
 Testing Mail Exchanger mail.xxxxxxx.org.
  One or more SMTP tests failed for this Mail Exchanger.
   Test Steps
   Attempting to resolve the host name mail.learncharter.org in DNS.
  The host name resolved successfully.
   Additional Details
  IP addresses returned: 216.xxx.xxx.xxx
 
 Testing TCP port 25 on host mail.xxxxx.org to ensure it's listening and open.
  The specified port is either blocked, not listening, or not producing the expected response.
   Tell me more about this issue and how to resolve it
   Additional Details
  A network error occurred while communicating with the remote host.
 
 
 
 
0
 

Expert Comment

by:supporthl
ID: 36514469
When ot runs open exchange management shell and run test-systemhealth

Is there any red?
0
 

Author Comment

by:ecubenetworks
ID: 36568991
no red...just some yellow warnings about network drivers being more than 2 years old.  FYI- I have no other network issues when this smtp trouble occurs
0
 

Accepted Solution

by:
ecubenetworks earned 0 total points
ID: 36712530
OK...I think I have narrowed the issue down to the NIC cards.  I have two teamed Broadcom NetExtreme II cards (in a Hyper V  environment).  When this issue occurded last, I disabled the NICS and re-enabled them.  External email immediately started working again.  I am going to upgrade drivers and see if this resolves the issue.
0
 

Author Closing Comment

by:ecubenetworks
ID: 36941303
Upgrading NIC drives resolved issue.
0

Featured Post

Want to promote your upcoming event?

Attending an event? Speaking at a conference? Or exhibiting at a trade show? Easily inform your contacts by using a promotional banner in your email signature. This will ensure your organization’s most important contacts are in the know.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now