Solved

VMWare OVF Deployment

Posted on 2011-09-07
17
5,191 Views
Last Modified: 2012-08-14
ERROR:
File win2k3z32.ovf fails integrity check and might have been corrupted during transfer.

I have recently exported this Windows VM from my ESX Server.  When i try to deploy this VM onto other ESX Server it shows the above error.

In the ovf file it had a line referring to a Windows Installation ISO file which I had connected to the Virtual Machine when is VM was running.  The folder where i exported the VM contained .vmdk file, .ovf file , .mf and the iso file which was connected to CD ROM.  WHile deploying i removed the line which instructs to take the ISO file in the .ovf file.  This caused for incomplete deployment of the VM. After that i poked with the file editing and modifying which stopped even taking the .OVF file as is seen in the error message.
 
  Then I Tried to attach the .vmdk file to a new created VM by using the " Add a existing HDD ". For this i copied the .vmdk file to the ESX Server Data store.  While browsing the data store to add .vmdk, the .vmdk file was not shown. I was wondering about the reason. Any help on this is appreciated.  After did lot of experiments to get it back but was not worth it.

Can someone tell me how can i get back the .vmdk file working as i have files in it.

I am attaching the OVF File with this mail. You  

Nikhil K win2k3x32.txt
0
Comment
Question by:nikhil9492
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 6
17 Comments
 
LVL 121
ID: 36494626
Do you still have the original Server for Export?

Have you tried mounting the vmdk files in your workstation?

See here
http://www.petri.co.il/virtual_mount_vmware_virtual_disk_without_vmware.htm
0
 
LVL 2

Expert Comment

by:ajjmunoz
ID: 36495728
You should keep the files locally....then try to use the "deploy OVF template" option in the VI client (vcenter or ESX connection).
0
 

Author Comment

by:nikhil9492
ID: 36497749
No i have overwritten the original Server and all the VM's in that Server are lost.  I will try Genius's method to read .vmdk file check if it works. Thanks for the solution.  Sorry for typo mistakes.
0
Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

 
LVL 121
ID: 36497792
The issue you may have is that the VMDKs maybe in a compressed format, do they look smaller than the originals?

If they are only the import process will work for you.

Try using the OVF Tool, to "see" if you can export the VMDKs correctly.
http://communities.vmware.com/community/vmtn/server/vsphere/automationtools/ovf
0
 

Author Comment

by:nikhil9492
ID: 36497889
Yes the seize of the vmdk file is around 1.6 GB when exported. Bu the HDD size i gave while creating thr VM was 8GB.  I had given the THIN Provision option, that may be the reason of smaller filesize.  What is Compressed format and what we need to do in such case.
0
 
LVL 121
ID: 36497928
Try using the OVF tools first to complete an export. and then complete the mount.
0
 
LVL 121
ID: 36497941
Have you also tried Converter? VMware Converter?
0
 

Author Comment

by:nikhil9492
ID: 36497989
I am at home and and will have try after i go to office tomorrow. I just wanted to accumulate all the details now and try it tomorrow. Thanks for suggestions.
0
 
LVL 121
ID: 36498135
Okay, I've edited your OVF file it now passes validation, try this, put in the folder with your existing vmdks, and try reimporting

 win2k3x32.txt
0
 

Author Comment

by:nikhil9492
ID: 36501700
Hey this is o/p i get when running vmware-mount.

C:\Program Files (x86)\VMware\VMware DiskMount Utility>vmware-mount.exe d: "e:\My Virtual Machines\windowsvm-with-ws-management\win2k3x32\win2k3x32-disk1.vmdk"

Unable to mount the virtual disk.  The disk may be in use by a virtual
machine or mounted under another drive letter.  If not, verify that the
disk is a virtual disk file, and that the disk file has not been corrupted.

What I do not get here is to which Drive should i mount?  Is there anything to be checked about the file system compatibilty?

By the way i have tried with the modified ovf file and the issue still persists.
0
 
LVL 121
ID: 36501732
what error do you get with OVF import, I tried here with no issues.

youll not be able to mount the vmdk it's compressed
0
 
LVL 121
ID: 36501781
I get this, does the error occur after this? deploy ovf
0
 
LVL 121
ID: 36501787
I only get a failed to deploy because I do not have the win2k3x32-disk1.vmdk file
0
 

Author Comment

by:nikhil9492
ID: 36502161
I am attaching the image with this message to get more information. ovf-error.jpg
0
 
LVL 121
ID: 36502200
Unfortunately, the VMDK is corrupted. That's why it cannot be deployed. The checksum of the vmdk file does not match the checksum in the OVF.

0
 

Author Comment

by:nikhil9492
ID: 36502297
Oops, thanks for the confirmation. Can you explain what could have caused this.
0
 
LVL 121

Accepted Solution

by:
Andrew Hancock (VMware vExpert / EE MVE^2) earned 500 total points
ID: 36502311
Network transfer, disk problems, Ive not seen this error personally before, but we always check exports before we delete or archive production VMs.
0

Featured Post

[Webinar] Learn How Hackers Steal Your Credentials

Do You Know How Hackers Steal Your Credentials? Join us and Skyport Systems to learn how hackers steal your credentials and why Active Directory must be secure to stop them. Thursday, July 13, 2017 10:00 A.M. PDT

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

HOW TO: Upload an ISO image to a VMware datastore for use with VMware vSphere Hypervisor 6.5 (ESXi 6.5) using the vSphere Host Client, and checking its MD5 checksum signature is correct.  It's a good idea to compare checksums, because many installat…
In this step by step tutorial with screenshots, we will show you HOW TO: Enable SSH Remote Access on a VMware vSphere Hypervisor 6.5 (ESXi 6.5). This is important if you need to enable SSH remote access for additional troubleshooting of the ESXi hos…
Teach the user how to convert virtaul disk file formats and how to rename virtual machine files on datastores. Open vSphere Web Client: Review VM disk settings: Migrate VM to new datastore with a thick provisioned (lazy zeroed) disk format: Rename a…
This video shows you how to use a vSphere client to connect to your ESX host as the root user. Demonstrates the basic connection of bypassing certification set up. Demonstrates how to access the traditional view to begin managing your virtual mac…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question