Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 266
  • Last Modified:

vlan doesnot work

Dear I have this  network doesn't work vlan why !!

main#wr t
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.101
 encapsulation dot1Q 101
 ip address 10.30.30.1 255.255.255.0
!
interface FastEthernet0/0.103
 encapsulation dot1Q 103
 ip address 91.217.185.194 255.255.255.192

main#ping 91.217.185.238

.....
Success rate is 0 percent (0/5)

main#ping 10.30.30.2

.....
Success rate is 0 percent (0/5)



bring#wr t


!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.101
 encapsulation dot1Q 101
 ip address 10.30.30.2 255.255.255.0
!
interface FastEthernet0/0.103
 encapsulation dot1Q 103
 ip address 91.217.185.238 255.255.255.192



Switch#wr t

interface FastEthernet0/1
 switchport mode trunk
!
interface FastEthernet0/2
 switchport mode trunk

interface Vlan1
 no ip address
 shutdown
!
interface Vlan101
 no ip address
!
interface Vlan103
 no ip address



vlan.jpg
0
memo12345678
Asked:
memo12345678
  • 5
  • 3
1 Solution
 
fgasimzadeCommented:
Have you created vlans on the switch?
0
 
memo12345678Author Commented:
yes I sent u config of sw also

Switch#wr t

interface FastEthernet0/1
 switchport mode trunk
!
interface FastEthernet0/2
 switchport mode trunk

interface Vlan1
 no ip address
 shutdown
!
interface Vlan101
 no ip address
!
interface Vlan103
 no ip address
0
 
Rick_O_ShayCommented:
Since you have multiple VLANs on each interface you need to be VLAN tagging all of your VLANs on all of the links.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
memo12345678Author Commented:
so how  please give me config example to solve this
 

what config recommend u want give to me !!
0
 
fgasimzadeCommented:
Have you created vlans 101, 103? Not interface vlans, just vlans
0
 
memo12345678Author Commented:
I remove

interface vlan 101 and 103 from switch  but now

when i make ping from bring to main router


i can ping to 91.217.185.194 but i cannot ping to 10.30.30.1 why !!

bring#ping 10.30.30.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.30.30.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

bring#ping 91.217.185.194

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 91.217.185.194, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 6/8/11 ms

0
 
fgasimzadeCommented:
Have you created vlan 103 on the switch? :)
0
 
memo12345678Author Commented:
thnxxxxxxxxxxxx alot fixed
0
 
memo12345678Author Commented:
thx
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now