Solved

recieving default routes for the internet via 2 seperate ISP's

Posted on 2011-09-07
4
252 Views
Last Modified: 2012-05-12
Just recieved 2 internet handoffs from 2 separate ISP's and now I need to BGP peer with both.
Each handoff is connected to two seperate cisco switches which are trunked together. Each switch also has a Cisco router which will be used to peer with each ISP.  I am looking to recieve the default routes from each ISP.  I need help with the configuration of this type of setup.  I have a /24 IP block that I would like to advertise.  Can someone help me with what the config will look like if the following info is assumed?  ISP A - AS 100;  ISP B - AS 200; my registered IP block 100.100.100.0/24;  my AS 300

thanks
0
Comment
Question by:FREDARCE
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 3

Accepted Solution

by:
woepwobin earned 500 total points
ID: 36501814
This is a rough start for Router1. Assuming you got address 200.0.0.2 from ISP1, and 200.0.1.2 from ISP2 for the interconnect.

interface Ethernet1
 description LAN
 ip address 100.100.100.1 255.255.255.0
!
interface Ethernet2
 description ISP1
 ip address 200.0.0.2 255.255.255.252
!
interface Ethernet3
 description ISP2
 ip address 200.0.1.2 255.255.255.252
!
router bgp 300
 bgp log-neighbor-changes
 neighbor 100.100.100.2 remote-as 300
 neighbor 100.100.100.2 description Router2
 neighbor 100.100.100.2 prefix-list Mynet in
 neighbor 100.100.100.2 prefix-list Mynet out
 neighbor 200.0.0.1 remote-as 100
 neighbor 200.0.0.1 description ISP1
 neighbor 200.0.0.1 default-originate
 neighbor 200.0.0.1 prefix-list Mynet out
 neighbor 200.0.1.1 remote-as 200
 neighbor 200.0.1.1 description ISP2
 neighbor 200.0.1.1 default-originate
 neighbor 200.0.1.1 prefix-list Mynet out
 !
 address-family ipv4
  neighbor 100.100.100.2 activate
  neighbor 200.0.0.1 activate
  neighbor 200.0.1.1 activate
 exit-address-family
!
ip prefix-list Mynet seq 10 permit 100.100.100.0/24
ip prefix-list Mynet seq 9999 deny 0.0.0.0/0 le 32

Open in new window

0
 

Author Comment

by:FREDARCE
ID: 36506404
thanks,  can you explain the preflix-list Mynet and what it is actually doing?
0
 
LVL 3

Expert Comment

by:woepwobin
ID: 36506632
One of the purposes of the prefix list is to prevent the router from sending ISP1's routes to ISP2.

Now that I look at it again, the next lines should not be used:

neighbor 100.100.100.2 prefix-list Mynet in
neighbor 100.100.100.2 prefix-list Mynet out

Open in new window


Because you'll want Router2 to learn about Router1's default routes.
0
 

Author Comment

by:FREDARCE
ID: 36515108
is it same to say that router 2 config will be the same?  If both routers are recieving default routes then what will determine which ISP all my traffic will route through?

thanks
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
In what cases will server send empty session id during TLS handshake 3 127
ping a url gives different ip addresses 5 90
Link issue 11 72
PIM sparse mode question 1 24
A few months ago I attended the Rocky Mountain IPv6 Summit which was a two-day educational event; it was the 3rd annual conference held here in Denver, Colorado that was held at the Hyatt Regency Denver at the Colorado Convention Center. It was an e…
I know for anybody starting from Beginner to Expert in Networking knows what OSI model. But this tutorial is for freshers or those who are new to networking world. Why I am putting OSI in such simple and compact manner is because it enables you to k…
Viewers will learn how to properly install and use Secure Shell (SSH) to work on projects or homework remotely. Download Secure Shell: Follow basic installation instructions: Open Secure Shell and use "Quick Connect" to enter credentials includi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question