Restoring Network Connections: The local device name is already in use.

We have a small workgroup in which we share access to individual computers, mostly for running backups.  We are in the process of upgrading from Windows Vista to Windows 7 and have one machine currently running 7.  Yesterday we successfully mapped our Vista machines to the 7 machine and everything seemed fine.  Today, I get the following error: "Restoring Network Connections An error occurred while reconnecting G: to \\XXXXX\X Microsoft Windows Network: The local device name is already in use. This connection has not been restored." on both Vista machines.  I run backups on my Vista machine for data on the 7 machine and had problems accessing the drive overnight so we changed the settings on the 7 machine to stay on and not lock after non-use.  This did not help as I got the above error this morning.  What are we missing in our settings that will maintain our network connections?
bakerg1Asked:
Who is Participating?
 
johnb6767Commented:
On each machine....

Delete all the mappings and retest....

net use * /del

Then remap[ it...

If it still errors, delete them from the Registry....

HCU\Network    (Actually, should see a 'G' subkey here....). Each mapping is named as the subkey....
0
 
homergfunkCommented:
You can also go into your Disk Management (Right Click my computer and Manage). It sounds like a Flash Drive or CD-ROM drive might have taken your mapped drive spot. Right click the conflicting device and assign it a different drive letter.

Otherwise, deleting the above mappings using the net use * /del command should work.
0
 
bakerg1Author Commented:
I did not try deleting the mappings as I was having issues "seeing" the 7 machine from my computer.  We had set all of our computers to "Private" network yesterday and they all becam "Public" overnight.  Once I reset them all back to "Private" we could see the 7 machine again.  We tried rebooting all machines, hoping to preserve the "Private" setting; however, they all reverted back to "Public."  We did turn off our firewalls (this is a totally private network, absolutely no Internet access) and removed password requirements for the 7 machine before the reboot.  After the reboot, I still have access to the 7 machine.  Why won't the network stay private?  It is also identified as "Unidentified network," can we change that?
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

 
homergfunkCommented:
If its only a couple machines you could set them up as all static IPs. This sounds like a router or network issue. I'm thinking that your machines are losing network connection and upon reestablishing a connection it is being assigned a new address, hence the switch to public network.

If you still can't fix this, you can always go into windows firewall and set the public settings to allow all traffic.
Go to Windows Firewall with Advanced Settings
Make the Public Profile ALLOW inbound and outbound connections that do not match a rule...

Either solution should work for you.
0
 
bakerg1Author Commented:
We already use static IP addresses.  We only use a switch to interconnect the workgroup.  What is really odd, even though I can map to the 7 machine and access it from the mapping, it does not show up as part of the network, even on that machine; it will show up in the network map when we are all set to private but you cannot access it from there even thought the Vista machines can access each other from this map.
0
 
homergfunkCommented:
Couple troubleshooting tips I can think of. Disable v6 in tcp/ip on all computers, and also try using a different switch. Disabling v6 on will force all computers to use v4 (even though it should be already).

I also read earlier you disabled the win7 firewall. Did you do this in services (services.msc), and if so, you might try starting the service and configuring the firewall as mentioned above, and if not, try disabling the firewall service and stopping it.

Try these 3 different approaches and see if you get any different result
-Disable v6 on network connection (ncpa.cpl)
-Replace switch
-Enable / Disable / Configure Windows Firewall
0
 
centervCommented:
If you're getting something like Network3, get your firewall configured or set to defaults.
Open network sharing and make a new network connection such as work.
Set it as discoverable and with file sharing.
Be sure workgroup name is same for all.
When you have your connection, go to registry and search for name of duplicate connection.
It will be grouped with all the other older connections.
Delete them all to prevent further issues.
Be sure to make restore point and backup registry before doing these repairs.
good luck
0
 
bakerg1Author Commented:
We maintained connection overnight last night and completed our necessary backups.  We set our network as private in the local secutiy policies and have the firewalls turned off.  Network discovery is turned on on all machines.  The only remaining problem is that the 7 machine still does not show up in the network like the other computers do.  We can access it by typing \\computername but it is not visible.  I verified that the Function Discovery Provider Host service was running in Task Manager and also ran "net config server" which is set to "NO" for hidden.  Will creating a network connection correct this issue?  If so, what is the best way to search for the registry keys that would need to be removed?
0
 
centervCommented:
For future ref and repairs, you may want to stick with the default settings such as turn on firewall if you use it and so on.
You can search registry for the name of conflicting connection such as Local Connection 8 etc.
Should be a subkey of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network
The advanved sharing options in win7 is set at 128 encryption for file sharing.
Change it to be compatible with xp and I don't remember Vista default, but they should all be the same.
Check the homegroup settings and be sure you're not using sinple file sharing ie turn off public folders.
Setup all your options using Advanced sharing center and not right clicking sharing on individual items.
0
 
bakerg1Author Commented:
Did not completely resolve the issue but each response did help guide us to a better solution.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.