Solved

Cisco 877 Router

Posted on 2011-09-07
5
532 Views
Last Modified: 2012-05-12
I am having trouble with my 877 dsl router where when I boot it up I get to the console
         --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]

unless I select either yes or no the CD light on front of the router keeps flashing and I can not do anything with the router. If I select no and set some values like hostname and reload the router it dosnt keep any of the saved configurations. My IOS version is c870-advipservicesk9-mz.124-15.T4 dose anyone have anyidea what might be going on
thanks
0
Comment
Question by:nchannon
5 Comments
 
LVL 17

Assisted Solution

by:rochey2009
rochey2009 earned 100 total points
ID: 36498768
Hi,

It's either lost its configuration or it's been told to bypass it.

Have a look at the configuration register  with the show version command

At the bottom of the output, it should say:

Configuration register is 0x2102
0
 
LVL 18

Accepted Solution

by:
jmeggers earned 350 total points
ID: 36500580
Say "no" to the initial configuration dialog, and at the prompt do a "show version" as mentioned above.  If it says anything other than 0x2102, look for a startup config using "show start".  If the startup config is there, do a "copy start run" to bring that configuration into the running configuration.  Then go into config mode, change the config register to 0x2102, and then save the config ("copy run start").  You MUST bring the startup config over to be the running config, otherwise when you change the config register and save that, you will overwrite the existing startup config with essentially a blank config.

If the config register is set to 0x2102 and there's no startup config, then you're on your own.  Hopefully you have an archived copy someplace.
0
 

Author Comment

by:nchannon
ID: 36501566
Hi thanks that did the job but im still a little confused as when I set the command config-register 0x2102
and reloaded all worked fine but when I check the show version my configuration register is now 0x3922 and not 0x2102 yet now the router is booting up fine why is this
Thanks
0
 
LVL 3

Assisted Solution

by:woepwobin
woepwobin earned 50 total points
ID: 36501729
The console baudrate is set to 115200 instead of 9600, that's why the config register is 0x3922 instead of 0x2102. See http://www.cisco.com/en/US/products/hw/routers/ps133/products_tech_note09186a008022493f.shtml#config-reg-meaning.
0
 

Author Closing Comment

by:nchannon
ID: 36502444
Thanks very much for your help my router is back up and running
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Can Cisco resolve internet address internally 4 29
OSPF Question 12 52
Guest Wi-Fi Marketing solution required 8 58
Vlan to Vlan communication 9 71
There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

929 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now