?
Solved

ProFTP not authenticating

Posted on 2011-09-07
5
Medium Priority
?
602 Views
Last Modified: 2013-12-02
Hi, I've just upgraded my proftp server running on fc8 (with plesk panel 9.5.2) from 1.3.2 to 1.3.3 and now I can't log into any users on it.  I can log into ssh using the user/pass fine, so I'm pretty sure it's not a mistyped password.  I also checked the deny users file, and none of the users are in there that I was trying to log in with.  (as far as I know, the only deny file is the /etc/ftpusers file which was assigned in /etc/pam.d/proftpd).

Does anyone know what I can do to see exactly why it's not authenticating, or has anyone seen this before and knows how to fix it?
0
Comment
Question by:Matt Kendall
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
5 Comments
 
LVL 17

Expert Comment

by:bigeven2002
ID: 36500595
Hello,

Which FTP clients are you using?  Most clients have an Active mode and Passive mode for FTP when connecting.  The default is usually Passive so try changing it to Active or vice versa in the settings to see if it will connect for you.
0
 
LVL 2

Author Comment

by:Matt Kendall
ID: 36500818
Hi bigeven, thanks for the suggestion.  I've been trying to connect with both Filezilla and windows ftp client.  I tried forcing both active and passive transfer modes (rather than default) and that didn't help.

I've been reading up on proftpd a lot since this started and I was reading about a debug mode that I think might help me pinpoint the problem, but it requires stand alone mode.  I can see where to put this mode in the proftpd.conf file, but once it's in there, I dont know how to start just proftpd.  It gets started by a xinetd service, which I can stop and restart, but I think that forces it into inetd mode and not stand alone.
0
 
LVL 9

Expert Comment

by:parparov
ID: 36502576
What do corresponding logs in /var/log say?
Maybe the default configuration for 1.3.3 is an "Anonymous user only"?
0
 
LVL 2

Accepted Solution

by:
Matt Kendall earned 0 total points
ID: 36525909
Just in case anyone encounters this problem in the future, it's because I upgraded the proftp server to a non parallel's version, which is required since the server is running plesk panel.  Switching to a parallel version fixed this.
0
 
LVL 2

Author Closing Comment

by:Matt Kendall
ID: 36553531
Found out through parallel's forums.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

One of the typical problems I have experienced is when you have to move a web server from one hosting site to another. You normally prepare all on the new host, transfer the site, change DNS and cross your fingers hoping all will be ok on new server…
What You Need to Know when Searching for a Webhost Provider
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question