Solved

ProFTP not authenticating

Posted on 2011-09-07
5
598 Views
Last Modified: 2013-12-02
Hi, I've just upgraded my proftp server running on fc8 (with plesk panel 9.5.2) from 1.3.2 to 1.3.3 and now I can't log into any users on it.  I can log into ssh using the user/pass fine, so I'm pretty sure it's not a mistyped password.  I also checked the deny users file, and none of the users are in there that I was trying to log in with.  (as far as I know, the only deny file is the /etc/ftpusers file which was assigned in /etc/pam.d/proftpd).

Does anyone know what I can do to see exactly why it's not authenticating, or has anyone seen this before and knows how to fix it?
0
Comment
Question by:kendalltech
  • 3
5 Comments
 
LVL 17

Expert Comment

by:bigeven2002
ID: 36500595
Hello,

Which FTP clients are you using?  Most clients have an Active mode and Passive mode for FTP when connecting.  The default is usually Passive so try changing it to Active or vice versa in the settings to see if it will connect for you.
0
 
LVL 2

Author Comment

by:kendalltech
ID: 36500818
Hi bigeven, thanks for the suggestion.  I've been trying to connect with both Filezilla and windows ftp client.  I tried forcing both active and passive transfer modes (rather than default) and that didn't help.

I've been reading up on proftpd a lot since this started and I was reading about a debug mode that I think might help me pinpoint the problem, but it requires stand alone mode.  I can see where to put this mode in the proftpd.conf file, but once it's in there, I dont know how to start just proftpd.  It gets started by a xinetd service, which I can stop and restart, but I think that forces it into inetd mode and not stand alone.
0
 
LVL 9

Expert Comment

by:parparov
ID: 36502576
What do corresponding logs in /var/log say?
Maybe the default configuration for 1.3.3 is an "Anonymous user only"?
0
 
LVL 2

Accepted Solution

by:
kendalltech earned 0 total points
ID: 36525909
Just in case anyone encounters this problem in the future, it's because I upgraded the proftp server to a non parallel's version, which is required since the server is running plesk panel.  Switching to a parallel version fixed this.
0
 
LVL 2

Author Closing Comment

by:kendalltech
ID: 36553531
Found out through parallel's forums.
0

Featured Post

Master Your Team's Linux and Cloud Stack!

The average business loses $13.5M per year to ineffective training (per 1,000 employees). Keep ahead of the competition and combine in-person quality with online cost and flexibility by training with Linux Academy.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Upgrade View 5.1.2 to Horizon 7 3 90
Migrate data to new Mac OS X server 3 88
CentOS create a user with predefined MD5 Hashed password 17 96
SSL Certificate for IIS7 Site 2 58
If, like me, you have a lot of Dell servers in the estate you manage this article should save you a little time. When attempting to login to iDrac on any server I would be presented with two errors. The first reads "Do you want to run this applicati…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…

860 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question