Solved

ProFTP not authenticating

Posted on 2011-09-07
5
590 Views
Last Modified: 2013-12-02
Hi, I've just upgraded my proftp server running on fc8 (with plesk panel 9.5.2) from 1.3.2 to 1.3.3 and now I can't log into any users on it.  I can log into ssh using the user/pass fine, so I'm pretty sure it's not a mistyped password.  I also checked the deny users file, and none of the users are in there that I was trying to log in with.  (as far as I know, the only deny file is the /etc/ftpusers file which was assigned in /etc/pam.d/proftpd).

Does anyone know what I can do to see exactly why it's not authenticating, or has anyone seen this before and knows how to fix it?
0
Comment
Question by:kendalltech
  • 3
5 Comments
 
LVL 17

Expert Comment

by:bigeven2002
ID: 36500595
Hello,

Which FTP clients are you using?  Most clients have an Active mode and Passive mode for FTP when connecting.  The default is usually Passive so try changing it to Active or vice versa in the settings to see if it will connect for you.
0
 
LVL 2

Author Comment

by:kendalltech
ID: 36500818
Hi bigeven, thanks for the suggestion.  I've been trying to connect with both Filezilla and windows ftp client.  I tried forcing both active and passive transfer modes (rather than default) and that didn't help.

I've been reading up on proftpd a lot since this started and I was reading about a debug mode that I think might help me pinpoint the problem, but it requires stand alone mode.  I can see where to put this mode in the proftpd.conf file, but once it's in there, I dont know how to start just proftpd.  It gets started by a xinetd service, which I can stop and restart, but I think that forces it into inetd mode and not stand alone.
0
 
LVL 9

Expert Comment

by:parparov
ID: 36502576
What do corresponding logs in /var/log say?
Maybe the default configuration for 1.3.3 is an "Anonymous user only"?
0
 
LVL 2

Accepted Solution

by:
kendalltech earned 0 total points
ID: 36525909
Just in case anyone encounters this problem in the future, it's because I upgraded the proftp server to a non parallel's version, which is required since the server is running plesk panel.  Switching to a parallel version fixed this.
0
 
LVL 2

Author Closing Comment

by:kendalltech
ID: 36553531
Found out through parallel's forums.
0

Featured Post

Do email signature updates give you a headache?

Do you feel like all of your time is spent managing email signatures? Too busy to visit every user’s desk to make updates? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today!

Join & Write a Comment

​Being a Managed Services Provider (MSP) has presented you  with challenges in the past— and by meeting those challenges you’ve reaped the rewards of success.  In 2014, challenges and rewards remain; but as the Internet and business environment evol…
BIND is the most widely used Name Server. A Name Server is the one that translates a site name to it's IP address. There is a new bug in BIND (https://kb.isc.org/article/AA-01272), affecting all versions of BIND 9 from BIND 9.1.0 (inclusive) thro…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now