Solved

remote server returned error 407 proxy authentication required

Posted on 2011-09-07
3
554 Views
Last Modified: 2012-05-12
Hi all

I have this error while trying to call a webService on a remote server
<<remote server returned error 407 proxy authentication required>>
I am calling the web services via microsoft console application...

How can I overwrite or what should I include on the scritp to help get ride of this error

Thanks in Advance
[System.CodeDom.Compiler.GeneratedCodeAttribute("wsdl", "2.0.50727.3038")]
[System.Diagnostics.DebuggerStepThroughAttribute()]
[System.ComponentModel.DesignerCategoryAttribute("code")]
[System.Web.Services.WebServiceBindingAttribute(Name="SellerDownloadServicesSoap", Namespace="http://www.website.com")]
public partial class SellerDownloadServices : System.Web.Services.Protocols.SoapHttpClientProtocol {
    
    private System.Threading.SendOrPostCallback GetPayeeListWithIDsOperationCompleted;
    
    
    
    /// <remarks/>
    public SellerDownloadServices() {
        this.Url = "https://%%/%/SellerDownloadServices.asmx";
    }

Open in new window

0
Comment
Question by:ZURINET
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 10

Accepted Solution

by:
eguilherme earned 400 total points
ID: 36502062
the client that is making the call to the webservice is behind a proxy.. you need to configure your application with the proxy settings eg:

http://msmvps.com/blogs/paulomorgado/archive/2009/01/12/setting-a-web-proxy-through-configuration-in-net-applications.aspx

http://msdn.microsoft.com/en-us/library/system.net.webrequest.defaultwebproxy.aspx
0
 

Author Comment

by:ZURINET
ID: 36502819
Hi Eguiherme

Please where is this file located.. in Proxy server or in the development machine?

The link says <<This configuration is done in the machine or application file in the proxy element of the defaultProxy configuration section in  the system.net section group>>


Thanks in Advance
 

<configuration>
  <system.net>
    <defaultProxy enabled="true">
      <proxy usesystemdefault="True"/>
    </defaultProxy>
  </system.net>
</configuration>

Open in new window

0
 
LVL 1

Expert Comment

by:rerard
ID: 36504840
On the dev machine in the app.config or projectname.exe.config
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This document covers how to connect to SQL Server and browse its contents.  It is meant for those new to Visual Studio and/or working with Microsoft SQL Server.  It is not a guide to building SQL Server database connections in your code.  This is mo…
Entity Framework is a powerful tool to help you interact with the DataBase but still doesn't help much when we have a Stored Procedure that returns more than one resultset. The solution takes some of out-of-the-box thinking; read on!
In this video, viewers will be given step by step instructions on adjusting mouse, pointer and cursor visibility in Microsoft Windows 10. The video seeks to educate those who are struggling with the new Windows 10 Graphical User Interface. Change Cu…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question