Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

This database has exceeded the size limit of 18 GB.

Posted on 2011-09-08
8
Medium Priority
?
711 Views
Last Modified: 2012-06-27
I'm receiving this error on our 2003 excchange server  and the mailbox store is shutting off every other day.  I've follow this link from Microsoft and made the Database Size Limit in GB - REG WORD key

But I'm still getting this error and today our server was down.

http://technet.microsoft.com/en-us/library/aa998066(EXCHG.65).aspx
 
Any advice?
0
Comment
Question by:ravenrx7
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +1
8 Comments
 
LVL 23

Expert Comment

by:Stelian Stan
ID: 36502727
You can do an offline defrag. To do that:

What you need to do is:
1. Dismount Store
2: cd "C:\Program Files\exchsrvr\bin"
3. eseutil /d  X:\exchsrvr\mdbdata\priv1.edb /tS:\tempdfg.edb

Replace X: and S: with the appropriate drive letters.

Make sure you have enough space on S drive (database + 25%)
0
 
LVL 9

Expert Comment

by:akitsupport
ID: 36502732
Have you upgraded too SP2?

If not you should do if you have follow this article from Microsoft on taking it above the 18Gb limit.

http://support.microsoft.com/kb/912375

0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 96

Expert Comment

by:Lee W, MVP
ID: 36502810
An offline defrag will do nothing to remedy this properly

> Have you upgraded too SP2?
Of course he has - or this would have been happening at 16 GB, not 18 GB.

ravenrx7 - have you restarted the computer or information store after making the change?  Can you post a screenshot of exactly what it looks like now with the change?
0
 

Author Comment

by:ravenrx7
ID: 36502934
I have upgraded to SP2 yes sir
0
 

Author Comment

by:ravenrx7
ID: 36502939
sorry yes i had to restart the information store today becasue the mail wasnt working
0
 

Author Comment

by:ravenrx7
ID: 36502978
Guys, on Monday I had to run a system state restore on the server and I just checked the reg entry and it was gone, this probably is the answer.

I name the reg word  Database Size Limit in GB correct?
0
 
LVL 9

Accepted Solution

by:
akitsupport earned 2000 total points
ID: 36503136
Right so a system state restore as you've mentioned could of caused the issue.

    On the computer that is running Exchange 2003 SP2, click Start, click Run, type regedit, and then click OK.

    Click one of the following registry subkeys, as appropriate for the store that you want to increase:
        For a mailbox store, click the following registry subkey:

        HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\Server name\Private-Mailbox Store GUID

        For a public folder store, click the following registry subkey:
        HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\Server name\Public-Public Store GUID

    On the Edit menu, point to New, and then click DWORD Value.

    In the New Value #1 box, type Database Size Limit in Gb, and then press ENTER.

    Right-click Database Size Limit in Gb, and then click Modify.
    Click Decimal, and then type an integer from 1 to 75 in the Value data box.

    Note These integer values represent the maximum size of the database in gigabytes (GB). For example, a value of 75 represents a database that has a maximum size of 75 GB.

    Click OK, and then exit Registry Editor.

    Restart the Microsoft Exchange Information Store service. To do this, follow these steps:
       
Click Start, click Run, type cmd, and then click OK.
        At the command prompt, type the following command, and then press ENTER:
        net stop msexchangeis
       
After the Microsoft Exchange Information Store service has stopped successfully, type the following command, and then press ENTER:
        net start msexchangeis
   
Examine the Application log to verify that the database size has been set successfully. To do this, follow these steps:
       
Click Start, click Run, type eventvwr, and then click OK.
In the Event Viewer tool, click Application.

Double-click event ID 1216 to verify that the database size has been set successfully.

0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question