Help with Centos kernal upgrade

I am running a Centos box on a Dell R410 with a quad core processor.  Currently I am running kernal version 2.6.18-238.el5PAE (Jan 13, 2011).  I am looking to upgrade to 2.6.18-238.12.1.el5PAE which is May 2011.  I tried running yum update kernal but no packages were found.  Any help would be great.
ipconfig610Asked:
Who is Participating?
 
PapertripConnect With a Mentor Commented:
Try 'install' instead of 'update'.
0
 
rindiCommented:
Maybe you have to get the spelling for "kernal" right, like as "yum update kernel"? Also, if you want a particular kernel, and not the newest one for your distro that is available, then you would have to include the complete string, like "yum update kernel-PAE-2.6.18-238.12.1.el5.i686".

Otherwise, if you just need the newest kernel available, you can just run yum update, which will update everything, not just the kernel. That would ensure that the system is optimally patched.
0
 
kaskhedikar_tusharCommented:
Hello,


Do that mannually , before upgrading kernel , please take back up of boot loader.

Download rpm & install it

http://www.centos.org/docs/5/html/Deployment_Guide-en-US/s1-kernel-preparing.html

Take the backup of grub (Bootloader)

http://www.linuxforums.org/forum/red-hat-fedora-linux/37599-how-backup-grub.html
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
ipconfig610Author Commented:
I tried yum update kernel-PAE-2.6.18-238.12.1.el5.i686 and received the following error.  looks like the packages are available but excluded in our yum config.  Below is my yum.conf


ERROR:
19 packages excluded due to repository priority protections
Setting up Update Process
Package(s) kernel-PAE-2.6.18-238.12.1.el5.i686 available, but not installed.
No Packages marked for Update


YUM.CONF
[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
distroverpkg=redhat-release
tolerant=1
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
bugtracker_url=http://bugs.centos.org/set_project.php?project_id=16&ref=http://bugs.centos.org/bug_report_page.php?category=yum

# Note: yum-RHN-plugin doesn't honor this.
metadata_expire=1h

installonly_limit = 5

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d
reposdir=/etc/yum.repos.d

0
 
rindiCommented:
There are probably too many dependencies which would have to get updated too. Why don't you just use yum update to get the newest version of the kernel and the rest of the updates? The version that came out after the one you want is: kernel-PAE-2.6.18-238.19.1.el5.i686 from the 18th of July. In my opinion it is best to keep uptodate.
0
 
ipconfig610Author Commented:
the yum update was the first thing i tried.  I receive the same message "19 packages excluded due to repository priority protections" and nothing to install.
0
 
rindiCommented:
I don't know yum well enough, but maybe you can check your logs for any packages listed that are held back.
0
 
PapertripCommented:
Sounds like this is being caused by the package yum-priorities.

If you feel overwhelmed to go and edit the priority setting for each repo which is the "proper" solution, change enabled to 0 in /etc/yum/pluginconf.d/priorities.conf

[main]
enabled=0

Open in new window


Be sure to turn it back on after!
0
 
ipconfig610Author Commented:
I changed enable to 0 and ran:  yum update kernel-PAE-2.6.18-238.12.1.el5.i686

I still get:
Setting up Update Process
Package(s) kernel-PAE-2.6.18-238.12.1.el5.i686 available, but not installed.
No Packages marked for Update
0
 
PapertripCommented:
Is that *all* of the output you get after running yum?

try:

yum update kernel-PAE

Open in new window

0
 
ipconfig610Author Commented:
tried that too.

[root@fs16(primary) ~]# yum update kernel-PAE
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.metrocast.net
 * dell-community: linux.dell.com
 * extras: mirror.net.cen.ct.gov
 * updates: centos.mirror.choopa.net
Setting up Update Process
No Packages marked for Update
0
 
ipconfig610Author Commented:
woohoo!!  That fixed it.  Thanks!
0
 
PapertripCommented:
My bad I didn't pay enough attention to the issue at first.

Upgrade is going to remove the old package and install the new.  Be glad that yum won't let you 'update' your running kernel :)

In your /etc/grub.conf, you will probably want to change the default value.  In that file you will see all the installed kernels you have, each starting with a 'Title' line.  Count those, starting at 0, find your new kernel, and change the default to that number.

Reboot and you are done!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.