Solved

LDAP client fails to communicate with server

Posted on 2011-09-08
6
2,933 Views
Last Modified: 2013-12-24
Hi

I have just configured a Sharp MX2600 MFD to pull address off out Active Directory which is in a Server 2008 DC.

The problem is that the connection test is failing, returning error 3333 which states "LDAP Port is invalid", even though I have specified port 389 (the default LDAP port) in the printer configuration.

Is there anything I need to do on the server to make sure it's listening on port 389? How can I check it?
0
Comment
Question by:Jason210
  • 3
  • 3
6 Comments
 
LVL 18

Accepted Solution

by:
BigSchmuh earned 500 total points
ID: 36529378
I think a basic "Telnet YourLDAPServerIPAddress 389" would allow to check that the port is being listened to on the LDAP server.

You should get a "can not connect" which will prove your favorite "network admin" that he has a IP/port to open on his super-secured firewall...
0
 
LVL 11

Author Comment

by:Jason210
ID: 36530153
Thanks...

I am that network admin :-) and port 389 is open. In fact just to make sure  I opened all the ports for a minute and tested it again.
0
 
LVL 18

Assisted Solution

by:BigSchmuh
BigSchmuh earned 500 total points
ID: 36530283
Before setting the LDAP authentication on your printer, were you able to print ?
Did you try to telnet your DC on port 389 ?
Did you try refering to your DC server using an IP instead of its name ?
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 11

Author Comment

by:Jason210
ID: 36543486
>Before setting the LDAP authentication on your printer, were you able to print ?
Yes

>Did you try to telnet your DC on port 389 ?
No, I checked it with nnap (results attached)

>Did you try refering to your DC server using an IP instead of its name ?
Yes
389/tcp   open  ldap

Open in new window

0
 
LVL 18

Assisted Solution

by:BigSchmuh
BigSchmuh earned 500 total points
ID: 36547844
Are you sure that the printer security settings does not enforce SSL for LDAP (Port 636 or 3269) instead of LDAP (389) ?
0
 
LVL 11

Author Comment

by:Jason210
ID: 36559289
I found the problem!

All the settings were correct, except one: Enable LDAP! I don't know how I managed to miss it but I did.

All your suggestions were valid so I'm awarding you points anyway!

Thanks!
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

SQL Command Tool comes with APEX under SQL Workshop. It helps us to make changes on the database directly using a graphical user interface. This helps us writing any SQL/ PLSQL queries and execute it on the database and we can create any database ob…
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
Video by: Steve
Using examples as well as descriptions, step through each of the common simple join types, explaining differences in syntax, differences in expected outputs and showing how the queries run along with the actual outputs based upon a simple set of dem…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now