Solved

Exchange 2003 OWA stopped working externally

Posted on 2011-09-08
15
371 Views
Last Modified: 2012-05-12
We have a SBS 2003 server.  For years we have been using OWA with self signed certificate. To login to OWA we used to use https://xxx.xxx.xxx.xxx/exchange.   I recently (few weeks ago) I installed a SSL certficate and everything was working fine until the server was rebooted yesterday.  There was some updates applied during reboot.  FYI.  After I configured SSL, I did not reboot the server.  This was the first time server rebooted since SSL change.   Now we can not access OWA externally.  I checked internally and use http://servername/exchange and that logs me directly into OWA mailbox of current user logged in.  For example, if I use http;//username/exchange on a user workstation, it will log me directly into that user without a login prompt like we were used to seeing.  So what I am really concerned about is the external link to OWA not working. Can anyone shed some light on my issue?  I will provide more info as needed.  Thank you.
0
Comment
Question by:itechresults
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 3
  • 2
15 Comments
 
LVL 23

Expert Comment

by:Suliman Abu Kharroub
ID: 36503377
How do you configure external access ? publish through ISA/TMG or port forwarding ?

what is the error message you get?
0
 

Author Comment

by:itechresults
ID: 36503451
I port forwarded 443 to server IP.  No ISA on SBS.  Error I receive is "The page cannot be found"  HTTP Error 404 - File or directory not found.
0
 
LVL 23

Expert Comment

by:Suliman Abu Kharroub
ID: 36503573
try to access it using IP address, what happen ?

also check the router (firewall) settings, make sure it forward to the correct server.
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 

Author Comment

by:itechresults
ID: 36503626
I tried using IP address and get same exact error message.  I just double checked firewall settings and they are correct.
0
 

Author Comment

by:itechresults
ID: 36503686
I also tried resetting default virtual directories for OWA using method 2.  http://support.microsoft.com/kb/883380
0
 
LVL 17

Expert Comment

by:Spartan_1337
ID: 36503722
Can you verify your public IP and then verify external URL IP?
0
 

Author Comment

by:itechresults
ID: 36503771
Hi Spartan:

What do you mean?  Our public IP has not changed and external URL IP is https://remote.domain.com.  An A record is setup pointing to server public IP.
0
 
LVL 17

Expert Comment

by:Spartan_1337
ID: 36503898
Did you have any redirects setup? Can you look at your firewall/router and verify that the traffic is being properly routed to the server?

0
 

Author Comment

by:itechresults
ID: 36503981
No redirects.  Firewall is configured properly
0
 

Author Comment

by:itechresults
ID: 36504013
If I use external https://remote.domain.com  without /exchange in url; it brings me to our old hosted website on our sbs server.  If I use /exchange I get the error mentioned.  Also I can see the certificate I setup when accessing either urls
0
 

Author Comment

by:itechresults
ID: 36505055
Any experts out there with new suggestions???
0
 
LVL 23

Expert Comment

by:Suliman Abu Kharroub
ID: 36505610
Had you tried iisrset ?
0
 

Author Comment

by:itechresults
ID: 36505744
Just tried iisreset and still have same issue
0
 

Accepted Solution

by:
itechresults earned 0 total points
ID: 36508434
Problem solved.  When I setup ssl; I created a website in iis with same name as external url.  This caused a dns issue after server was rebooted
0
 

Author Closing Comment

by:itechresults
ID: 36527988
i resolved my own problem
0

Featured Post

Salesforce Made Easy to Use

On-screen guidance at the moment of need enables you & your employees to focus on the core, you can now boost your adoption rates swiftly and simply with one easy tool.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question