Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

How do I fix slow first web service responses (17+ seconds) from iis7 on Windows 2008 Server?

Posted on 2011-09-08
9
Medium Priority
?
1,227 Views
Last Modified: 2012-06-27
We've just upgraded our server from Windows 2000 Server to Windows 2008 Server 64-bit and copied the .NET 2005 web services across to the new server.
We've still kept the old server and it's response times are always fast.
The new server's first response is slow and then fast subsequently but if not used for a couple of minutes resort to first response (slow) mode.
I've looked into (this (Q_27241923)) (application pool) solution but I can't get it to work.
0
Comment
Question by:kev1970
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
  • +1
9 Comments
 
LVL 9

Accepted Solution

by:
Tehzar earned 400 total points
ID: 36503508
0
 

Author Comment

by:kev1970
ID: 36503868
I've scanned that article but I think that what I need is force IIS7 to stop unloading the web service.
0
 
LVL 9

Assisted Solution

by:Grant Spiteri
Grant Spiteri earned 400 total points
ID: 36506742
We came across the same issue basically definitely have a look @ Tehzar's link as well as the following link is what we used:
http://blogs.iis.net/thomad/archive/2009/10/14/now-available-the-iis-7-5-application-warm-up-module.aspx

0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 9

Expert Comment

by:Grant Spiteri
ID: 36506761
My apologies looks like it has been discontinued.
0
 
LVL 3

Expert Comment

by:Srm74
ID: 36509293
First time you access a .Net service, it "compiles" it, which is why it takes some time.

Your service uses an app pool. If the service is not used for a timeout period, it is recycled.
The next time its used, it's "compiled" again.

You need to set this timeout up, to postpone recycling ..

Hope this helps..
0
 

Author Comment

by:kev1970
ID: 36509901
Srm74,
Thanks, that's what I tried to base my original solution on but it doesn't seem to work in Windows Server 2008/IIS7.
I'm assuming that you referring to the "Idle Time-out (minutes)" property. I've set it to 0 so, theoretically, it should never timeout.
What are the exact settings required stop web services from unloading in IIS7?
0
 
LVL 3

Assisted Solution

by:Srm74
Srm74 earned 400 total points
ID: 36509973
Hi,

Yes, setting it to 0 should disable the idle timeout.

Provinding its not caused by an error, try checking the periodic restart settings..

Periodic restart

Other than that, i should work..
0
 

Assisted Solution

by:kev1970
kev1970 earned 0 total points
ID: 37099377
I apologise for the long delay (holiday, other work issues, ...).

IIS wasn't unloading the web services, as I thought. The problem was resolved by re-naming the server.

To summarise, the server had 2 web sites which had 2 different names which we registered manually in the DNS server (ie IntServ - 10.118.6.1 and IntServ2 - 10.118.6.2). The server and one of it's web sites had identical names (IntServ) and unfortunately, with Windows Server 2008 SP2, this meant that every time the server was rebooted, the DNS server ensured that all of the IP addresses were registered against the server name (http://support.microsoft.com/kb/975808). IntServ would, thus, have 2 DNS entries registered against it, for 10.118.6.1 and 10.118.6.2 respectively, which caused the DNS server to resolve IntServ in a round-robin fashion.
To fix this we re-named the server (ie ServerIntServ) which meant that the DNS server would register the 2 IP addresses against ServerIntServ and IntServ would always maintain it's 1 DNS entry. ServerIntServ will now round-robin which won't affect the end users.

I don't understand the mechanics of this resolution as we always ensured that IntServ only had one entry in the DNS server by deleting the 2nd entry when neccessary.

Subsequent IntServ web service hits have responded in less than 1 sec and even after 15 hours the response-time was less than 7 secs.
0
 

Author Closing Comment

by:kev1970
ID: 37126685
This was a Windows Server 2008 SP2 and DNS issue and not an IIS issue. Unfortunately, no one pointed me in that direction.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Logparser is the smartest tool I have ever used in parsing IIS log files and there are many interesting things I wanted to share with everyone one of the  real-world  scenario from my current project. Let's get started with  scenario - How do w…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question