Solved

How do I force Windows 7 startup to finish before logon is allowed?

Posted on 2011-09-08
5
1,291 Views
Last Modified: 2012-05-12
I am trying to get my Windows 7 workstations to wait until all the Startup policies have finished before allowing the user to logon.  My Windows 7 workstations don't behave this way.  To test this I've created a group policy that runs the following script:

Dim objFSO
Set objFSO = CreateObject("Scripting.FileSystemObject")
Dim objOutput
Set objOutput = objFSO.CreateTextFile("C:\Test.txt", True)
objOutput.WriteLine(Now() & " - Sleeping for 5 minutes.")
WScript.Sleep 300000
objOutput.WriteLine(Now() & " - Finished sleeping.")
objOutput.Close

When the workstation is started, the logon screen is presented immediately.  If I log on and check the file that the script creates, only the first line appears.  The second line appears 5 minutes later.

How can I force Windows 7 workstations to wait until all startup wscripts are finished before allowing a user to logon?  I've enabled the 'Always wait for network at computer startup and logon", which didn't help.

0
Comment
Question by:CousinDupree
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 22

Accepted Solution

by:
Joseph Moody earned 500 total points
ID: 36505286
Disable Run Startup Scripts asynchronously (if you have it enabled).
0
 

Author Comment

by:CousinDupree
ID: 36505911
I don't have it enabled.

0
 
LVL 11

Expert Comment

by:X_layer
ID: 36506170
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 36506204
Description of the Windows XP Professional Fast Logon Optimization feature
http://support.microsoft.com/kb/305293

Still applies to Win7, also helps to explain why the behavior is the way it is.....
0
 

Author Closing Comment

by:CousinDupree
ID: 36506285
It turns out that Jmoody10 was on the right track.  In Windows 7, you need to set  'Run Startup Scripts Asynchronously' to disabled to get startup scripts to run synchronously.  Previous versions of Windows ran startup scripts synchronously by default, but Windows 7 runs them asynchronously by default.  Setting 'Computer Configuration->Policies->Administrative Templates->System->Scripts->Run Startup Scripts Asynchronously' to 'Disabled' fixed my issue.  Setting the policy setting to 'Not Configured' did NOT work!
0

Featured Post

PeopleSoft Has Never Been Easier

PeopleSoft Adoption Made Smooth & Simple!

On-The-Job Training Is made Intuitive & Easy With WalkMe's On-Screen Guidance Tool.  Claim Your Free WalkMe Account Now

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Last week, our Skyport webinar on “How to secure your Active Directory” (https://www.experts-exchange.com/videos/5810/Webinar-Is-Your-Active-Directory-as-Secure-as-You-Think.html?cid=Gene_Skyport) provided 218 attendees with a step-by-step guide for…
This article explains the steps required to use the default Photos screensaver to display branding/corporate images
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question