Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 729
  • Last Modified:

4.3.1 Insufficient System Resources on Exchange 2007

Hi,

My client has been reporting intermittent email flow when receiving email.  They will go for stretches of hours without receiving email.  I checked the boards and found suggestions on telneting to the server and using the command MAIL FROM:admin@test.com.  This returns the 4.3.1 Insufficient System Resources message.

I edited the EdgeTransport.exe.config file and disabled Back Pressure setting and changed the Queue path to the D drive and restarted the Transport service as well as the server.  In both cases, the email is not flowing and I still receive the above message when telneting.

They are using SBS2008 server.

Any suggestions are appreciated.

Rick
0
rmegni
Asked:
rmegni
  • 6
  • 5
  • 5
  • +2
2 Solutions
 
madhatter5501Commented:
check the space on all the hard drives, most likely there are still some logs on the c: drive building up and causing this issue
0
 
rmegniAuthor Commented:
Hi,

Can you be more specific?  What folder paths should i check?

Thanks
0
 
madhatter5501Commented:
here is an article that is relating you what is going on with your server

http://exchangeserverpro.com/exchange-server-2007-event-id-15002-and-431-insufficient-system-resources-errors

when you said you moved the queue logs, did you also move the exchange transport queue database?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
AkhaterCommented:
This can only be back pressure,

Check the event log and you will know what is causing the back pressure.

Clear the log and restart the transport service
0
 
rmegniAuthor Commented:
I only changed the value with key QueueDatabasePath to the D drive where there is over 1Tb of drive space available.

Should I redirect the key QueueDatabaseLoggingPath as well?
0
 
madhatter5501Commented:
yes
0
 
madhatter5501Commented:
then restart the transport service like recommended above, if that doesn't work, the restart the server
0
 
Alan HardistyCo-OwnerCommented:
Here is an article I wrote which gives you a quick fix for the problem (BackPressure), which as stated above is either caused by lack of disk space or lack of system resources:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_4259-Exchange-2007-2010-Backpressure-Quick-Fix.html
0
 
madhatter5501Commented:
nice article, good way to get the server going quick for clean up later
0
 
Alan HardistyCo-OwnerCommented:
Thanks - That's the plan.
0
 
rmegniAuthor Commented:
Hi Guys,

Once I redirected the Log path all is good.

Thanks!  You guys were terrific at helping me quickly solve this for my client.

Rick
0
 
Alan HardistyCo-OwnerCommented:
Backpressure is a great 'feature' if you haven't come across it before - but the Insufficient Resources message = Backpressure has kicked in.

Need to get your client to keep on top of their disk space to make sure that Backpressure doesn't bite them on the backside again.  Are they taking backups with an Exchange Aware backup program?
0
 
rmegniAuthor Commented:
No.  Any good recommendations?
0
 
madhatter5501Commented:
I like the built in Windows Backup, there is also a few other paid backup solutions but for me the built in backup works good
0
 
Alan HardistyCo-OwnerCommented:
Use the built-in SBS backup - it will purge the Exchange logs happily.

You can plug in an external HDD or an internal HDD dedicated to holding the backups (the larger the better) and then configure the backups to use the drive, then the logs shouldn't consume huge amounts of space and the issue should happen again (for the same reason).

As you have SBS - which includes WSUS, disable the logs in IIS for the WSUS virtual Directory and then purge the logs - they will grow and chew up your C: drive very quickly.
0
 
rmegniAuthor Commented:
Excellent!  Thanks.
0
 
Alan HardistyCo-OwnerCommented:
You're welcome.  I have found the WSUS logs eating about 30Gb of disk space!  As if anyone is going to look through them :)
0
 
excell-tecCommented:
Any reason why after I canged the line to false all emails trying to be sent are going into the draft folder and not being sent now?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 6
  • 5
  • 5
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now