Centos Qemu dump virtual machine when shutdown


I'm working with qemu under Centos and when I shutdown the host computer it start dumping the the guest machines into /var/lib/libvirt/qemu/save and I don't have too much space in my hard drive. So I want to change the directory of that dump or disable it.

Who is Participating?
wesly_chenConnect With a Mentor Commented:
In /etc/libvirt/qemu.conf
 hugetlbfs_mount = "/dev/hugepages"
hugetlbfs_mount = ""

And reboot your system.
All the configuration are under

Find out where is the setting:
grep  "/var/lib/libvirt/qemu/save"   /etc/libvirt/qemu.conf
grep  "/var/lib/libvirt/qemu/save"   /etc/libvirt/qemu/*

(post the result here)
nociSoftware EngineerCommented:
There are more or less 3 solutions to this:

If you have a different disk you can mount the disk on to the /var/lib/libvirt/qemu/save direcotry
mount /dev/blabla /var/lib/libvirt/qemu/save

Or if you have room to spare on a different disk that allready is mounted
then you can use mount --bind to use a detour:
  mount --bind /somedir/whereever /var/lib/libvirt/qemu/save

This might also be possible using symbolic links, if like:

mv /var/lib/libvirt/qemu/save/* /somedir/whereever/
rmdir /var/lib/libvirt/qemu/save    
ln -s /somedir/whereever /var/lib/libvirt/qemu/save

The mount's can be added to the /etc/fstab file to enable them during boot
the ln -s needs to be done once.
A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

luis_chiangAuthor Commented:
[root@m23 /]# grep  "/var/lib/libvirt/qemu/save"   /etc/libvirt/qemu.conf
[root@m23 /]# grep  "/var/lib/libvirt/qemu/save"   /etc/libvirt/qemu/*
luis_chiangAuthor Commented:
Hi noci:

Unfortunately I don't have enough space or another disk, =( what is I point the folder to /dev/null ? these could be possible?

luis_chiangAuthor Commented:
Hi wesly_chen.

But I didn't find the variable in the configuration file (attached with .txt extension) qemu.txt
nociSoftware EngineerCommented:
/dev/null doesn't behave like a folder so that won't help.
Did you try renaming the save directory to save.nosave   (doesn't work if the directory is auto created..)

or modifying it's protection to no access?

chmod 000 /var/lib/libvirt/qemu/save

Take out the comment "#"
luis_chiangAuthor Commented:
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.