troubleshooting Question

Windows 7 Will not Install USB Devices

Avatar of gfunk9132
gfunk9132 asked on
Windows 7
5 Comments1 Solution2522 ViewsLast Modified:
I've recently reloaded my workstation because I could not install any USB devices.  After reloading with WIndows 7 Ultimate x64 and running Windows Update everything was working well.  Now, 3 days later the problem has returned on my new workstation.  I've searched the setupapi.dev log immediately after trying to connect say a USB thumb drive below is a portion of the log:

Device Install (DiShowUpdateDevice) - USB\VID_22B8&PID_4285\0158ED840C01D020]
>>>  Section start 2011/09/08 21:57:11.719
      cmd: "C:\Windows\system32\mmc.exe" "C:\Windows\system32\compmgmt.msc" /s
     dvi: {DIF_UPDATEDRIVER_UI} 21:57:11.719
     dvi:      No class installer for 'MB810'
     dvi:      No CoInstallers found
     dvi:      Default installer: Enter 21:57:11.719
     dvi:      Default installer: Exit
     dvi: {DIF_UPDATEDRIVER_UI - exit(0xe000020e)} 21:57:11.719
     ndv: {Update Driver Software Wizard for USB\VID_22B8&PID_4285\0158ED840C01D020}
     inf:      Opened PNF: 'C:\Windows\INF\usbstor.inf' ([strings.0409])
     inf:      {SetupCopyOEMInf: C:\Windows\INF\usbstor.inf} 21:57:15.369
     inf:           Driver Store location: C:\Windows\System32\DriverStore\FileRepository\usbstor.inf_amd64_neutral_26b33263a639795d\usbstor.inf
     inf:           Published Inf Path: C:\Windows\INF\usbstor.inf
     inf:           Opened PNF: 'C:\Windows\INF\usbstor.inf' ([strings.0409])
     inf:           OEM source media location: C:\Windows\INF\
!    inf:           Unable to set OEM source media location - error ignored
!    inf:           Error 87: The parameter is incorrect.
     inf:      {SetupCopyOEMInf exit (0x00000000)} 21:57:15.401
     dvi:      Searching for hardware ID(s):
     dvi:           usb\vid_22b8&pid_4285&rev_0216
     dvi:           usb\vid_22b8&pid_4285
     dvi:      Searching for compatible ID(s):
     dvi:           usb\class_08&subclass_06&prot_50
     dvi:           usb\class_08&subclass_06
     dvi:           usb\class_08
     inf:      Opened PNF: 'C:\Windows\System32\DriverStore\FileRepository\usbstor.inf_amd64_neutral_26b33263a639795d\usbstor.inf' ([strings.0409])
     dvi:      Selected driver installs from section [USBSTOR_BULK] in 'c:\windows\system32\driverstore\filerepository\usbstor.inf_amd64_neutral_26b33263a639795d\usbstor.inf'.
     dvi:      Class GUID of device changed to: {36fc9e60-c465-11cf-8056-444553540000}.
     dvi:      Set selected driver complete.
     dvi:      {Plug and Play Service: Device Install for USB\VID_22B8&PID_4285\0158ED840C01D020}
     ump:           Creating Install Process: DrvInst.exe 21:57:15.401
     ump:           Server install process exited with code 0xc0000142 21:57:15.416
     ump:      {Plug and Play Service: Device Install exit(c0000142)}
     ndv:      Device Install failed for new device...installing NULL driver.
     dvi:      {Plug and Play Service: Device Install for USB\VID_22B8&PID_4285\0158ED840C01D020}
     ump:           Creating Install Process: DrvInst.exe 21:57:15.416
     ump:           Server install process exited with code 0xc0000142 21:57:15.432
     ump:      {Plug and Play Service: Device Install exit(c0000142)}
     ndv: {Update Driver Software Wizard exit(c0000142)}
<<<  Section end 2011/09/08 22:03:02.445
<<<  [Exit status: FAILURE(0xc0000142)]


>>>  [Device Install (Hardware initiated) - USB\VID_22B8&PID_4285\0158ED840C01D020]
>>>  Section start 2011/09/08 22:00:43.116
     ump: Creating Install Process: DrvInst.exe 22:00:43.122
     ump: Server install process exited with code 0xc0000142 22:00:43.146
<<<  Section end 2011/09/08 22:00:43.148
<<<  [Exit status: FAILURE(0xc0000142)]


>>>  [Device Install (Hardware initiated) - USB\VID_22B8&PID_4285\0158ED840C01D020]
>>>  Section start 2011/09/08 22:15:17.599
     ump: Creating Install Process: DrvInst.exe 22:15:17.599
     ump: Server install process exited with code 0xc0000142 22:15:17.631
<<<  Section end 2011/09/08 22:15:17.631
<<<  [Exit status: FAILURE(0xc0000142)]


[Boot Session: 2011/09/08 22:15:55.359]

>>>  [Device Install (Hardware initiated) - USB\VID_0000&PID_0000\5&28b2efbf&0&1]
>>>  Section start 2011/09/08 22:16:24.894
     ump: Creating Install Process: DrvInst.exe 22:16:24.894
     ump: Server install process exited with code 0xc0000142 22:16:24.957
<<<  Section end 2011/09/08 22:16:24.957
<<<  [Exit status: FAILURE(0xc0000142)]


>>>  [Device Install (Hardware initiated) - usb\vid_0000&pid_0000\5&28b2efbf&0&1]
>>>  Section start 2011/09/08 22:16:24.957
     ump: Creating Install Process: DrvInst.exe 22:16:24.957
     ump: Server install process exited with code 0xc0000142 22:16:24.972
<<<  Section end 2011/09/08 22:16:24.972
<<<  [Exit status: FAILURE(0xc0000142)]


>>>  [Device Install (Hardware initiated) - USB\VID_22B8&PID_4285\0158ED840C01D020]
>>>  Section start 2011/09/08 22:17:04.490
     ump: Creating Install Process: DrvInst.exe 22:17:04.490
     ump: Server install process exited with code 0xc0000142 22:17:04.490
<<<  Section end 2011/09/08 22:17:04.490
<<<  [Exit status: FAILURE(0xc0000142)]


[Boot Session: 2011/09/08 22:20:15.375]

>>>  [Device Install (Hardware initiated) - USB\VID_22B8&PID_4285\0158ED840C01D020]
>>>  Section start 2011/09/08 22:21:15.216
     ump: Creating Install Process: DrvInst.exe 22:21:15.216
     ump: Server install process exited with code 0xc0000142 22:21:15.357
<<<  Section end 2011/09/08 22:21:15.357
<<<  [Exit status: FAILURE(0xc0000142)]


>>>  [Device Install (Hardware initiated) - USB\VID_0781&PID_5406\0572730CEAD147DC]
>>>  Section start 2011/09/08 22:23:10.302
     ump: Creating Install Process: DrvInst.exe 22:23:10.302
     ump: Server install process exited with code 0xc0000142 22:23:10.405
<<<  Section end 2011/09/08 22:23:10.405
<<<  [Exit status: FAILURE(0xc0000142)]


>>>  [Device Install (Hardware initiated) - USB\VID_0781&PID_5406\0572730CEAD147DC]
>>>  Section start 2011/09/08 22:39:18.182
     ump: Creating Install Process: DrvInst.exe 22:39:18.182
     ump: Server install process exited with code 0xc0000142 22:39:18.214
<<<  Section end 2011/09/08 22:39:18.214
<<<  [Exit status: FAILURE(0xc0000142)]


>>>  [Device Install (Hardware initiated) - USB\VID_22B8&PID_4285\0158ED840C01D020]
>>>  Section start 2011/09/08 22:54:20.934
     ump: Creating Install Process: DrvInst.exe 22:54:20.934
     ump: Server install process exited with code 0xc0000142 22:54:20.965
<<<  Section end 2011/09/08 22:54:20.965
<<<  [Exit status: FAILURE(0xc0000142)]


>>>  [Device Install (Hardware initiated) - USB\VID_0781&PID_5406\0572730CEAD147DC]
>>>  Section start 2011/09/08 22:55:07.695
     ump: Creating Install Process: DrvInst.exe 22:55:07.695
     ump: Server install process exited with code 0xc0000142 22:55:07.711
<<<  Section end 2011/09/08 22:55:07.711
<<<  [Exit status: FAILURE(0xc0000142)]


Basically it's coming down to what the hell is error 0xc0000142?  The only thing I can think of that caused this problem was after installing IntelliPoint for my keyboard and mouse, I did remove it to no avail.  I've tried almost everything that other's are suggesting.  
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 5 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 5 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros