Solved

Windows 7 Windows IP Configuration Blank after Service Pack install

Posted on 2011-09-09
27
1,395 Views
Last Modified: 2012-06-21
I have a Windows 7 32bit workstation that has no Internet Connection. This has only happened after the Windows 7 SP1 was installed. If I do a ipconfig I get the following result with no IP address -

Windows IP Configuration

I have seen this before on a XP workstation and I ran a "netsh winsock reset" command and it was able to resolve it. This is not the case with my current problem. I tried to do a restore but all my restore points are gone since the service pack update.

Any ideas how I can resolve this issue? Let me know if you require any additional information.
0
Comment
Question by:dextor03
  • 8
  • 6
  • 5
  • +5
27 Comments
 
LVL 87

Expert Comment

by:rindi
ID: 36509461
Make sure you have the correct drivers installed (NIC, Chipset etc.).
0
 
LVL 6

Expert Comment

by:Shaun Rieman
ID: 36509464
I know this sounds really, really simple but have you tried the Windows 7 network diagnostics tool?
0
 

Author Comment

by:dextor03
ID: 36509473
Latest drivers are installed and I've tried the diagnostics tool but no joy.
0
 
LVL 2

Expert Comment

by:LondonCitizen
ID: 36509490
As Rindi suggested, might be issue with your NIC, try to look in device manager and see if you can see any problems. Try to uninstall and reinstall NIC.

Can you set static ip address on your NIC and ping your gateway?
Let me know what the results are.

Could you post screenshot or full output of your ipconfig /all ?
Thanks.
0
 

Author Comment

by:dextor03
ID: 36509559
I've uninstalled and reinstalled the NIC but still the same problem.

I've tried to assign a static IP address but it will not give me the "Properties" option. The only option I have is "Install"

I have ran the ipconfig /all command and I receive the following -

Windows IP Configuration

Hostname. . . . . . . . . . . . . . . . . . . .: Hostname
Primary DNS Suffix. . . . . . . . . . . . .:
Node Type. . . . . . . . . . . . . . . . . . . :No
IP Routing Enabled. . . . . . . . . . . . . No
WINS Proxy Enabled. . . . . . . . . . . :Hybrid

0
 
LVL 87

Expert Comment

by:rindi
ID: 36509576
Post a screenshot of the device manager. To me it looks as if there is no physical NIC available.
0
 

Author Comment

by:dextor03
ID: 36509594
Screenshot attached.
Doc1.doc
0
 
LVL 87

Expert Comment

by:rindi
ID: 36509665
And what is shown when you open the network and sharing center, then select Change adapter Settings?
0
 
LVL 4

Expert Comment

by:Daelt
ID: 36509668
try disabling all network cards except the broadcom one, check that your network cable is inserted in the right ethernet port.
Restart the machine, see the results.
0
 

Author Comment

by:dextor03
ID: 36509765
See attached.

I've disabled all network cards except for the broadcom and restarted. No difference.
Doc1.docx
0
 
LVL 6

Expert Comment

by:Shaun Rieman
ID: 36509771
Are you sure it isn't a virus or spyware issue?  Have you run Malwarebytes?
0
 
LVL 87

Expert Comment

by:rindi
ID: 36509804
I meant the view before that, is the adapter "Enabled"?
0
 

Author Comment

by:dextor03
ID: 36509815
Have ran a Malwarebytes scan and it's clean.

Yes, the adapter is enabled.
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 87

Expert Comment

by:rindi
ID: 36509920
Try deleting the adapter from device manager, then restart the PC and allow it to install it again, then try getting a connection.
0
 
LVL 6

Expert Comment

by:Shaun Rieman
ID: 36509928
0
 
LVL 2

Expert Comment

by:LondonCitizen
ID: 36510077
To me it still looks like malfunctioning NIC or incorrect drivers. Can you replace NIC to rule out this option, you might save yourself alot of trouble before we blame software settings.
0
 
LVL 2

Expert Comment

by:LondonCitizen
ID: 36510086
Can you try to allocate NIC to another slot too if possible, just in case there is something wrong with motherboard.
0
 
LVL 2

Expert Comment

by:LondonCitizen
ID: 36510127
LondonCitizen:
 
The only option I have is "Install"

Assuming your hardware, drivers are ok, it look like Service pack uninstalled your TCP IPV4.
Looks like it needs to be reinstalled.
0
 
LVL 2

Expert Comment

by:LondonCitizen
ID: 36510162
Click on Internet Protocol TCP / IPv4.
If you see Install then click and choose Protocol, Add, choose Have Disk.
browser to c:\windows\inf and then click OK.
On the list choose Internet Protocol (TCP/IPv4), hit OK and you might need to restart.
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 36510399
In Device Manager>View, and check "Show Hidden Devices">Expand "Non plug and play drivers". Anything there with a problem?

Also, in the Event Viewer>Windows Event Logs>System, do you see any errors from the source "Service Control Manager"? Might be something like the AFD/IPSec driver not starting.....
0
 

Author Comment

by:dextor03
ID: 36510593
Ok, I've added a USB NIC card to the system and installed it but getting the same result. The NIC appears to be installed correctly but if I do an ipconfig the results are blank. I think the original drivers for the NIC card are fine and the NIC card is working but the problem exists with the TCP/IP protocol.

I also tried to install the TCP/IP protocol but I cannot find the "inf" file in the Windows directory. Could it be somewhere else?

0
 
LVL 2

Expert Comment

by:Mike
ID: 36510656
Do you have other devices running on your home network?

Do you have activity or connection lights on the back of your NIC?

Can you use static IP information?
0
 

Author Comment

by:dextor03
ID: 36510696
Other devices on the network are fine.

Have link lights on the back of both NICs as both are now connected.

Cannot add static address as I do not have the option to go into properties on either NIC.
0
 
LVL 2

Expert Comment

by:Mike
ID: 36511212
In your doc client for windows is selected.

I take it when you select IPv4 properties is also grayed out?

When you open properties of you connection does an error warning you of access restrictions appear?

0
 
LVL 2

Expert Comment

by:LondonCitizen
ID: 36511377
I just checked on my Windows 7 64bit and I got the inf files present.

Just do exactly same thing as before but make sure to navigate to:

c:\Windows\inf\choose any *.inf file and press ok, Windows will give you option to install the protocols.
0
 
LVL 4

Accepted Solution

by:
bloodygonzo earned 250 total points
ID: 36515975
You need to run sfc /scannow from an administrator command prompt. Reboot and your network should be restored. Also on the back of the pc are the NIC lights on?
0
 

Author Comment

by:dextor03
ID: 36519637
Ran the sfc /scannow and everything is now working as it should be. Cheers for the help!
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Article by: Lee
Windows 7 Ultimate and Enterprise (and 2008 R2) introduced a new feature you may not be aware of - Boot from VHD.   Boot from VHD (or what Microsoft refers to asNative Boot allows you to install Windows to a VHD (Virtual Hard Disk) file that is t…
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
This Micro Tutorial will teach you the basics of configuring your computer to improve its speed. It will also teach you how to disable programs that are running in the background simultaneously. This will be demonstrated using Windows 7 operating…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now