Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

How to configure Create VLANs?

Posted on 2011-09-09
4
Medium Priority
?
782 Views
Last Modified: 2012-05-12
I have a task to segregate My Network with 5 VLANs. Resources i have following:

1. Cisco Layer2 Catalyst Switches 2960 4 NOs.
2. Cisco Layer3 Catalyst Switch 3560 2 NOs.
3.  Fortigate Firewall 60B

Requirement :

VLAN 1 IP- 10.50.3.0/24
VLAN2 IP- 10.50.4.0/24
VLAN3 IP- 172.19.121.0/24
VLAN4 IP- 172.18.16.0/22
VLAN5 IP- 172.19.248.0/24

VLAN 5 will act as Server Farm for VLAN 3 & 4

Please assist me with step by step command or guide to setup

Already i have setup Fortigate with Network IP 10.50.3.0 as a flat network and all servers and client are using same network ID i.e. 10.50.3.0/24
Now i need to split my network.

please suggest!


0
Comment
Question by:aloknet21
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 18

Expert Comment

by:jmeggers
ID: 36510645
In the more recent versions of Cisco IOS on switches, when you assign a switch port to a VLAN, if the VLAN does not already exist, it is created.  Here are the steps to assign to a VLAN:

configure term
interface fa0/1
switchport
switchport mode access
switchport access vlan 10

If you need a VLAN interface with an IP address on the switch for the switch to route between VLANs, then configure:

interface vlan 10
ip address a.b.c.d 255.255.255.0

It's possible you may need to "no shut" the interface but usually not.
0
 
LVL 26

Expert Comment

by:Soulja
ID: 36510731
On 3560:
conf t
ip routing
interface vlan 1
ip address 10.50.3.254 255.255.255.0
no shut

interface vlan 2
ip address 172.50.4.254 255.255.255.0
no shut

interface vlan 3
ip address 172.19.121.254 255.255.255.0
no shut

interface vlan 4
ip address 172.18.16.254 255.255.255.0
no shut
 
interface vlan 5
ip address 172.19.254.254 255.255.255.0
no shut

exit

vlan 2
vlan 3
vlan 4
vlan 5

interface gix/x   (connected to 2960)
switchport trunk encapsulation dot1q
swithport mode trunk

ip route 0.0.0.0 0.0.0.0 fortgateipaddress

interface fax/x (connected to fortigate)
switchport access vlan 1
swtchport mode access

On 2960 switch


vlan 2
vlan 3
vlan 4
vlan 5

ip default gateway 10.50.3.254

int gix/x  (connected to 3560)
switchport trunk encapsulation dot1q
switchport mode trunk





On Fortigate


You need routes to the other 4 vlans so:

ip route 10.50.4.0 255.255.255.0 10.50.3.254
ip route 172.19.121.0 255.255.255.0 10.50.3.254
ip route 172.18.16.0 255.255.255.0 10.50.3.254
ip route 172.19.248.0 255.255.255.0 10.50.3.254
0
 
LVL 26

Expert Comment

by:Soulja
ID: 36510764
Once you do the config above, just assign ports to the vlan or your choice for the pc's and servers.

conf t
interface x/x
switchport access vlan x
switchport mode access

Then ensure you configure the correct ip settings on the servers and pc's to be on the same subnet and point to the correct vlan inteface for their gateway.

For DCHP, just add an ip helper to the Vlan Interfaces where the dhcp server does not sit.

For example, if the dhcp server sits on vlan 1 then add the ip helper to the other vlan interfaces, not interface vlan 1.

interface vlan x
ip helper-address x.x.x.x (address of dhcp server)

Make sure you have the scopes created for each vlan on the dhcp server.
0
 
LVL 26

Accepted Solution

by:
Soulja earned 2000 total points
ID: 36523314
Author, are you out there? Update?
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question