Solved

wifi not working with Tosh Satellite running Linux Ubuntu 10.04 LTS

Posted on 2011-09-09
17
564 Views
Last Modified: 2012-05-12
hi, i didn't have trouble with wifi when running win7 on this tosh satellite T135-S1309. I installed ubuntu on a new partition. I am total linux novice. Coulld someone please guide me on figuring out whether wifi is working or not and how to to make it work? I don't see any notifications on Ubuntu's bar on top tell me anything about detected wifi networks. I am thinking perhaps something is shut off.
0
Comment
Question by:polaatx
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
17 Comments
 

Author Comment

by:polaatx
ID: 36512433
Hello, I made sure my router is broadcasting. Where do I check to see if toshiba is detecting the wifi signal?
0
 
LVL 21

Expert Comment

by:Papertrip
ID: 36512443
paste the output from 'ifconfig -a'
0
 

Author Comment

by:polaatx
ID: 36512462
Hello, would you kindly tell me how to do: paste the output from 'ifconfig -a'   ? thx.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 21

Expert Comment

by:Papertrip
ID: 36512481
open up a terminal and type

sudo /sbin/ifconfig -a

Open in new window

0
 

Author Comment

by:polaatx
ID: 36512508
eth3      Link encap:Ethernet  HWaddr 00:26:9e:42:96:09  
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::226:9eff:fe42:9609/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:512826 errors:0 dropped:0 overruns:0 frame:0
          TX packets:311175 errors:0 dropped:0 overruns:0 carrier:8
          collisions:0 txqueuelen:1000
          RX bytes:690819149 (690.8 MB)  TX bytes:27142590 (27.1 MB)
          Interrupt:29

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6473 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6473 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:456264 (456.2 KB)  TX bytes:456264 (456.2 KB)

wlan0     Link encap:Ethernet  HWaddr 70:1a:04:1e:e5:fc  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:17 Memory:f8068000-f8068100
0
 
LVL 21

Expert Comment

by:Papertrip
ID: 36512527
ok step 1 is done, confirmed ubuntu sees your wireless card.

Check out this link for all sorts of ubuntu wifi goodies
0
 

Author Comment

by:polaatx
ID: 36512602
Hello, I ran iwconfig. It seems it sees the wifi card. Does it look like it is configured?

ali@smtower:~$ iwconfig
lo        no wireless extensions.

wlan0     802.11bgn  Nickname:"rtl8191SEVA2"
          Mode:Managed  Frequency=2.417 GHz  Access Point: Not-Associated  
          Bit Rate:300 Mb/s  
          Retry:on   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=10/100  Signal level=0 dBm  Noise level=-100 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth3      no wireless extensions.
0
 
LVL 21

Expert Comment

by:Papertrip
ID: 36512622
Did you do anything else?  all that shows you is just hardware specs of the nic, keep going.
0
 

Author Comment

by:polaatx
ID: 36512697
I am trying to start the Networking GUI article mentions. But there's no  (System)->(Administration)->(Networking) onmy system. Only there is Network Tools. See the pic attached. Is this what I need? The article is very dense. I am not sure what to do from here. Would you please guide me a bit? what should I do next?
Screenshot-Devices---Network-Too.png
0
 
LVL 21

Expert Comment

by:Papertrip
ID: 36512762
sudo dhclient wlan0

Open in new window

0
 
LVL 21

Expert Comment

by:Papertrip
ID: 36512780
Check this out and try to get Network Tools going.  While it's good to learn how to do things on the command line, sometimes things are just easier through the gui.
0
 
LVL 21

Expert Comment

by:Papertrip
ID: 36512793
Woops my bad that is an old deprecated link, here is the updated one.

As I thought, that doc says it's installed by default, but check that page out anyways.  It appears the only real problem here is that you aren't getting an IP from your router.  Probably just missing entries in your interfaces file for wlan0 -- try to get Network Manager working and this should be pretty easy to fix.
0
 

Author Comment

by:polaatx
ID: 36514079
Hi, If it is installed by default, where is it? The article you sent me talks about some icon in system tray NM Applet. There is no such icon on my machine. How do I get it to appear?


0
 
LVL 21

Accepted Solution

by:
Papertrip earned 500 total points
ID: 36514154
Try

sudo apt-get install network-manager network-manager-gnome

Open in new window


If it doesn't complain about them already being installed, and does successfully install them, logging out and back in to your desktop should make it available.  Might put an icon in the notification tray, not sure.
0
 
LVL 2

Expert Comment

by:0x4c1d
ID: 36515894
hey dude try this Wireless manager i find this works well with 10.04

sudo apt-get install wcid

Open in new window


when this is installed - scan for wireless devices ,

once you find you're one, click on your wifi -> properties -> select your wifi type , wep, wpa, wpa2

and click connect

give that a try cheers

ox
0
 
LVL 2

Expert Comment

by:cyclechip
ID: 36515959
Often plugging a newly-installed Linux system into an available network jack and performing a system update will enable proprietary drivers necessary for many wireless cards.
0
 

Author Closing Comment

by:polaatx
ID: 36532866
Thank you for your help.
0

Featured Post

Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The purpose of this article is to fix the unknown display problem in Linux Mint operating system. After installing the OS if you see Display monitor is not recognized then we can install "MESA" utilities to fix this problem or we can install additio…
Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question