Solved

Exchange 2010 Resolve Anonymous mail to GAL but NOT enabling relay

Posted on 2011-09-09
19
1,502 Views
Last Modified: 2012-05-12
I'd like to configure an Exchange 2010 SP1 receive connector for anonymous mail, have it resolve to the GAL, but NOT allow it to relay outside my organization.  This connector is only to be used by internal applications for internal e-mail deliver only.  So far, I have been able to find out how achieve this but the connector would also allow mail relay.

Does anybody know how to achieve this?

Summary:  Exchange 2010 SP1 Receive connector for anonymous mail, with GAL resolution, but NO mail relay allowed (only internal mail delivery)

0
Comment
Question by:ctc1900
  • 10
  • 6
  • 3
19 Comments
 
LVL 7

Expert Comment

by:JohnGrunwell
ID: 36512579
0
 
LVL 7

Expert Comment

by:JohnGrunwell
ID: 36512594
Sorry Mis-understood the question
0
 
LVL 4

Author Comment

by:ctc1900
ID: 36512598
No worries JohnGrunwell, thanks for checking though
0
 
LVL 7

Expert Comment

by:JohnGrunwell
ID: 36512651
0
 
LVL 4

Author Comment

by:ctc1900
ID: 36512685
JohnGrunwell, that solution enables mail relay, which I would like to avoid.  Thanks
0
 
LVL 4

Author Comment

by:ctc1900
ID: 36525121
I'm testing a possible solution: follow the instructions on "http://exchangeserverpro.com/how-to-configure-a-relay-connector-for-exchange-server-2010" for creating an relay connector and apply the following Remove-ADPermission

Get-ReceiveConnector “Name” | Remove-ADPermission –User “MS Exchange\Externally Secured Servers” –ExtendedRights “ms-Exch-SMTP-Accept-Any-Recipient”
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36529368
Basically you have nothing to do to meet your requirement just enable "anonymous" on it, by default the connector will NOT allow relaying. if yours does then the permission was added and it can indeed be solved by removing the “ms-Exch-SMTP-Accept-Any-Recipient” extended right
0
 
LVL 4

Author Comment

by:ctc1900
ID: 36530197
Akhater, one of the requirements is to enable GAL resolution.  Just enabling "anonymous" does not help me meet that requirement.  Thanks.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36530225
can you please give me more details about what you mean by "GAL resolution"
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 4

Author Comment

by:ctc1900
ID: 36530247
This article explains resolving anonymous mail to the GAL, thanks

http://exchangeserverpro.com/resolving-anonymous-mail-gal-exchange-server-2010
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36530417
this makes it clearer thanks.

so what is the problem with using this method to create a new connector and restrict its usage only to the IPs of the internal applications ?
0
 
LVL 4

Accepted Solution

by:
ctc1900 earned 0 total points
ID: 36530618
I want to allow local mail delivery only (no mail relay) with anonymous GAL resolution, thanks.

The only solution I found so far is to create a relay connector like explained here "http://exchangeserverpro.com/how-to-configure-a-relay-connector-for-exchange-server-2010" and remove the "mail relay" functionality with the following:


Get-ReceiveConnector “Name” | Remove-ADPermission –User “MS Exchange\Externally Secured Servers” –ExtendedRights “ms-Exch-SMTP-Accept-Any-Recipient”
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36532509
Just for my info this solution worked ?
0
 
LVL 4

Author Comment

by:ctc1900
ID: 36532663
So far this solution has been working OK
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36532675
thank you, that's an interesting approach
0
 
LVL 4

Author Comment

by:ctc1900
ID: 36537585
One more thing, it seems as if the Exchange powershell console noticed the change as it is throwing this warning every time I get the receive connector.  I have ticket going on with Microsoft to see if this is a recommended solution or if they have a better a approach

[PS] T:\>Get-ReceiveConnector "Name"

Identity                                              Bindings                                             Enabled
--------                                              --------                                             -------
..............\Name                               {X.X.X.XX:XX}                                      True
WARNING: The object .............\Name has been corrupted, and it's in an inconsistent state. The following validation errors happened:
WARNING: You must set the value for the PermissionGroups parameter to ExchangeServers when you set the AuthMechanism parameter to a value of
ExternalAuthoritative.

0
 
LVL 49

Expert Comment

by:Akhater
ID: 36539668
thank you for the update, and if you can share PSS solution it would be geeat
0
 
LVL 4

Author Comment

by:ctc1900
ID: 36543383
PSS advised they recommend enabling authentication for the application servers sending e-mail, which requires a mailbox for each one of them to the very least.  They also advised that this is a time-consuming process so the workaround (removing the ms-Exch-SMTP-Accept-Any-Recipient permission for MS Exchange\Externally Secured Servers) is the most optimized.  

There are a few a couple of gotchas with this workaround:

1) The warning message mentioned on a previous post when "get-receiveconnector". PSS advised it can be safely ignored

2) The Exchange Management Console sees this change when trying to open the receive connector object and throws this warning "The properties on this object have invalid data. If you click OK, default values will be used instead and will be saved if you do not change them before hitting Apply or OK on the property page.  If you click cancel, the object will be displayed read-only and corrupted values will be retained".    

      PSS advised that in order to make changes to this connector, we would need to temporarily add the "ms-Exch-SMTP-Accept-Any-Recipient" permission for "MS Exchange\Externally Secured Servers", make the appropriate changes, and then remove the permission again.


PSS Message

To achieve the receive connector for internal email only whilst be to able resolve display name, our recommended way is to enable authentication for the application servers. This method requires you to create mailbox for each of the application servers.  This could be a time-consuming process when you have over hundreds application servers. Thus, the workaround you found is the most optimized in our case.

After removing the AD permission for the connector, the connector will be unable to configure but it is functional. The warning can be ignored. One thing is that if you want to make some changes to the connector afterwards, the permission needs to be re-added, or you need to re-create the connector.
0
 
LVL 4

Author Closing Comment

by:ctc1900
ID: 36591654
Found solution
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…

932 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now