Report Caching

I'm having issues  with reporting services caching Reports.     Is there any way to completely turn  caching off so nothing is ever cached?    It only lets me limit history to 1.  

The problem is if the back end data change in the database from some process  and the user calls the reports  they do not see  the updated information until they pass the report a different set of parameteres first then put the original parameters back in.  

LVL 2
unreal400Asked:
Who is Participating?
 
dbaSQLCommented:
double check this, but you may just need to have this in your rsreportdesigner.config:

<Add Key="CacheDataForPreview" Value="False
0
 
Alpesh PatelAssistant ConsultantCommented:
Remove caching from report.
0
 
unreal400Author Commented:
CacheData for preview only really help with design mode correct?

Is there no setting directly in the server for production usage  as I'm not totally sure  the first will work with the way we are calling our code.
0
 
mlmccCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.