Fedora 15 Randomly Reboots

Posted on 2011-09-09
Last Modified: 2012-05-12
I installed F15 on a new build:

Intel Core i7-950 LGA1366
EVGA 131-GT-E767-TR (motherboard)
CORSAIR Vengeance 12GB DDR3 1600 (RAM)
650W PSU

First couple of weeks, everything ran smooth. A couple days ago the system started rebooting. It started to randomly reboot while I was working on file conversions in a XP virtualbox VM. I spent sometime troubleshooting vbox only to discover that my system will also reboot when ever I unrar a file with "unrar". The reboots have also happened while I was browsing with Firefox. The message log doesnt always generate a log entry either.

This is the last message log entry before the most recent reboot:
Sep 9 16:24:53 machine dbus: [system] Successfully activated service 'org.freedesktop.PackageKit'

I think its the last entry because it follows the entry below:
Sep 9 16:26:31 machine kernel: imklog 5.8.2, log source = /proc/kmsg started.

A couple of days ago this was the last entry before the crash:
Sep 6 19:06:42 machine kernel: [ 1293.903698] CE: hpet increased min_delta_ns to 20113 nsec

my current kernel is:

Any suggestions??? Not sure (at this point) if my issue is software or hardware related.
Question by:ro6ot
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions

Author Comment

ID: 36514434
I may have just solved my issue.. I turned off VT-x in virtualbox and I was able to convert a media file in my guest XP without a reboot on my host. Still need to figure out the rebooting when I'm using unrar.

Accepted Solution

leebrumbaugh earned 300 total points
ID: 36514572
Try running a memory checker, bad memory can cause reboots.  I've always liked Memtest86:

Let it run over night to do multiple passes.  Sometimes a single pass won't find anything while multiple ones will.

Expert Comment

ID: 36514576
Also check your BIOS to see if you have VT turned off..
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)


Author Comment

ID: 36514869
I spoke to soon..

Just tried another process in my guest XP and got a reboot. Looked at dmesg and the entries below are in it. Not sure what to make of this yet.. Will try your suggestions ASAP.

[ 2.541666] res 51/20:03:00:00:00/00:00:00:00:00/a0 Emask 0x1 (device error)
[ 21.085631] dbus[1000]: avc: netlink poll: error 4

[ 0.000000] ACPI Warning: Optional field Pm2ControlBlock has zero address or length: 0x0000000000000450/0x0 (20110413/tbfadt-560)
[ 0.000000] ACPI Warning: Invalid length for Pm2ControlBlock: 0, using default 8 (20110413/tbfadt-610)
[ 0.011865] WARNING: at arch/x86/kernel/apic/apic.c:1237 setup_local_APIC+0xee/0x317()

Expert Comment

ID: 36515169
Appears to be issue with the network card selected in Virtualbox. Here is my experience with the problem way back. Also you can try to deselect the System -> IO APIC in the Settings option of the virtual machine.

Assisted Solution

eager earned 200 total points
ID: 36516531
Were the reboots repeatable?  Did Vbox fail every time you ran XP, or only occasionally?  Would running unrar always cause a reboot?

If the reboot is not repeatable, it isn't likely related to Vbox settings, APIC, or other software issues.  As mentioned earlier, memory failure is a likely cause.  You might also check that all boards and connectors on the motherboard are tight.  

Author Comment

ID: 36519683
VT was already disabled in the BIOS when I checked.
I ran a memory test. It went through 6 passes and no errors.

The IO APIC settings in virtualbox are not enabled (never have been).

The reboots continue when I have high CPU utilization in my VM. I havent been able to duplicate a reboot while using unrar inside my host. It happened a few times but its not consistent.

I reseated all my boards and cables and nothing was loose. I had my DVD plugged into a SATA3 port so I moved it to a SATA2 port. Dont know if that was causing the reboots I'm trying another file conversion in my guest VM to see if I can duplicate the reboot.

Expert Comment

ID: 36524961
Not sure if it helps any, but maybe you could try VMware player?  The latest versions let you create VMs now as well.  It'd be interesting to see if it happens in that as well.

Author Comment

ID: 36525639
I solved the issue!!

After moving my DVD to a SATA2 port the reboots continued. So I started looking closer at my CPU and RAM settings in the BIOS. My BIOS had XMP enabled for my RAM. I turned XMP off and went back into the OS. I started my guest XP and started converting videos. I didnt get a reboot so I moved my DVD back to SATA3 port and tested again. No reboots so I started some really big file conversions. About 50GB total and no reboots. My system has been up for about 24 hours!

So far everything is good. Thanks for the memory suggestions, it got me thinking on the right path.

Author Closing Comment

ID: 36525659
The suggestions about memory got me looking in the right direction. Thanks for the help!

Expert Comment

ID: 36525832
Glad that it got resolved.  I had to Google XMP on memory.. must be a newer motherboard then I've never seen as I didn't know what it was for.  Thanks for the info!

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Many people tend to confuse the function of a virus with the one of adware, this misunderstanding of the basic of what each software is and how it operates causes users and organizations to take the wrong security measures that would protect them ag…
The purpose of this article is to fix the unknown display problem in Linux Mint operating system. After installing the OS if you see Display monitor is not recognized then we can install "MESA" utilities to fix this problem or we can install additio…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question