Solved

SWF showing in gray-scale, but only in FF6

Posted on 2011-09-10
19
350 Views
Last Modified: 2012-08-14
I have embedded a SWF in a client site, and all appears all right apart from it showing in Firefox 6 as a gray-scale image.

I have no previous versions of FF left so cannot say if it is a version or application issue. But Chrome, Safari, IE and Opera show it in colour as it should.

The URL is this. The SWF are the leafs in the left corner.

Any ideas would be appreciated.

Thanks
capt.
0
Comment
Question by:captain
  • 11
  • 8
19 Comments
 
LVL 29

Expert Comment

by:dgofman
ID: 36516764
If you will open http://www.mindmatters.uk.com/img/Leafs.swf in Firefox you will get same colors
So, problem in HTML CSS
0
 
LVL 29

Expert Comment

by:dgofman
ID: 36516798
Can you try for now remove in HTML

<PARAM name="wmode" value="transparent">
0
 
LVL 30

Author Comment

by:captain
ID: 36516811
Well that is great but how to fix it...

As you know HTML CSS means not a lot in your answer especially as it works in other browsers, hence I appreciate a little more consequential explanation as I don't quite see what you mean with "so"...

Maybe you could elaborate? For instance which FF you are using?
0
 
LVL 29

Expert Comment

by:dgofman
ID: 36516814
But I am thinking problem with your "Cufon" library. I never used before but looks like its changing alpha in DIV objects. Can you comment cufon-yui.js script and run your HTML
0
 
LVL 30

Author Comment

by:captain
ID: 36516815
Oh thanks, I typed mine before your second post. If I remove the window mode it will not be transparent and will be contained in the stage colour which is white.

Will try though...
0
 
LVL 29

Expert Comment

by:dgofman
ID: 36516828
If you will remove wmode you may need to re-range z-index in  divs
0
 
LVL 30

Author Comment

by:captain
ID: 36516843
The CUFON is not the issue, that made no difference...

Taking out the first wmode did not change anything the second did, it was in colour but did display what I explained earlier. see index.html...
0
 
LVL 30

Author Comment

by:captain
ID: 36516850
It looks like it is the second which should be an "if IE" only element, but the code seems jumbled:
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="222" height="283" id="FlashID" title="Leafs Background">
  <param name="movie" value="img/Leafs.swf" />
  <param name="quality" value="high" />
 <param name="wmode" value="transparent" />
  <param name="swfversion" value="6.0.65.0" />
  <!-- This param tag prompts users with Flash Player 6.0 r65 and higher to download the latest version of Flash Player. Delete it if you don’t want users to see the prompt. -->
  <param name="expressinstall" value="../Scripts/expressInstall.swf" />
  <!-- Next object tag is for non-IE browsers. So hide it from IE using IECC. -->
  <!--[if !IE]>-->
  <object type="application/x-shockwave-flash" data="../img/Leafs.swf" width="222" height="283">
    <!--<![endif]-->
    <param name="quality" value="high" />
    <param name="wmode" value="transparent" />
    <param name="swfversion" value="6.0.65.0" />
    <param name="expressinstall" value="../Scripts/expressInstall.swf" />
    <!-- The browser displays the following alternative content for users with Flash Player 6.0 and older. -->
    <div>
      <h4>Content on this page requires a newer version of Adobe Flash Player.</h4>
      <p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" width="112" height="33" /></a></p>
    </div>
    <!--[if !IE]>-->
  </object>
  <!--<![endif]-->
</object

Open in new window

0
 
LVL 29

Expert Comment

by:dgofman
ID: 36516853
I cannot fix your problem localy without source code. Please try to play with CSS settings or disable for now all and check if your Leafs.swf can be colour with wmode
0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 
LVL 30

Author Comment

by:captain
ID: 36516876
The CSS relating to the flash is:
#flash1 {position:absolute;
float:left;
top:15px;
left:0px;

}

Open in new window

0
 
LVL 30

Author Comment

by:captain
ID: 36516879
Not sure what I should change here.
0
 
LVL 30

Author Comment

by:captain
ID: 36516902
I just checked on a different machine with FF 3.6 and it is fine there, could anyone let me know which FF version is affected??
0
 
LVL 29

Expert Comment

by:dgofman
ID: 36516965
Hi, I can not help now I am out of my computer but create a simple HTML page with your flash movie and run on FF6. I am sure you have to get correctcollors
If you will not resolve your problem I will write a new J's script for you swf.
Remember you must use embed tags in HTML for FF
0
 
LVL 30

Author Comment

by:captain
ID: 36517128
OK, I have reduced this down to the fact that the colour changes to grey as soon as the page background is set to the background PNG. I have changed the PNG to JPG but same result.

The moment I use a background without image the colour returns...
0
 
LVL 29

Assisted Solution

by:dgofman
dgofman earned 250 total points
ID: 36517971
Wow! This is FF bug. If you want you can open

Workaroung set background color to white in your div holder

#wrap {
    background-image: url("../img/mid.png");
    background-repeat: repeat-y;
    background-color:white;
....


0
 
LVL 29

Expert Comment

by:dgofman
ID: 36517986
The link if you will decide to report bug for FF

https://bugzilla.mozilla.org/enter_bug.cgi
0
 
LVL 30

Author Comment

by:captain
ID: 36518619
It seems a bug.

background-color:white; does not help either, it  fills the elements that need to stay transparent but also does not change the color.

Which version of FF are you using?
0
 
LVL 30

Accepted Solution

by:
captain earned 0 total points
ID: 36518782
I have figured it out, the PSD file the Flash was based on had its layers set to 'Darken' which was retained in the SWF. I have asked for the source files, imported it again using Normal opacity and after publishing the color appeared correctly.

Strange that it did not happen in other browsers.
0
 
LVL 30

Author Closing Comment

by:captain
ID: 36547862
Thanks for you help. I think you were right about the bug, but the solution lay elsewhere.

capt.
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Bada platform is becoming more and more famous this days and people talking about same. Some friends included those who have bada OS mobile asked me "what is bada?"and "what its features?". That encouraged me to research and write this article. [st…
I annotated my article on ransomware somewhat extensively, but I keep adding new references and wanted to put a link to the reference library.  Despite all the reference tools I have on hand, it was not easy to find a way to do this easily. I finall…
The goal of the tutorial is to teach the user what frame rate is, how to control it and what effect it has on the video.
Google currently has a new report that is in beta and coming soon to Webmaster Tool accounts. This Micro Tutorial will highlight new features for Google Webmaster Tools.

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now