Solved

CompanyWeb not functioning

Posted on 2011-09-10
27
473 Views
Last Modified: 2012-09-10
Hello,
I have a server running Windows 2003 Server R2 Premium.  Everything has been running well for some time.  However, last week, the intranet website, CompanyWeb, stopped working for internal LAN Clients.  It is working perfectly when I run the IE browser on the server console, but when I run IE on a PC Client on the LAN, it does not work.  When I run browser, it says "Internet Explorer cannot display the webpage", and when I use the "Diagnose Connection Problems" button, it sayd that windows did not detect any problems.  I opened IIS and checked the asp.net version for the CompanyWeb website, which is 1.1.4322.  Was also able to browse the contents of the website from IIS.
Can anyone lend me some assistance here?  Please advise.  Thanks.  Sincerely,
0
Comment
Question by:jeandemo
  • 12
  • 6
  • 4
  • +1
27 Comments
 
LVL 16
ID: 36517630
If you try to ping "companyweb" from a command line does it resolve to correctly?

MO
0
 
LVL 13

Expert Comment

by:khairil
ID: 36517797
Hi,

Try this:

1. Try ping your server first, if no reply then go step 5
2. Try telnet to port 80 of your server,
telnet companyweb 80

Open in new window

then do some random typing and press enter (maybe you need to press enter multiple time)
3. Try navigate using IP address, can you browse the web?
4. If yes then try this command at command prompt:
nslookup companyweb

Open in new window

Check the IP address are they same with the one of your server. If not same then there is DNS problem or broswer problem. For browser check if it is running on proxy server, or try use other type of browser (freshly install if possible).
5. If all failed, then go to your server and turn off the Windows Firewall (also firewall on the client computer if still failed after turning off server firewall)
6. Try back step 1 - 3


If possible, can you post your company website url over here, so that we can do some basic test.
0
 

Author Comment

by:jeandemo
ID: 36517885
Hello,
When I ping CompanyWeb from the command prompt of a PC Client, it works correctly, it is resolving properly.

Will try to do a telnet to port 80 and get back to you with an answer.  However, as indicated previously, when I use the "Diagnose Connection Problems" button, it sayd that windows did not detect any problems, so I suspect that the connection is good.

Have not tried nslookup CompanyWeb either, will try this ASAP and get back to you with a response to same.  That said, when I put IP address of the server into the web browser, it resolves to the SBS default page.  One of the links on the default page points to the "My Company's Internal Web Site", and this is the website that is not responding.

Will also check the firewall issue, but SBS has a default firewall (i.e. Microsoft Firewall Client for SBS 2003) that is used with all PC Clients, and most of the services are, by default, open on the LAN network.  All PC Clients run a proxy on the firewall client.

Will get back to you when I try the issues identified by you guys.

Thanks.  Sincerely,
0
 
LVL 16
ID: 36517922
If you go to IIS on the SBS and right click on the companyweb directory are you able to "Browse"? Also can you go to http://companyweb from the SBS itself?

The problem sounds like an IIS issue. Let me know about the two questions above.

MO
0
 
LVL 13

Expert Comment

by:khairil
ID: 36518041
you said the link on the site refer to your companyweb failed but you be able to browse the site using ip address (just like to confirm)?

is the link relative? eg: /mypage.aspx
or absolute? eg: http://companyweb/mypage.aspx

if it is the later, you might have dns issues.
0
 

Author Comment

by:jeandemo
ID: 36520038
Hello All,

As a follow-up to the comments and suggestions that were made, here is what I have at this point:

In response to mgortega's first question: If you try to ping "companyweb" from a command line does it resolve to correctly?

Answer: When I ping CompanyWeb from the command prompt of a PC Client, it works correctly, it is resolving properly.

In response to khairil's first comments and suggestions

1) Did a telnet to port 80, the following was the response:
Connecting To companyWeb...Could not open connection to the host, on port 80: Connect failed

2) Did a nslookup CompanyWeb and it responded perfectly.  In fact, I plugged the exact response (i.e. companyweb.xxxx.local) into the URL, although it asked me for a username and password, when I entered it, I got onto the companyweb.  However, I must point out that accessing the company web has never requested me to enter a username and password before.  Could this be a security or policy issue?  The way I have it setup now is default (i.e. all authenticated users are supposed to have access to the companyweb)

3) Based on item 2 above, I want to suspect that the firewall may not be an issue, since I am able to access the companyweb via a different URL.

In response to mgortega's second question: If you go to IIS on the SBS and right click on the companyweb directory are you able to "Browse"?

Answer: Yes I am able to browse perfectly from the server console, I can get to the site

Question: Also can you go to http://companyweb from the SBS itself?

Answer: Yes I can.  It is the default website address for all PCs clients including the server.  It works on the server (i.e. http://companyweb) and correctly defaults to http://companyweb/default.aspx

In response to khairil's second question: You said the link on the site refer to your companyweb failed but you be able to browse the site using ip address (just like to confirm)?

Answer: When I type in the IP address of the server, I am taken to the default SBS page that says:

* My Company's Internal Web Site
Collaborate and share documents on your company's internal Web site

* Network Configuration Wizard
Join a client computer to the Windows Small Business Server network

* Remote Web Workplace
Connect to the Windows Small Business Server network over the Internet
   
* Information and Answers

Clicking on each one of the links (i.e. with the * in this email) works EXCEPT for "My Company's Internal Web Site", which points to http://companyweb

Hope I have been able to help with the responses... at least we are making progress.  Looking forward to positive feedback.

Thanks.  Sincerely,
0
 
LVL 16
ID: 36520068
If you can't telnet to the server on port 80 then some security software sounds like it's blocking access from any hosts other than "localhost". Is windows firewall enabled on the server? It's not by default, but was it turned on? Any other security software, e.g. Symantec, McAfee, etc., that might be blocking access?

MO
0
 
LVL 13

Expert Comment

by:khairil
ID: 36520880
Emm... Ok at least something here.

1. Local access prompt you password - It is because the security context of the directory no longer allow anonymous access and being set to digest security mode. You can change this in IIS but I not recommended at a moment, try to look other solution first.

2. You can ping the IP but failed to telnet to port 80 - means that your port 80 is not running (if not blocked by firewall). You can try to confirm this by running this command on the server using the command prompt:

netstat -a

Open in new window


it will list all the network connection currently open. eg on my compute with running HTTP and HTTPS it will list port 80 and 443 on the local computer (see attachment)

 nestat
If only 443 available, but port 80 is not running - so that is the problem.
But, if port 80 is there and you not be able to access it via telnet - it is firewall problem, turn off the firewall (Windows or any other firewall on the server)

3. If both are running and firewall is off then might be link to "your site". I not familiar with SBS but we do have face problem like this when running Sharepoint portal.
0
 

Author Comment

by:jeandemo
ID: 36528744
Guys,

Sorry I have not been able to get back to you all as yet.  I am currently working on a down condition with one of my servers.  Please bear with me until I can get back to the problem.  Thanks.  Sincerely,
0
 

Author Comment

by:jeandemo
ID: 36528757
Hello,

In response to mgortega's question:  Is windows firewall enabled on the server?

Answer: Because this is a Windows 2003 SBS R2 Premium server, not only is Windows Firewall running, but also ISA Server and IIS.  Also have Symantec EndPoint protection installed.  Will check on this and get back to you ASAP.  Thanks.  Sincerely,
0
 

Author Comment

by:jeandemo
ID: 36528776
Hello,

khairil, as soon as I can get to carry out your suggestions, I will get back to you with a response.  Thanks.  Sincerely,
0
 
LVL 16
ID: 36542484
Actually Windows Firewall is disabled by default with all flavors of Windows 2003. Of course, since you're running ISA that changes things.

Quick history check. All was working well and then suddenly not. Do you know of anything new that changed right before it stopped work. Perhaps SEP install on server or upgrade? ISA server updates or config change?

If a change in the setup of the server isn't so obvious I would get a netmon capture on your SBS when a client computer is attempting to connect just to confirm whether or not the server is blocking the connection.

Is Sharepoint (Companyweb) opened externally? If so, can you access it externally? If not, can you open it up for external access? This will determine if ISA server has anything to do with the local clients inability to access the site or if the server, in general, is preventing the connection.

Send some updates. Thanks.

MO
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 

Author Comment

by:jeandemo
ID: 36557041
Guys,
Still have not gotten around to addressing this issue... I have been battling a couple of server down conditions this week.  Will get to it ASAP and get back to you guys with a response.  Thanks.  Sincerely,
0
 
LVL 13

Expert Comment

by:khairil
ID: 36557205
Symantec EndPoint Protection (SEP) installed have firewall build-in, which automatically block incoming traffic (only pass selected traffic). Try turn off or remove it. I not suggest you to use SEP for your server and avoid using any anti malware that bundle firewall together. Try anti virus for server instead.
0
 
LVL 16
ID: 36559801
Recommended deployment for SEP is with Network Threat Protection enabled. That gives you the benefit of the IPS engine. You do have to specify to not use the built in firewall though. Without removing SEP you can simply go into SEP Manager on the server and disable the default Firewall Policy. From the client on the server you can then force an update of the policy by right clicking on it. This should eliminate the SEP firewall as a variable.

MO
0
 

Author Comment

by:jeandemo
ID: 36560271
Hello,

In response to khairil suggestion... you can try to confirm this by running this command on the server using the command prompt: netstat -a

I ran this command and I can confirm that the server is LISTENING on the http port and the https port.

Based on this response, I will check on the firewall (I am assuming ISA Server) and get back to you.  If it is not ISA, please drop me a quick note.

Thanks. Sincerely,
0
 

Author Comment

by:jeandemo
ID: 36560307
Hello,

In response to mgortega questions/comment: Is Sharepoint (Companyweb) opened externally? If so, can you access it externally? If not, can you open it up for external access?

SharePoint is NOT open for external access.  Have never tried to open up SharePoint for external access.  Let me look into this and get back to you regarding same.

Thanks.  Sincerely,

0
 
LVL 16
ID: 36560333
If you can temporarily open up Companyweb (Sharepoint) through your network firewall you could test the connection to the server with ISA out of the picture. If it works externally then ISA is potentially the issue. If it still doesn't work it's likely a software Firewall, e.g. SEP.

MO
0
 

Author Comment

by:jeandemo
ID: 36582739
Hello,
Scheduled to go back on the site tomorrow to test out options suggested here.  Thanks.
0
 

Author Comment

by:jeandemo
ID: 36713357
Guys,
Well I went back on site to attempt repairs.  Still can't figure out why the system is working perfectly when I use http://companyweb.xxx.local/default.aspx

Checked DNS and IIS once again, everything seems to be correct.  I am now at a loss.  Any further suggestions?

Thanks.  Sincerely,
0
 

Author Comment

by:jeandemo
ID: 36713489
Guys,
Following my last post, let me point out that using the FQDN stated above works perfectly, but I am asked to enter a username and password in order to access companyweb.  I have since learnt that if I use https://companyweb, I access the companyweb without any problems, I do not even get a username and password request.  I went back into IIS to verify that port 80 is open and everything seems OK.  Still working on this problem.  Thanks.  Sincerely,
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 37934779
I've requested that this question be deleted for the following reason:

The question has either no comments or not enough useful information to be called an "answer".
0
 

Author Comment

by:jeandemo
ID: 37934780
All,
This problem still remains unsolved as of today 05/05/12.  I am still hoping for a solution to be found.  Thanks.  Sincerely,
0
 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 500 total points
ID: 38041148
Just so I understand your current problem, you cannot access http://companyweb from client computers, but you can access https://companyweb?

Is that correct?

If so, this indicates that somehow port 444 has been removed from your companyweb site.  Because normally, if you wanted to access companyweb via SSL you need to use https://companyweb:444

There is a special ISAPI filter on SBS 2003's IIS which pushes a request for http://companyweb (on port 80) over to port 444 so that you cannot access SharePoint without a secure connection.  If port 444 configuration is missing, you will experience the problem you are having.

The first way to try to repair this is to run the Configure Email and Internet Connection Wizard (CEICW) which should reset the proper port numbers on companyweb.

However, if it doesn't, you will need to manually configure the site as follows:

Companyweb IIS configuration
Also, make sure that on the Directory Security tab > Secure Communications > Edit -- the box for Require Secure Channel (SSL) should be unchecked.

Companyweb SSL settings
After making these changes rerun the CEICW once more just to make sure it gets all the proper bindings configured.

Jeff
TechSoEasy
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Pimping Sharepoint 2007 without Server-Side Code Part 1 One of my biggest frustrations with Sharepoint 2007 in the corporate world is that while good-intentioned managers lock down the more interesting capabilities of Sharepoint programming in…
We had a requirement to extract data from a SharePoint 2010 Customer List into a CSV file and then place the CSV file into a directory on the network so that the file could be consumed by an AS400 system. I will share in Part 1 how to Extract the Da…
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now