Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 461
  • Last Modified:

Router

I have 2x router at my home. router1= 192.168.1.1 router2(main router)=192.168.2.1.
When i do not use router1 in my network then my MAIL SERVER works perfect,But i connect my computer to router1 network (192.168.1.100) then i cant get any mail.

I think i do mistake in router1 routing can some one help pls?
Thanks
0
orkinos
Asked:
orkinos
  • 8
  • 4
  • 3
  • +1
7 Solutions
 
orkinosAuthor Commented:
my computer 192.168.1.115---->router1 192.168.1.1------->router2 192.168.2.1  MAIL SERVER no works

my computer 192.168.2.115---->router2 192.168.2.1  MAIL SERVER  works

I did the same config on router1 too, (port 110,25,143)
0
 
chakkoCommented:
You have 2 networks setups.  Easiest thing would be to change your Router1 to be IP 192.168.2.2  (update DHCP inside router if needed).  This would put everthing onto 1 network.

Then you can access your mail server while connected to either Router1 or Router2.
0
 
PapertripCommented:
OK, there is a ton of missing information here that we would need to answer something like this.

Why aren't you doing all this routing on just 1 router?  What are you trying to accomplish by having 2 physical routers?

You should get in the habit of pasting more information so that we can accurately help you.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
orkinosAuthor Commented:
I bought new cisco E2000 router ,I would like to use that on my wireless(300mp) network BUT cisco router is not DSL router. router from ISP is DSL router.

I did router 1 gets (192.168.2.2) dhcp address from router2 (192.168.2.1). All works when i connect my computer 192.168.1.1 network.
But only think my mail server is not working I do test on the mail server(192.168.1.100) then show not connected.

I did the same port connection on the router 1 which can allow 110,25,143 ports.
But still not get mails
0
 
PapertripCommented:
Just use the E2000 to do routing/dhcp for both subnets.  Better yet just use it to create 1 subnet for all your internal hosts.

What are you trying to accomplish by having 2 internal networks?
0
 
orkinosAuthor Commented:
But this is a router isnt? router has possibilty routing the other network.

I know what you mean router1 192.168.2.129 router2 192.168.2.1(dhcp range 1-128). But why i cant routing to 192.168.2.0 network?
0
 
PapertripCommented:
Can you do what you want with your current setup?  Sure... but why do you need to?

You could technically add a bunch more routers to your overall network, but why do that when 1 router can handle all that you need?

The bottom line here from what I can see is that you have an overly-complex home network and it's causing you problems.  Condense your network into 1 subnet being managed by 1 router and this should be a non-issue.  Unless you have a good reason for all the complexity, so if you do, tell us what that is.
0
 
orkinosAuthor Commented:
but why do you need to? :)  
router1 =new cisco e2000     Wireless 300mbp (NOT DSL ROUTER= this means without help dsl router cant use internet), E2000 (MORE SECURE )

router2 = ISP router old one  Wireless 54mbp. (without that router i cant use my E2000 Cisco router)

configuration=

router1(internet port+ dhcp open and get ip from router2) ----->router2 (network port ).

0
 
ZephyrTCCommented:
I'm with Papertrip... you should be using one router.  Is there a reason you are trying to use 2?

What is the IP of your mail server?  Could it be as simple as the mail server STATIC IP address not being in the same subnet as the router (seeing how router 1(not working) is on the .1 range and router 2(working) is on the .2 range.)

Also, you will need to insure that port forwarding and/or NAT translation is set up on the router you are having problems with and is configured to forward port 25 to your mail server.

But I digress, Why are you using (or trying to use) two routers - (the e2000 series routers are consumer grade - in that, they are designed for home applications)?

What would help here is the following information:

The IP of your mail server (give a false one in the same subnet if you are worried about security).
A layout of the working router connected and one of the non-working router connected
Verification of the port forwarding and/or NAT translation settings of each router
Verification of internet access in both configurations from the mail server and your computer.
0
 
orkinosAuthor Commented:
What is the IP of your mail server?-- 192.168.1.115
forwarding and/or NAT translation -- Nat open and port forwarding 110,25,143 to 192.168.1.115
0
 
ZephyrTCCommented:
What is your network architecture?  Are you actively using both the .1 and .2 networks?
0
 
orkinosAuthor Commented:
0
 
orkinosAuthor Commented:
with this config INTERNET works.
But only thing MAIL server cant connect.
0
 
chakkoCommented:
you need to put a static route in the Router2 so that any destination to network 192.168.1.0 / 24 has the gateway of 192.168.2.2

0
 
chakkoCommented:
do you mean mail server cannot connect from your PC -> mailserver.  Or do you mean your mailserver cannot connect to the internet?

Again, please clarify, you are connecting your computer to Router1 as the gateway (your pc has 192.168.1.x IP) or are you using Router2 as your gateway (your PC has 192.168.2.x IP)?  Or you need it to work with either Router1 or Router2 as your gateway?
0
 
chakkoCommented:
I would setup like this if you need your current network config to be the way it is.

Router 1,  IP 192.168.2.2, gateway 192.168.2.1
Router 2, IP 192.168.2.1, gateway current setting as is since it works already.
Static router on Router2, source address 192.168.2.0/24 network destination 192.168.1.0/24 network, gateway 192.168.2.2

If you need internet mail to come from internet to the Mail server (on inbound internet based connection) then in Router2 port forward any required ports to IP 192.168.2.2.

the port forwarding on Router1 looks fine the way you describe it.
0
 
ZephyrTCCommented:
Ok,

If there are no actual devices in your .2 range, I would suggest to put the DSL router into bridge mode and set up the authentication perameters (according to ISP specifications) on the E2000 series router.  The most likely reason things aren't working is you are double NAT'ed.  If you need help doing this, please supply the model number and make of the ISP DSL router.

Double NAT can wreak havoc on networks.\
The first post here explains a bit on your issue.
0
 
orkinosAuthor Commented:
Hey guys
worrkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkksssssssssssssssss
Thanks alot


you need to put a static route in the Router2 --- this is the key
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 8
  • 4
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now