SBS2011: smb & file locking issues

Hi,

On a recently upgraded server (SBS2011/Windows 2008) with a shared folder for accounts containing Sage Line50 v2009 data, shared for Everyone FullAccess, now getting file locking errors.

Clients O/s: Windows7 64-bit, Vista & XP

I understand problems arise beause of mixture of client OS's and that SMB2 needs disabling. I've read several articles detailing how to disable on the client-side or on the server-side.

my query is: can I just disable on the server-side? is this sufficient? pls include how-to.

http://blog.korteksolutions.com/disable-smb-20-on-windows-server-2008/

Thanks
jay
Jay_RatansiAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
SuperTacoConnect With a Mentor Commented:
You should just be able to disable SMB 2.0 on the server side and be OK.  the client OS will auto adjust.  

Open a Command propmt and type the following.

sc config lanmanworkstation depend= bowser/mrxsmb10/nsi
sc config mrxsmb20 start= disabled
0
 
Netman66Connect With a Mentor Commented:
Correct.  The client will negotiate, but if the server has SMB2 disabled then there's nothing to negotiate.

You should also change the Everyone - Full Control to Authenticated Users - Full Control.  

0
 
Jay_RatansiAuthor Commented:


1.Run "regedit" on Windows Server 2008 based computer.

2.Expand and locate the sub tree as follows.
HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

3.Add a new REG_DWORD key with the name of "Smb2" (without quotation mark)
Value name: Smb2
Value type: REG_DWORD
0 = disabled
1 = enabled

4.Set the value to 0 to disable SMB 2.0, or set it to 1 to re-enable SMB 2.0.

5.Reboot the server.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.