Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Connecting 2 Cisco Switches together

Posted on 2011-09-11
7
Medium Priority
?
786 Views
Last Modified: 2012-05-12
I have 2 cisco 3560 and I want to connect these together with a single network cable.

Switch A has 3 Vlans (1 - Company A,2 - Company B,3 - Public) and I want to connect this to Switch B. The problem is Switch B belongs to company B and all I want to go over the link is Vlan 2. If I put the port on Switch A into switchport mode access & switchport access vlan 2 all I get is an orange light on Switch A but a Green on Switch B. If I change the port to trunk mode the light on switch A changes to green.

What I really want to do is treat Switch B like a dumb switch.

Thanks
0
Comment
Question by:jrgcomputing
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 10

Expert Comment

by:SuperTaco
ID: 36518892
since you already have VLANs, the "dumb switch" is out of the question.  All you should have to do is connect a port on Switch A that is a VLAN member to a Port on switch b that is a VLAN member.

there the config

config t
int gi/0/1 (or whatever interface)
switchport access VLAN 2

this will dedicate that port to the VLAN.
0
 
LVL 2

Expert Comment

by:bgilsing
ID: 36518920
Treating it as a dumb switch is not out of the question. On switch A set a port to be a member of VLAN 2 as if you were going to connect a workstation to it. Clear all VLAN config information on switch B and set it up as a dumb switch. Connect any port on switch B to the port you configured on switch A and your done. If you are not "trunking" vlans you don't have to change the mode of the ports to trunk mode. I think what you are missing is the cable type. If you are connecting two switches together you need a crossover cable. It flips the transmit and receive pairs so the switches can talk to each other. That's why you are getting an orange port. Lookup crossover cable on google if you need a pinout, or just go buy one if your not comfortable making cables.
0
 
LVL 11

Expert Comment

by:gmbaxter
ID: 36518989
You'll need to set up a trunk between the switches, but limit the traffic which is allowed through the trunk. From memory, the 3560 has two separate gigabit ports, assuming you have a 48 port switch. Connect a crossover cable from switch A to B into the gigabit ports, and use the following config.

on switch A:
configure terminal
int gigabit Ethernet 0/1
no shutdown
description Trunk to switch B
switchport trunk encapsulation dot 1q
switchport mode trunk
switchport trunk allow vlan 2
exit
exit
wr

on switch B:
configure terminal
int gigabit Ethernet 0/1
no shutdown
description Trunk to switch A
switchport trunk encapsulation dot 1q
switchport mode trunk
switchport trunk allow vlan 2
exit
exit
wr

You'll now have a trunk between the two switches which will only pass vlan 2 traffic. You can then set all access ports on the switch to vlan 2.
0
When ransomware hits your clients, what do you do?

MSPs: Endpoint security isn’t enough to prevent ransomware.
As the impact and severity of crypto ransomware attacks has grown, Webroot has fought back, not just by building a next-gen endpoint solution capable of preventing ransomware attacks but also by being a thought leader.

 
LVL 47

Accepted Solution

by:
Craig Beck earned 1500 total points
ID: 36519015
I would do this with an access port, as it isn't guaranteed that VLAN2 already exists on switch B, and if it does you might not want to link VLAN2 on switch A to VLAN2 on switch B.

In any event you will need to edit the configuration on both switches, so do this on switch A...

conf t
interface gi0/1
switchport mode access
switchport access vlan 2
end


And on switch B, configure the port you're connecting to the same, but set the VLAN to whatever you need it to be in.
0
 
LVL 3

Author Closing Comment

by:jrgcomputing
ID: 36530370
The only thing I needed that wasn't mentioned is a crossover cable.
0
 
LVL 47

Expert Comment

by:Craig Beck
ID: 36531052
You don't strictly need a crossover to link two 3560's together - they do Auto MDI-X!
0
 
LVL 3

Author Comment

by:jrgcomputing
ID: 36531335
Yeah I thought that, but with a straight through cable I got orange light on one of the switches and green on the other. as soon as I tried a crossover cable it worked. I don't know if it mattered that one was a 3560g and the othe 3560.
0

Featured Post

Put Machine Learning to Work--Protect Your Clients

Machine learning means Smarter Cybersecurity™ Solutions.
As technology continues to advance, managing and analyzing massive data sets just can’t be accomplished by humans alone. It requires huge amounts of memory and storage, as well as the high-speed power of the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Examines three attack vectors, specifically, the different types of malware used in malicious attacks, web application attacks, and finally, network based attacks.  Concludes by examining the means of securing and protecting critical systems and inf…
A new hacking trick has emerged leveraging your own helpdesk or support ticketing tools as an easy way to distribute malware.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
Suggested Courses

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question