Solved

spooler.svc deadlocked

Posted on 2011-09-11
13
1,024 Views
Last Modified: 2012-05-12
Hi,
I am having a problem where on one particular desktop the spoolersvc.exe process deadlocks and then obviously any programs that uses it (word, excel etc) waits for it indefinitely)

The current solution is to end the process and just start it again and everything comes back to life.
The eventlog doesn't report anything about the spooler except for me ending it unexpectedly.

I am wondering if we can turn diagnostic logging on or something for the spooler service perhaps.This seem to happen at startup, on first print, then after that it works ok.

It also doesn't happen at each startup, only some.

The OS is windows 7 32 bit.
The server sharing the printer is a mix of SBS 2008 and Server Standard 2008 64 bit
There are numerous other clients running exactly the same printers and drivers who don't have this problem.  Two Desktops have this problem though.

The printers used are:
On the SBS server:
Brother HL-2270DW series, running on wireless
Kyocera FS-C5300DN
On the server Standard:
Samsung SCX-6345N

The reason the samsung printer is seperate to the rest is because as soon as you start printing through it on the SBS server documents gets stuck in the printer queues.

All the printers are running the latest drivers of the website, except for the samsung which is running a PCL5 driver.
The samsung is running this driver because it seems to be the most stable of the lot including(PCL6, and Universal)

 Deadlocked
Any help appreciated.
Thanks
Wihan
0
Comment
Question by:EHWtech
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
13 Comments
 
LVL 66

Expert Comment

by:johnb6767
ID: 36520945
On the two desktops, might just be a driver corrupting the spooler..... I would remove ALL printers and their corresponding drivers, then start from scratch.....

Windows 7 Steps (this is my standard response for spooler problems)....

Remove all physical printers.

Once the printer(s) is deleted, go to start>, and type CMD (Right Click, and "Run As Administrator"

net stop spooler
net start spooler

Click Start, and type "Print Management">Print Servers>Local>Drivers>Rt Click a driver and select "Remove Driver Package", and remove them all.....

Then try and reinstall the network/local printers
0
 

Author Comment

by:EHWtech
ID: 36520998
Hi Johnb6767

I have tried this, but not exactly the way you said.
The weird thing is that no matter if I delete all the printer queues, or physical printers.
The Print Management snap in always says that the driver is in use.

The only way to remove the printer is to restart the spooler and then within 1-4 seconds from it starting, remove the driver, then it seems to remove it.

Not sure if this is the cause to the problem, or related.
Any ideas how to get past that?

Cheers
Wihan
0
 
LVL 8

Expert Comment

by:Sushant Gulati
ID: 36521008
Make sure the Print Spooler service is running from the Services Console...

1. Download Debugging tools for Windows

http://msdl.microsoft.com/download/symbols/debuggers/dbg_x86_6.11.1.404.msi -- Install this tool...

2. Open elevated command prompt, go to C:\Progam Files\Debugging tools for windows --- Copy and paste this command

cscript adplus.vbs -hang -pn spoolsv.exe -o c:\adplus_spooler_deadlock


This has to be done at the time when the problem has started or the symptoms you see...

Or easiest way is .....


1. Download the process explorer tool on your machine

http://download.sysinternals.com/Files/ProcessExplorer.zip

2. Download Debugging tools for Windows

3. Extract the Process Explorer tool.. Run the Procexp.exe .. Under Options - Configure Symbols
DBGhelp.dll Path
Under C:\Progam Files\Debugging tools for windows\Dbghelp.DLL
Symbols Path:
SRV*c:\symbols*http://msdl.microsoft.com/download/symbols
OK


In both the cases go to the dump file location and zip the dump and upload it. I will see what is in there causing this. This is some driver is causing this.

Q: If this is only with 2 machines then, did you check?

@@ What happens if remove the Samsung Printer driver and delete the Samsung printer from this machine? -- TEST PRINT
@@ Same goes with the Brother? -- TEST PRINT
&
@@ Same goes with KYOCERA? -- TEST PRINT

Add them one by one in the respective way these have been removed.... TEST PRINT...

This is just because we need to rule the driver which is causing this issue.

Hope this helps..!!

Good Luck...
~SG~
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:EHWtech
ID: 36521152
Sounds great, I will wait for the problem to re occur and then install those utilities.
Thanks for the help.
0
 
LVL 8

Expert Comment

by:Sushant Gulati
ID: 36522600
Keep yourself ready with the download and installation of the tools so that you can dump the process at the time of the issue. That's how I would do...

Good Luck..!!
~SG~
0
 

Author Comment

by:EHWtech
ID: 36539816
Ok,
This morning it have done it again.
I hope i have done this correctly
I followed your instructions.
Not sure about the symbols path as it looks like a URL and a folder that doesn't exist c:\symbols
I just copied it and continued anyway. (it did accept it)

I then went to spoolersv.exe and created a full dump and mini dump.
The full dump is 57MB so not going to upload it unless you need it i can put it on FTP.
I have attached the minidump though
Thanks for your help, much appreciated
Wihan
 spoolsv-mini.DMP
0
 

Author Comment

by:EHWtech
ID: 36539835
by the way the problem with the process of elimination you suggested in your post is that it only does this every 2 -3 days at some random time.
So I cannot let the user run without their printer for a week to see if the problem goes away.
When it is in deadlock, they can't print to any printers at all, they don't even show up in device and printers.

Printing to all the printers work fine for 2 -3 days then this happens, it doesn't just freeze once you print to a specific printer.
0
 
LVL 8

Expert Comment

by:Sushant Gulati
ID: 36544673
You should upload the dump over http://uploading.com after zipping it. In the MiniDump I dont think it must be so useful though I will look into it and check that and update you on this.

The answer to your query..

There is no way you can print without running the Spoolsv.exe because that's the process called by the Spooler service. Even to have the Printer and Device console open the System must be running with the Print Spooler service. I would have made the user understand to right click in the Process Explorer and Create a Full Dump of the process at the time of DeadLock Situation.

Then this is a Print Spooler issue. I would also do this..COPY AND PASTE THE COMMAND
Cmd
C:\Program Files\Debugging Tools for Windows\> gflags.exe /p /enable Spoolsv.exe /full /decommit

Restart the Spooler Service and monitor it. Start the Process Explorer to keep this under monitor and take the dump at the time of the issue.

Let me know if you still have this confusion..

Good Luck..!!
~SG~

0
 
LVL 8

Accepted Solution

by:
Sushant Gulati earned 400 total points
ID: 36545051
And rename this DLL or update it. It's for Brother..

0:000> lmvm BRUIM10A
start    end        module name
70010000 700ee000   BRUIM10A T (no symbols)          
    Loaded symbol image file: BRUIM10A.DLL
    Image path: C:\Windows\System32\spool\drivers\w32x86\3\BRUIM10A.DLL
    Image name: BRUIM10A.DLL
    Timestamp:        Fri Jun 11 07:20:00 2010 (4C119648)

Its loading into the Stack on Thread # 2....

Good Luck..!!
~SG~
0
 
LVL 8

Expert Comment

by:Sushant Gulati
ID: 36569137
Any news bro???

~SG~
0
 
LVL 1

Assisted Solution

by:PanopticComputerServices
PanopticComputerServices earned 100 total points
ID: 36901890
I was stumped by this issue for weeks until today!

New Win7 x64 deployment for customer was hanging daily while trying to print from any application.

The solution was to install the Brother Universal PCL5e/6 Driver that they recommend anyway for network printers. So far so good on this end.
http://welcome.solutions.brother.com/bsc/public/us/us/en/dlf/dlf/000000/004600/dlf004694.html?reg=us&c=us&lang=en&prod=hl2270dw_all&type2=82&os=92&flang=4&dlid=dlf004694

This does not seem to be a well known issue yet. However, after isolating the issue I found this post confirming this is a widespread problem with this driver.
http://forums.citrix.com/thread.jspa?threadID=288591&tstart=0#1564127

0
 

Author Closing Comment

by:EHWtech
ID: 37029492
Thanks for your help.  
Seems the issue could not be resolved as the computer in question has had a failed main board since then and have been replaced.

I have not been able to try the solutions you proposed as i have been away, hence the delay.

Thanks again for your help.
I have distributed points between 2 people.
Thanks
0

Featured Post

Enroll in June's Course of the Month

June’s Course of the Month is now available! Experts Exchange’s Premium Members, Team Accounts, and Qualified Experts have access to a complimentary course each month as part of their membership—an extra way to sharpen your skills and increase training.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

While working, an annoying popup showing below will come and we cannot cancel or close it form the screen. The error message will come again and again.
There are many software programs on offer that will claim to magically speed up your computer. The best advice I can give you is to avoid them like the plague, because they will often cause far more problems than they solve. Try some of these "do it…
The viewer will learn how to successfully download and install the SARDU utility on Windows 8, without downloading adware.
This video Micro Tutorial shows how to password-protect PDF files with free software. Many software products can do this, such as Adobe Acrobat (but not Adobe Reader), Nuance PaperPort, and Nuance Power PDF, but they are not free products. This vide…

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question