[Webinar] Streamline your web hosting managementRegister Today

  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 777
  • Last Modified:

SRV record _http._tcp. not working

I have a networking device with a web interface serving HTTPS pages. There's an A record pointing to it (mydomain.com points to that device). But when people visit the domain without https (ordinary http), I want them to be directed to another server (in this case server2.mydomain.com).

Now I've created the following SRV record: _http._tcp.mydomain.com.  0  100 80 server2.mydomain.com.

When performing a lookup, it properly shows the entry. But whenever someone enters mydomain.com in their browser (and even http://mydomain.com or mydomain.com:80), they get directed to the HTTPS device which is referred to in the A record.

Did I forget to configure something? Or are A records always chosen instead of SRV records if they exist?
1 Solution
SRV records in web browsers has very limited support mainly because there is no standard on how they should work when people specify a specific port on the URL for example/
I assume the 'networking device' is not a standard web server so you cant configure it to redirect traffic sent to its http address to the https equivalent.
Your best bet would be to have the DNS point to a web server which just redirects all traffic to the (different) https address that the device listens to.

Another way would be to have a proxy server which just forwards all https traffic onto the network device while forwarding http traffic elsewhere to something which just issues a redirect. This is a bit more messy but at least people always see the same dns name.
RHochstenbachAuthor Commented:
Thanks for the information, I think I'll consider a proxy server as an option.

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now