Access Permissions reading Sockets from a C# application

Posted on 2011-09-12
Medium Priority
Last Modified: 2012-06-27
I've written a threaded GPRS receiver in C# (at the moment as a Windows Forms application, for debugging purposes).

When I run it on the server (Windows Vista), through either VS or just running the .exe, I get the error:

"An attempt was made to access a socket in a way forbidden by its access permissions".

The application is residing in C:\Program files\GPRSReceiver\
I've tried right clicking and tried "Running as Administrator"

Any ideas what else do I need to do?

Question by:Spike_66
  • 3
  • 2
LVL 22

Expert Comment

by:Ivo Stoykov
ID: 36522611
move it to your profile or another disk. C: has lots of restrictions


Ivo Stoykov

Author Comment

ID: 36522702
Thanks for that- but moving it to suggested locations hasn't helped.


Author Comment

ID: 36522795
I've just found out that there is a web site running on the server.
The server is accessed via IP addrress rather than Domain name.

I'm assuming that there is going to be a conflict between the web site and thie GPRS monitor both listening on port 80. Am I right?

LVL 22

Accepted Solution

Ivo Stoykov earned 2000 total points
ID: 36524252
perhaps. principle is one service - one port

Author Comment

ID: 36528266
I have tested with other ports on this server, and although they aren't receiving anything, there wasn't any permissions error.

Thanks anyway.

Featured Post

Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

When you see single cell contains number and text, and you have to get any date out of it seems like cracking our heads.
High user turnover can cause old/redundant user data to consume valuable space. UserResourceCleanup was developed to address this by automatically deleting user folders when the user account is deleted.
Six Sigma Control Plans
Introduction to Processes

607 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question