Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 826
  • Last Modified:

Network switches slow down connection

Hi guys,

I'm having an issue where whenever I connect a switch between the wall and the machine, network speeds are significantly slower. It almost seems like they are reverting to 1Mbps speeds. At first I thought it was the switches themselves (they are 10/100 Netgear FS108's) but I got different ones and the result is the same. Plugging directly into the wall (and by wall I mean a bunch of Cisco Catalyst switches) works fine. I tried changing the NIC settings to auto-negotiate and 100Mbps Full Duplex, but it didn't seem to have made a difference. These are all unmanaged switches and the activity lights on them show them as being in 100Mbps mode.

Speed tests show only download speed affected. I also tried different ethernet cables.

Would anyone know why introducing the switches degrades network performance for all machines connected to that switch?
0
Titlevest
Asked:
Titlevest
3 Solutions
 
carlmdCommented:
You could try manually setting the baud rate AND the duplex on both ends. If two connected switches are set to auto negotiate and get the wrong duplex setting, you can see what you are describing.
0
 
pjamCommented:
Please forgive me if i misread or understand.  It sounds like you have a Netgear Hub between you and a cisco Switch.  That IMHO is never a good idea as it can cause looping.
0
 
TitlevestAuthor Commented:
Just to clarify, the current setup is as follows:

NetGear 8 port desktop switch FS108->wall jack (patch panel->Cisco Catalyst 48-port switch)

This is the desktop switch we are using (we have multiple and all give the same result): http://www.amazon.com/NETGEAR-ProSafe-8-Port-Desktop-Switch/dp/B00002EQCS/ref=sr_1_1?ie=UTF8&qid=1315844895&sr=8-1

We bought different brands of switches to see if it was a Netgear issue but they all yield the same result. One interesting bit of information is that we tried hooking up an old D-Link 5 port switch and it worked perfectly. There were no slowdowns whatsoever.

@pjam
It's definitely a switch, not a hub.

@carlmd
I'll check it out although i'm not hopeful
0
New Tabletop Appliances Blow Competitors Away!

WatchGuard’s new T15, T35 and T55 tabletop UTMs provide the highest-performing security inspection in their class, allowing users at small offices, home offices and distributed enterprises to experience blazing-fast Internet speeds without sacrificing enterprise-grade security.

 
sameer_dubeyCommented:
I would test with a 8-port switch that does not support "auto uplink". Just to rule out any issue in two switches working on "auto uplink".

There may be a loose connection in your wall port (patch panel). I would check that as well.
0
 
sloden94Commented:
One thing to check would be your port configuration on the catalyst. Make sure its on auto instead of full duplex.
0
 
eeRootCommented:
Can you check the config on the Cisco switch?  Smart switches often have settings to limit the total number of clients allowed on a port and the speed as well.
0
 
TitlevestAuthor Commented:
@sloden94:
This is what it says on for all ports:

 speed 100
 duplex full
 spanning-tree portfast

I'll try changing it to auto and see if it makes a difference.

@eeRoot:
What would such a a limit on the number of clients show up as in the config file?
0
 
eeRootCommented:
Those would be "switchport port-security" commands.
0
 
TitlevestAuthor Commented:
I forced 100Mbps and full duplex and that fixed it. Thank you all for your help!
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now