Solved

Using Parallels frequently blocks keyboard in host

Posted on 2011-09-12
17
698 Views
Last Modified: 2012-05-12
I am evaluating Parallels with Windows XP VMs. Very frequently, I find that I am unable to use the keyboard in the Mac host. The keyboard focus is simply locked into the VM.

There is a message at the bottom of some Parallels screens about Ctl-Alt release the mouse and  keyboard (similar to in VMWare Fusion), but I have not been able to get such a key sequence to work to restore the focus to the host. This forces me to log out of the host.

I cannot find anything in the Parallels documentation either.

What is the solution?
0
Comment
Question by:jasimon9
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 7
17 Comments
 
LVL 2

Expert Comment

by:cyclechip
ID: 36523235
Installing Parallels Tools will automatically move the focus of the mouse and keyboard between the virtual machine and your Mac.

In the Parallels menu, select Action > Install PT

Then go into the virtual machine and run the program. If it doesn't auto-start, look in your virtual CD ROM drive for an executable.
0
 

Author Comment

by:jasimon9
ID: 36523938
Parallels Tools has always been installed, and has been by default since I installed Parallels for the first time a few days ago.

You don't understand my issue. I did not say "keyboard does not work". I said that "very frequently keyboard does not work". To be very precise, here is a better restatement of the issue:

I am using Parallels and able to use the keyboard and mouse in both the guest and host, as expected. That is, both keyboard and mouse work as expected in both. Then, very frequently as it turns out, after switching back to the host, the keyboard will NOT work. The mouse DOES work in the host. The keyboard continues to work in the guest. The only problem is that the keyboard focus cannot be switched back to the host.

I am feeling this might be a lack of familiarity with Parallels, and am looking for that "simple solution" that restores the keyboard focus to the host. But pressing Ctrl-Alt does not work to "release the keyboard" as shown in the screen shot.

When this happens (already 3 times by 11am this morning), I only way I have found to restore the keyboard focus to the host is to shut down Parallels, log out and re-login.

Needless to say, this workaround is unacceptable.

Parallels message showing supposedly how to release the keyboard.
0
 
LVL 2

Expert Comment

by:cyclechip
ID: 36524110
Sounds like you've found a bug as this is not normal behavior. Since you are new to Parallels I'm not sure what you mean when you explain that the keyboard and mouse work "as expected", but to clarify, when PT is working correctly there should never be a need to press the ctrl-alt key combo. PT is supposed to automatically switch your keyboard and mouse between each machine by following the movement of your mouse. If it's not doing that, try uninstalling and reinstalling PT within your XP guest.
0
Put Machine Learning to Work--Protect Your Clients

Machine learning means Smarter Cybersecurity™ Solutions.
As technology continues to advance, managing and analyzing massive data sets just can’t be accomplished by humans alone. It requires huge amounts of memory and storage, as well as the high-speed power of the cloud.

 

Author Comment

by:jasimon9
ID: 36525434
Seems I have already "reinstalled" it at least once.

In any case, trying to follow the instructions to remove Parallels Tools does not quite work. From the Parallels Tools help, here are the steps:

Remove Parallels Tools
To remove Parallels Tools from Mac OS X guest operating systems:

Start the Mac OS X guest operating system.
When it boots up, choose Virtual Machine > Reinstall Parallels Tools. The Parallels Tools icon appears on the Mac OS X desktop.
Double-click the Parallels Tools icon, double-click Uninstall Parallels Tools and follow the assistant's instructions.

The problem is that when I click on Reinstall Parallels Tools, no icon appears. Instead it just goes ahead with the reinstall. Perhaps this is equivalent, but in many cases with other software it is not, and a good clean uninstall is required first.

Bottom line is that I don't know if I am following your recommendation properly.
0
 
LVL 2

Expert Comment

by:cyclechip
ID: 36525469
From your screenshot I can see that your host OS is Mac, and the guest is Windows XP. Therefore you are following the wrong instructions. Follow the steps for removing the tools from within Windows. i.e.: open Add/Remove Programs and uninstall it. It may require a reboot each time the tools are added or removed. Don't skip this step!
0
 

Author Comment

by:jasimon9
ID: 36525549
ok, I will follow your latest instructions and try again.

But here is what happened when I did the "Reinstall Parallel Tools". The process completed and Windows apparently rebooted. But when I came back up, it actually caused the problem! That is, no keyboard in the host.

Not only that, but this time and in the previous times, exiting the VM and exiting Parallels still leaves the Mac without a keyboard, even though Parallels is no longer running! Forced to logout/login to the Mac once again.

As an aside, I am wondering why the instructions provided within Parallels are not apparently correct for the environment.
0
 
LVL 2

Expert Comment

by:cyclechip
ID: 36525581
I can't see why the instructions would be incorrect unless somehow Parallels thinks your guest OS is Mac and it tailored the instructions to what it believes you have installed. When you created the virtual machine was there an option to select the guest OS? If so, is it possible that you chose Mac? That's the only way I'd think it would present you with only the incorrect instructions for your particular environment.
Here's a link to an older version of the instructions that covers all environments:
http://download.parallels.com/desktop/v5/docs/en/Parallels_Desktop_Users_Guide/23651.htm
0
 

Author Comment

by:jasimon9
ID: 36525583
Aha, I might have found something!

Turns out VMWare Tools is still installed in this VM (because it was converted from VMWare). Seems to me this could be a conflict, so I am also going to remove VMWare Tools, and see what happens.

Also, as another aside, it seems that the conversion program should at least recommend that VMWare Tools should be removed.

Will post the results here.
0
 
LVL 2

Expert Comment

by:cyclechip
ID: 36525591
yes absolutely move any VMware Tools packages! Sounds like you found the problem. Congrats!
0
 
LVL 2

Expert Comment

by:cyclechip
ID: 36525595
guess I can't edit my posts? That should read: "remove..."
0
 

Author Comment

by:jasimon9
ID: 36525805
Interestingly, during the reboot after uninstall of VMWare Tools was happening I noticed that I lot the keyboard again (I was trying to refresh this page to see if you had posted anything more, which you had!)

However, I pressed Ctrl-Alt, and this time it freed up the keyboard.

Now doing the final (I hope!) reinstall of Parallels Tools.
0
 

Author Comment

by:jasimon9
ID: 36525808
*lost* as in ".. lost the keyboard". See I can do it too.
0
 

Author Comment

by:jasimon9
ID: 36530393
The probelm continues. That is, after working normally for a while, after some time, the keyboard does not work in the hos, and the only workaround appears to be to logout and re-login to the Mac.

If this cannot be fixed, my short experiment with Parallels will be declared a failure, as it turns out that "it does not work." Too bad, because in most things, "it just works", and better than VMWare.

Oddly, after the "uninstall/reinstall" of Parallel tools, the functioning of the VPM from withint the VM has been clobbered. That is, after first converting the VM from VMWare to Parallels, all the VPN functionality worked. But after the uninstall/reinstall, it did not. I am not sure why this has occurred. I was able to achieve a partial workaround by adding entries to the Windows hosts file.

In any case, I will be forced to revert to VMWare unless I can get this fixed. From what I have read, there does not seem to be much tech support available from Parallels. At least I see a lot of complaints.

So I called Parallels, and I am currently talking to a technician. I'll post the results later.
0
 
LVL 2

Expert Comment

by:cyclechip
ID: 36530419
I suspect Parallels might have difficulty fully supporting a virtual machine that was created using another vendor's Physical-to-Virtual (P2V) tool. Good luck!
0
 

Author Comment

by:jasimon9
ID: 36532116
I called Parallels tech support and they guided me through a very lengthy and detailed set of steps. Not sure yet if it has fixed it because it takes some time to see if it recurs.

The short version of what we did was to uninstall the Parallels keyboard dirver, uninstall Parallel Tools, Uninstall Parallels, reinstall Parallels, open the VM from the file on disk, reinstall Parallel Tools by clicking on the installation file on disk. Durning this process he had me check a lot of settings, but we did not change any.

So I don't know if this is really a fix of a condition; rather seems like just a "clean reinstall" procedure, which is a brute force attempt in the hopes that the problem does not recur.

He did not say anything about having an issue with a converted VM. He said that should not cause any issues.
0
 

Accepted Solution

by:
jasimon9 earned 0 total points
ID: 36564078
The problem recurred after the Parallels clean reinstall.

Turns out the problem is not Parallels at all, but OS X Spaces. The keyboard is lost immediately after switching to a different Space, but the Spaces switch indicator stays on the screen, and the keyboard is locked. This problem is discussed on some Apple Forums. The easiest workaround is to Press SHFT-CTRL-EJECT, which puts the screen to sleep. Then press the key that you use to wake up the screen (for me pressing on the mouse scroll wheel), and the keyboard is released.

This is the best answer to the solution on Snow Leopard.

In the meantime, I have upgraded to Lion, which uses Mission Control instead of Spaces, so I would suspect this issue will probably not occur.
0
 

Author Closing Comment

by:jasimon9
ID: 36591861
Parallels not a fault at all; instead a bug in Snow Leopard. Workaround given in my comment.
0

Featured Post

Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We could spend the next millennium discussing the differences of the Mac and Windows platforms. The next century will continue to have fanatics on both side of the equation and neither side will win the war. However, that’s not why we are here. W…
This article shows how to use a free utility called 'Parkdale' to easily test the performance and benchmark any Hard Drive(s) installed in your computer. We also look at RAM Disks and their speed comparisons.
Teach the user how to use vSphere Update Manager to update the VMware Tools and virtual machine hardware version Open vSphere Client: Review manual processes for updating VMware Tools and virtual hardware versions: Create a new baseline group in vSp…
This video shows you how to use a vSphere client to connect to your ESX host as the root user. Demonstrates the basic connection of bypassing certification set up. Demonstrates how to access the traditional view to begin managing your virtual mac…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question