PowerEdge 2850 Boot Issue

Experts,

Hi, I am having an problem with a Dell PowerEdge 2850.  Recently this server indicated it was experiencing a processor error so I have replaced that component.  Somewhere along the way however we seem to have lost the RAID settings.  The system was utilizing 2 drives in a Raid 1 set.  I believe the drives are SCSI.

I think that I just need to somehow re-initialize the Raid because I cannot get the system to boot to Windows.  The interesting thing is that the Server 2003 splash screen comes up briefly but then the system reboots itself.

Please see this video of the boot sequence:  http://www.youtube.com/watch?v=lJOr1uC64uQ

Thank you!

Jason
copyfaxAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

chakkoCommented:
There is not any hardware RAID and the drives are connected to the normal SCSI controller.

So, you probably have a Software RAID from Windows.

You should try a safe mode boot and also the Last Known Good Configuration options.

Before the Windows screen shows up hit the F8 key a few times and then you will see the boot options menu.

Try those first.


0
jimbecherCommented:
  Ouch! Have you tried booting to "Last Known Good Configuration" by tapping on the F8 key as the server is booting? It almost looks like a driver issue. Is the processor the only thing that got replaced?

   Other then that I would try pressing the Ctrl-A at boot (when it scans the LSI controller) and see what it tells you about your Raid 1 being intact...

0
copyfaxAuthor Commented:
Thank you for the quick responses!

I have attempted to invoke the "Last Know Good Conifg" by pressing F8 while the system is booting - however despite repeated attempts it does not seem to do anything.  Any other tips on what I can try to gain F8 functionality?

Also, I have looked in the LSI controller menu by pressing Ctrl - A. It seems to show both drives but there is no mention anywhere that I can find about any RAID settings at all.  I can shoot a video of this section if that would help.

Thanks again,

Jason
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

chakkoCommented:
you don't have a hardware based RAID.

Did you try the Safe Mode boot?  it will list the drivers as they are being initialized.  Watch the screen and try to see the last one that appears before the reboot happens.  just try to remember the filename part.  It may help track down the problem.

Do you have a Windows 2003 install CD?

You should boot the CD and go into the Recovery Console, it will give you a Command window and you can take a look if your C: and disk is there, also would suggest you to do a chkdsk on the c: drive too.


Also, you may need the CD to do a repair installation of Windows 2003 as a last resort.
0
jimbecherCommented:
Dell's are ugly about the F8. Just the fact that up get up the Windows 2003 screen should mean that the F8 is doable. Tap on it repeatedly as soon as the "press ctrl-e to enter BMC" shows up. It is tricky because of the way Dell invokes that BMC setup but it should be doable.

I agree with chakko. If raid is involved it does not appear to be done via the LSI controller. It looks like the LSI controller just thinks there are two, single drives in the system. If you are indeed running a software Raid 1 it injects a whole different set of circumstances in to the ballgame. Software raid has never been a real good idea and can be brutal to get going again.
0
chakkoCommented:
Did you get the boot options menu?

Hit the F8 key many times after you see the BMC thing message on the boot process.  The Windows starts to load after that BMC message appears.  Hit the F8 key many times repeatedly, until you get the Boot menu to appear.  You have to hit F8 before you see any Windows screen.
0
PowerEdgeTechIT ConsultantCommented:
If your BIOS settings got cleared, then the RAID controller would currently be turned OFF.  The PERC 4e/Di (LSI controller) will only be available during POST (CTRL-M) when turned on in the BIOS.  How sure are you that you had a hardware RAID array?  Your disks are 73GB ... what kind of storage space did Windows report?  How many disks shown in My Computer/Disk Management?
0
copyfaxAuthor Commented:
Well, for some reason I simply cannot get F8 to work.  I have some new information though that may be helpful.

During the course of troubleshooting the original processor error another administrator removed and re-seated some additional modules - including the 256MB memory stick shown in the embedded photo.  Could that have resulted in the BIOS being cleared?  Also does the photo indicate that we have a PERC installed?

I cannot swear to it but I really believe this system was running a hardware PERC RAID 1.  I do have all the original disks that came with the server.

Thank you very much for the assistance!!!


 PowerEdge 2850 Internal
0
PowerEdgeTechIT ConsultantCommented:
Chakko should not have been so sure of himself and lead you down the wrong road.  Yes, you have the RAID Key, Memory, and Battery, as outlined in the picture below, so your system is capable of hardware RAID.  However, reseating any of these parts would not have cleared/reset the BIOS.
RAID Kit.
There is no harm in doing this, but boot to BIOS Setup (F2), Integrated Devices, and set Embedded RAID to RAID Enabled (make sure it is on on both channels, unless you have a tape drive installed, if tape then just RAID on the first channel).  When you boot you will get a scary warning about data loss - ignore it and accept the change - no data loss will occur because of this.  If you see a message about a "mismatch", then enter CTRL-M, Configure, View/Add, (Disk View, if prompted) and let us know what exactly is shown there.  Otherwise, you can simply let Windows attempt to load.  If it does, great.  If not, then you are still at the point that you may need to do a Repair ... you just need to decide if you want to try to repair the SCSI version or the RAID version.  How much storage and how many disks did Windows have?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
copyfaxAuthor Commented:
PowerEdgeTech, you got it going on.  I changed that setting to RAID and she boots right up into Windows.

I had actually gotten to that point yesterday and made the change - however I got those warnings about data loss when the system booted and I bailed.  Seems a little bit unusual that they would make you confirm FOUR times that you will experience data loss - and then you don't!

Thank you everyone for the assistance!  EE rocks!

Jason
0
PowerEdgeTechIT ConsultantCommented:
Glad it worked for you.

It can cause data loss, depending on what disk-altering functions you perform on it after the switch, which is why it wants you to make sure that you don't change it on accident ... it asks you for each channel, then confirms your choice for each channel.  You weren't doing anything in this case to alter the disks ... just testing the disks' contents.

Take care.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Hardware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.